Sabnzbd+ randomly quitting on OSX

Report & discuss bugs found in SABnzbd

Re: Sabnzbd+ randomly quitting on OSX

Postby shypike » February 27th, 2012, 6:04 pm

Come again? It must have had use_pickle.
Otherwise I'm not sure you got the right one.
What does the Config main page show?
It should something like this:
Code: Select all
Config file = /Users/user/Library/Application Data/SABnzbd/sabnzbd.ini
User avatar
shypike
Administrator
Administrator
 
Posts: 18039
Joined: January 18th, 2008, 1:49 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » February 27th, 2012, 6:10 pm

shypike wrote:Come again? It must have had use_pickle.
Otherwise I'm not sure you got the right one.
What does the Config main page show?
It should something like this:
Code: Select all
Config file = /Users/user/Library/Application Data/SABnzbd/sabnzbd.ini


Yup, shows exactly that

Code: Select all
Configfile: /Users/trooper/Library/Application Support/SABnzbd/sabnzbd.ini


no use_pickle in the ini
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » February 27th, 2012, 6:35 pm

I downloaded 0.6.15 from here
http://sourceforge.net/projects/sabnzbdplus/files/
and installed it the way I described.
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » February 28th, 2012, 3:26 pm

Crashed again today, adding in use_pickle made no difference.
When I restart it, it always picks up where it left off, and is always in the process of extracting a download.
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby shypike » February 28th, 2012, 3:38 pm

trooper wrote:and is always in the process of extracting a download.


That's odd.
I am tempted to say that unrar is the cause, but I don't think that's possible.
SABnzbd has hardly any overhead watching unrar run, and an unrar crash
will not cause SABnzbd to crash. At least not to my knowledge and experience.
The only other work-around I can think of is to block downloads during post-processing
(option in Config->Switches). It should not be needed for your beefy system.

I'm still not happy about what you said about "use_pickle" not being present in the INI file.
That's an indication that you're not using 0.6.15 or are editing the wrong INI file.
The latter you could test by entering the "use_pickle" line twice.
This would cause SABnzbd to throw a panic page at startup.

I'll setup an endurance test during the weekend on the miniMac (don't have a big one).
You are using Lion, I assume?

BTW: which speed (MBytes/sec) do you get?
User avatar
shypike
Administrator
Administrator
 
Posts: 18039
Joined: January 18th, 2008, 1:49 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » February 28th, 2012, 4:13 pm

Download speed? I cap it at 600Kb/s mainly, but I let it run uncapped overnight and it peaks at 800Kb/s, which is commensurate with my 7.5mb line.
Actually, I haven't tested leaving the cap on overnight, i'll give that a go next. Maybe running uncapped is causing issues while trying to extract, for some reason.

I don't know what to tell you about the ini file! I'm changing the ini file referenced in the config page in sab, i'm downloading the install from the sourceforge page, i'm shutting down sab before copying the app into the application directory. I'm not sure what else I could be doing to not have the correct ini file?

I put use_pickle into the ini twice and sab beachballed on startup and I couldn't even get to the web page to see anything. I took out the duplicated use_pickle line and it works fine again. So I guess that proves i'm on 0.6.15 code? I'm just not getting the ini file installed for some reason.
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » February 28th, 2012, 4:16 pm

Oh and yes OSX Lion 10.7.3
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby shypike » February 28th, 2012, 4:51 pm

trooper wrote:Download speed? I cap it at 600Kb/s mainly
I put use_pickle into the ini twice and sab beachballed on startup and I couldn't even get to the web page to see anything. I took out the duplicated use_pickle line and it works fine again. So I guess that proves i'm on 0.6.15 code? I'm just not getting the ini file installed for some reason.


Is that 600 Mbits or MBytes?

It looks like you did pick the right INI file.
Only it isn't supposed to beachball, but show the panic message in the browser.
I see now that launching the browser doesn't succeed in this particular situation.
Other problem, never mind.
So if says it's 0.6.15, then it must be.
So neither yEnc nor pickle seem to be causing your issue.
Beats me what does do it.
Normally I'd say, dodgy hardware, but the prime exposer of bad RAM is the par2 program.
Par2 doesn't crash on you as far as I can tell, plus a failing par2 won't crash SABnzbd either.
User avatar
shypike
Administrator
Administrator
 
Posts: 18039
Joined: January 18th, 2008, 1:49 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » February 28th, 2012, 5:33 pm

600 KiloBytes/s or 0.6 MegaBytes/s or 5 Megabits/s :)
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby shypike » February 28th, 2012, 5:50 pm

That's definitely not too fast.
Any old system should be able to do that.
User avatar
shypike
Administrator
Administrator
 
Posts: 18039
Joined: January 18th, 2008, 1:49 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » February 28th, 2012, 7:10 pm

It only ever crashes overnight, never during the day. I'm running with the 600Kb cap tonight, rather than leaving it uncapped and see if that makes a difference.
I'm also running memtest to check out my hardware.
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » March 1st, 2012, 2:34 pm

No luck, came back after a night away and it wasn't running anymore. This time there was nothing in the queue and nothing to process when I started it back up.
Memtest came back with everything fine, no errors.

Last entries in the log:
Code: Select all
2012-03-01 06:02:48,008::INFO::[postproc:83] Saving postproc queue
2012-03-01 06:02:48,009::INFO::[__init__:846] Saving data for postproc1.sab in /Users/trooper/Library/Application Support/SABnzbd/admin/postproc1.sab
2012-03-01 06:02:48,009::INFO::[downloader:229] Post-processing finished, resuming download
2012-03-01 06:02:51,010::INFO::[nzbqueue:170] Saving queue
2012-03-01 06:02:51,011::INFO::[__init__:846] Saving data for queue9.sab in /Users/trooper/Library/Application Support/SABnzbd/admin/queue9.sab
2012-03-01 06:02:51,011::INFO::[__init__:846] Saving data for totals9.sab in /Users/trooper/Library/Application Support/SABnzbd/admin/totals9.sab
2012-03-01 06:02:51,012::INFO::[__init__:846] Saving data for rss_data.sab in /Users/trooper/Library/Application Support/SABnzbd/admin/rss_data.sab
2012-03-01 06:02:51,012::INFO::[__init__:846] Saving data for bookmarks.sab in /Users/trooper/Library/Application Support/SABnzbd/admin/bookmarks.sab
2012-03-01 06:02:51,012::INFO::[__init__:846] Saving data for watched_data.sab in /Users/trooper/Library/Application Support/SABnzbd/admin/watched_data.sab
2012-03-01 06:02:51,013::INFO::[postproc:83] Saving postproc queue
2012-03-01 06:02:51,013::INFO::[__init__:846] Saving data for postproc1.sab in /Users/trooper/Library/Application Support/SABnzbd/admin/postproc1.sab
2012-03-01 06:02:51,013::INFO::[postproc:619] Queue has finished, launching: None (None)
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby shypike » March 1st, 2012, 3:06 pm

Is there anything in the OSX console log?
User avatar
shypike
Administrator
Administrator
 
Posts: 18039
Joined: January 18th, 2008, 1:49 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby trooper » March 1st, 2012, 3:32 pm

Nothing apart from iTunes bitching about not being able to find my iphone every 5 minutes :D
trooper
Newbie
Newbie
 
Posts: 41
Joined: September 27th, 2011, 1:59 pm

Re: Sabnzbd+ randomly quitting on OSX

Postby shypike » March 1st, 2012, 5:37 pm

I will test during the weekend, but cannot make any promises about results :(
User avatar
shypike
Administrator
Administrator
 
Posts: 18039
Joined: January 18th, 2008, 1:49 pm

PreviousNext

Return to Bug Reports