Search found 12 matches

by elmer91
November 3rd, 2010, 4:06 am
Forum: Bug Reports
Topic: High Memory Usage / Potential Memory Leaks Investigation Thread
Replies: 80
Views: 47585

Re: High Memory Usage / Potential Memory Leaks Investigation Thread

After few runs, memory used by SAB once downloading is completed:

run #1: 144M/101M
run #2: 160M/117M
run #3: 162M/119M
run #4: 181M/124M

There is definitely memory not released back to the system !
by elmer91
November 2nd, 2010, 12:17 pm
Forum: Bug Reports
Topic: High Memory Usage / Potential Memory Leaks Investigation Thread
Replies: 80
Views: 47585

Re: High Memory Usage / Potential Memory Leaks Investigation Thread

Still under testing, but it seems the reported behavior remains the same ! Test conditions: SAB 0.5.4 running on Linux 2.6.32 (python 2.5.5 + yenc) Cache: 128M, Quickcheck on One 4 GB nzb (91 rar files 50M each) downloaded several times (2 bad articles on this NZB) Only one job in queue at a time. F...
by elmer91
November 2nd, 2010, 10:33 am
Forum: Bug Reports
Topic: High Memory Usage / Potential Memory Leaks Investigation Thread
Replies: 80
Views: 47585

Re: High Memory Usage / Potential Memory Leaks Investigation Thread

I have made following things on my system (Synology NAS DS710+) 1) Compiled/installed tcmalloc buy my own 2) modified my SAB startup script to force python using tcmalloc:   export TCMALLOC_SKIP_SBRK=1   export LDPRELOAD="/opt/lib/libtcmalloc.so"   python ... SABnzbd.py I will report later results o...
by elmer91
March 26th, 2010, 11:31 am
Forum: Bug Reports
Topic: Release 0.5.0 - Reverse Proxy
Replies: 6
Views: 4932

Re: Release 0.5.0 - Reverse Proxy

I'm also using SAB behind a reverse proxy (nginx in my setup) in exactly same HTTP/HTTPS configuration as yours. It is working perfectly even with 0.5.0 version. The error message indicates there is no server (no port opened): - Check if SAB is running - Check SAB configuration (particularly web ser...
by elmer91
February 17th, 2010, 4:07 am
Forum: Bug Reports
Topic: Python 2.5.5 error SABnzbd 0.5RC
Replies: 12
Views: 8805

Re: Python 2.5.5 error SABnzbd 0.5RC

It was a problem of unicode (UCS4 vs UCS2) Latest Python package was build with UCS2, previous one was with UCS4. Other python modules (like pyOpenSSL were build with UCS4) I have filled a bug to the NSLU2 IPKG team. They are on the way to rebuild packages. New python 2.5.5 package should be built a...
by elmer91
February 15th, 2010, 10:03 am
Forum: Bug Reports
Topic: Python 2.5.5 error SABnzbd 0.5RC
Replies: 12
Views: 8805

Re: Python 2.5.5 error SABnzbd 0.5RC

I have now exactly the same problem...
Synology DS-207+ with IPKG running python 2.5

I have made a (stupid) upgrade to pyhton 2.5.5: same consequences, no more SSL !

Simple workaround (for the time being): use stunnel and configure SAB without SSL

It works well.
Elmer
by elmer91
February 12th, 2010, 8:56 am
Forum: Beta Releases
Topic: RC6 using a lot of ram and cpu
Replies: 14
Views: 4241

Re: RC6 using a lot of ram and cpu

I have noticed similar behavior while upgrading from 0.4.x series to 0.5.x (RC6 and previous since Beta1) SAB is running on a small embedded server (500 MHz ARM). It was enough to maintain a 1 Mb download/decoding smoothly with 0.4.x. Since 0.5.x upgrade, I notice periodic peaks and slow downs on do...
by elmer91
December 7th, 2009, 10:52 am
Forum: Beta Releases
Topic: [FIXED] Power saving issue with 0.5.0 beta 1
Replies: 6
Views: 1494

Re: Power saving issue with 0.5.0 beta 1

rss.py line 365:

            if type(feeds) != type({}):
                self.save()

Works !
by elmer91
December 7th, 2009, 10:18 am
Forum: Beta Releases
Topic: [FIXED] Power saving issue with 0.5.0 beta 1
Replies: 6
Views: 1494

Re: Power saving issue with 0.5.0 beta 1

I have found (at least) one thing: RSS module is saving its state periodically. In my config file, RSS checks is set to 15 mn I have no RSS feed set. In 0.4.x series, no problem. In 0.5.0 beta 1, RSS module is saving its state. I enabled debug logs, following lines appear every 15mn: 2009-12-07 15:4...
by elmer91
December 6th, 2009, 9:22 am
Forum: Beta Releases
Topic: [FIXED] Power saving issue with 0.5.0 beta 1
Replies: 6
Views: 1494

Re: Power saving issue with 0.5.0 beta 1

Thanks for your answer,

I have already checked logs.
Nothing is logged after SAB has finished downloading.

Logging is set to "Errors/warnings"

I will try to find a Linux tool able to monitor hard disk /file acces.
I will report any progress in this direction.

Thanks for your help.
by elmer91
December 6th, 2009, 8:38 am
Forum: Beta Releases
Topic: [FIXED] Power saving issue with 0.5.0 beta 1
Replies: 6
Views: 1494

[FIXED] Power saving issue with 0.5.0 beta 1

I was using SAB 0.4.x for a very long time. It was running on a small Linux server (Synology NAS) without any problem. I have configured the watched folder to a RAM drive / no RSS. When SABnzbd became idle, my hard drives correctly enter power save mode after a while. I recently tested 0.5.0 beta 1 ...