Free Newsservers

Feel free to talk about anything and everything in this board.
User avatar
Vyp3R
Newbie
Newbie
Posts: 40
Joined: May 25th, 2011, 11:53 pm
Location: Melbourne, Australia

Re: Free Newsservers

Post by Vyp3R » January 10th, 2013, 11:12 pm

I have the exact situation as Overburner. My default internet connection with my ISP doesn't have IPv6, but the extra connection through the SixXS tunnel does, so I get the same error he describes in the previous post.

Even though Test-IPv6.com says that I have a working IPv6 connection (apart from that error), most times I can't connect to IPv6 news servers. Such as reader.ipv6.xsnews.nl, newszilla6.xs4all.nl and weathergirl-ipv6.tele2.net with a 'failed to initialize' error. I used to be able to connect to those servers easily, now I am lucky if I do, if at all.

I tried changing the default DNS settings as Overburner, but with no success either. :(

User avatar
sander
Release Testers
Release Testers
Posts: 6713
Joined: January 22nd, 2008, 2:22 pm

Re: Free Newsservers

Post by sander » January 11th, 2013, 12:16 am

Vyp3R wrote:I have the exact situation as Overburner. My default internet connection with my ISP doesn't have IPv6, but the extra connection through the SixXS tunnel does, so I get the same error he describes in the previous post.

Even though Test-IPv6.com says that I have a working IPv6 connection (apart from that error), most times I can't connect to IPv6 news servers. Such as reader.ipv6.xsnews.nl, newszilla6.xs4all.nl and weathergirl-ipv6.tele2.net with a 'failed to initialize' error. I used to be able to connect to those servers easily, now I am lucky if I do, if at all.

I tried changing the default DNS settings as Overburner, but with no success either. :(
Overburner's error message is "No IPv6 address detected". Is that what you get on www.test-ipv6.com ?

User avatar
Vyp3R
Newbie
Newbie
Posts: 40
Joined: May 25th, 2011, 11:53 pm
Location: Melbourne, Australia

Re: Free Newsservers

Post by Vyp3R » January 11th, 2013, 9:05 am

sander wrote:Overburner's error message is "No IPv6 address detected". Is that what you get on http://www.test-ipv6.com ?
No just the final error...

Code: Select all

- Your IPv4 address on the public Internet appears to be (blah...)
- Your IPv6 address on the public Internet appears to be (blah...)
- Your IPv6 service appears to be: (blah...)
- Since you have IPv6, we are including a tab that shows how well you can reach other IPv6 sites.
- Good news! Your current configuration will continue to work as web sites enable IPv6.
- Your DNS server (possibly run by your ISP) appears to have no access to the IPv6 Internet, or is not configured to use it. This may in the future restrict your ability to reach IPv6-only sites.
And up to now I still have the "failed to initialize" error for reader.ipv6.xsnews.nl, newszilla6.xs4all.nl and weathergirl-ipv6.tele2.net. Yet they are all online.

User avatar
sander
Release Testers
Release Testers
Posts: 6713
Joined: January 22nd, 2008, 2:22 pm

Re: Free Newsservers

Post by sander » January 11th, 2013, 9:10 am

Ah, OK. On what platform do you run SABnzbd? Has it python installed?

Based on your answers I can define a few tests ...

User avatar
Vyp3R
Newbie
Newbie
Posts: 40
Joined: May 25th, 2011, 11:53 pm
Location: Melbourne, Australia

Re: Free Newsservers

Post by Vyp3R » January 11th, 2013, 10:43 pm

sander wrote:Ah, OK. On what platform do you run SABnzbd? Has it python installed?
It is the Windows installation (SABnzbd-0.7.9-win32-setup.exe) running on Windows 7 x64.

User avatar
sander
Release Testers
Release Testers
Posts: 6713
Joined: January 22nd, 2008, 2:22 pm

Re: Free Newsservers

Post by sander » January 12th, 2013, 1:33 am

Vyp3R wrote:
sander wrote:Ah, OK. On what platform do you run SABnzbd? Has it python installed?
It is the Windows installation (SABnzbd-0.7.9-win32-setup.exe) running on Windows 7 x64.
OK, let's check your DNS / name resolution like this:

Code: Select all

nslookup -type=aaaa newszilla6.xs4all.nl
nslookup -type=aaaa newszilla6.xs4all.nl 8.8.8.8
and post the output here.

Below is mine (from a WinXP I found)

Code: Select all

C:\>nslookup -type=aaaa newszilla6.xs4all.nl
Server:  router.home
Address:  192.168.1.254

Non-authoritative answer:
newszilla6.xs4all.nl    canonical name = newszilla.ipv6.xs4all.nl
newszilla.ipv6.xs4all.nl        AAAA IPv6 address = 2001:888:0:18::119

C:\>


C:\>nslookup -type=aaaa newszilla6.xs4all.nl 8.8.8.8
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
newszilla6.xs4all.nl    canonical name = newszilla.ipv6.xs4all.nl
newszilla.ipv6.xs4all.nl        AAAA IPv6 address = 2001:888:0:18::119

C:\>

User avatar
Vyp3R
Newbie
Newbie
Posts: 40
Joined: May 25th, 2011, 11:53 pm
Location: Melbourne, Australia

Re: Free Newsservers

Post by Vyp3R » January 12th, 2013, 8:13 pm

Code: Select all

C:\Users\Vyp3R>nslookup -type=aaaa newszilla6.xs4all.nl
Server:  dsldevice.lan
Address:  192.168.1.254

Non-authoritative answer:
Name:    newszilla.ipv6.xs4all.nl
Address:  2001:888:0:18::119
Aliases:  newszilla6.xs4all.nl

C:\Users\Vyp3R>nslookup -type=aaaa newszilla6.xs4all.nl 8.8.8.8
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    newszilla.ipv6.xs4all.nl
Address:  2001:888:0:18::119
Aliases:  newszilla6.xs4all.nl

User avatar
sander
Release Testers
Release Testers
Posts: 6713
Joined: January 22nd, 2008, 2:22 pm

Re: Free Newsservers

Post by sander » January 13th, 2013, 2:52 am

Ah ... so there is NO problem with your name resolving. Pity; I thought that was the cause. That means I have no idea what is causing this.

Just to be complete, here is the source code the gives the error message:

Code: Select all

                    if nw.connected:
                        self.__request_article(nw)
                    else:
                        try:
                            logging.info("%[email protected]%s:%s: Initiating connection",
                                              nw.thrdnum, server.host, server.port)
                            nw.init_connect(self.write_fds)
                        except:
                            logging.error(Ta('Failed to initialize %[email protected]%s:%s'),
                                              nw.thrdnum, server.host,
                                              server.port)
                            logging.info("Traceback: ", exc_info = True)
                            self.__reset_nw(nw, "failed to initialize")
I don't think this code is triggered by a DNS fail or a connection fail, so I'm out of ideas.

ziddey
Newbie
Newbie
Posts: 24
Joined: March 14th, 2008, 2:20 pm

Re: Free Newsservers

Post by ziddey » January 14th, 2013, 2:18 am

Gave newszilla6.xs4all.nl another go after a long time. Can't say about retention / reliability, but I was pulling down over 5MB/s. Not too shabby

User avatar
Vyp3R
Newbie
Newbie
Posts: 40
Joined: May 25th, 2011, 11:53 pm
Location: Melbourne, Australia

Re: Free Newsservers

Post by Vyp3R » January 14th, 2013, 5:03 am

sander wrote:I don't think this code is triggered by a DNS fail or a connection fail, so I'm out of ideas.
Yeah, it is a strange problem. Unless it lies with the SixXS tunnel?

User avatar
sander
Release Testers
Release Testers
Posts: 6713
Joined: January 22nd, 2008, 2:22 pm

Re: Free Newsservers

Post by sander » January 14th, 2013, 5:43 am

Vyp3R wrote:
sander wrote:I don't think this code is triggered by a DNS fail or a connection fail, so I'm out of ideas.
Yeah, it is a strange problem. Unless it lies with the SixXS tunnel?
Could very well be that Sixxs blocks Usenet traffic. Here's a test:

Code: Select all

telnet newszilla6.xs4all.nl 119
and report back what happens.

On Windows 7 you first have to install the telnet client; see http://technet.microsoft.com/en-us/libr ... s.10).aspx how.

User avatar
Vyp3R
Newbie
Newbie
Posts: 40
Joined: May 25th, 2011, 11:53 pm
Location: Melbourne, Australia

Re: Free Newsservers

Post by Vyp3R » January 14th, 2013, 10:48 pm

sander wrote:report back what happens.

Code: Select all

201 dreader37.news.xs4all.nl NNRP Service Ready - [email protected] (no posting).
Yet a test of the server in SABnzbd comes back with: Server quit during login sequence.

User avatar
sander
Release Testers
Release Testers
Posts: 6713
Joined: January 22nd, 2008, 2:22 pm

Re: Free Newsservers

Post by sander » January 15th, 2013, 1:30 am

Can you join this thread: http://forums.sabnzbd.org/viewtopic.php?f=3&t=12865 and continu there ... same error messages

User avatar
Vyp3R
Newbie
Newbie
Posts: 40
Joined: May 25th, 2011, 11:53 pm
Location: Melbourne, Australia

Re: Free Newsservers

Post by Vyp3R » January 15th, 2013, 7:53 am

sander wrote:Can you join this thread: http://forums.sabnzbd.org/viewtopic.php?f=3&t=12865 and continue there ... same error messages
The fix on that thread of changing the value of "ipv6_servers" to 2 in Config > Special worked! Didn't occur to me to think it was a change between versions of Sabnzbd itself. Now all three IPv6 servers I mentioned before are now working well. Thanks Sander.

sacii
Newbie
Newbie
Posts: 17
Joined: January 4th, 2011, 10:37 am

Re: Free Newsservers

Post by sacii » March 22nd, 2013, 7:41 am

Weathergirl and free.xsusenet are both down. Hope they are not going away.

Update: Temporary, they were both back up in a few hours.
Last edited by sacii on May 2nd, 2013, 4:22 pm, edited 1 time in total.

Post Reply