Download speed starts fast, then slows down after a few minutes

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
beiseman
Newbie
Newbie
Posts: 2
Joined: January 6th, 2019, 4:53 pm

Download speed starts fast, then slows down after a few minutes

Post by beiseman » January 6th, 2019, 4:59 pm

Hello! I'm running SABnzbd on macOS. I just downloaded the latest beta version.

I am having an issue when downloading. The download will start at full speed, but after a few minutes it drops down to about 20-30% of available bandwidth. I get a few minutes of fast downloads before it starts bottlenecking.

I have accounts at three different Usenet servers, and it happens no matter which one I use, and it also happens when I have all three active. So I suspect it is something in my setup, not the servers.

I've done the suggestions above, checking the server connection and testing the servers. All is good there.

User avatar
safihre
Administrator
Administrator
Posts: 2975
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Download speed starts fast, then slows down after a few minutes

Post by safihre » January 7th, 2019, 2:06 am

It seems your CPU cannot keep up with the download speed. What speeds are we talking about?
Try lowering the number of connections, to about 10 per server.
Making sure you have set 400M or more for Article Cache.
And then in the Status and Interface settings window, do a Test Download of 1000MB.

beiseman
Newbie
Newbie
Posts: 2
Joined: January 6th, 2019, 4:53 pm

Re: Download speed starts fast, then slows down after a few minutes

Post by beiseman » January 7th, 2019, 11:18 am

Hi, thank you for that information. I tried what you suggested, and unfortunately it did not help.

I already have (had) the Article Cache set to 1GB. The host computer has 16GB RAM installed, so I believe it is not a problem with running out of memory. And the CPU is also not being taxed too much during download. I have watched Activity Monitor while downloading, and it is nowhere near maxing out the CPU.

I tried switching both servers to 10 connections each, and the results were almost identical. It starts out at full speed for about 20 seconds or so, and then drops down to a much lower speed for the remainder of the download.

I have a 500mbps internet connection. So under ideal conditions, I would expect about 60-70MB/s download. And in fact that is what it starts out with. But after a time, it slows down to about 15-20MB/s.

I should indicate that I have tried NZBGet as well, and I do not see this problem. I would like to use SABnzbd, because I prefer the interface. But with everything else the same, I would have to switch to NZBGet because of the speed.

User avatar
safihre
Administrator
Administrator
Posts: 2975
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Download speed starts fast, then slows down after a few minutes

Post by safihre » January 7th, 2019, 1:42 pm

Unfortunately I'm not sure what it could be then..
While the download is going on, what values doe you see on the Article cache on the Status window?
It shows a live view of how much memory it's actually using.

Post Reply