2.3.6Beta1 rss delete not working

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
bl0m5t3r
Newbie
Newbie
Posts: 1
Joined: May 27th, 2019, 4:58 pm

Re: 2.3.6Beta1 rss delete not working

Post by bl0m5t3r » May 27th, 2019, 5:23 pm

I just registered to file a bug report on the same problem, but figured i'd do a search for the bug first. :)
The delete button/trashcan icon doesn't do anything, i've tried both chrome and firefox as i though it maybe some script is getting blocked or something.

Really hope you find a solution, let me know if it helps if i can provide you with anything (logs/ini/etc)
For now i'm disabling the rows by using the checkmark at the start of the row, that works fine. (as does saving/editing, anything but deleting)
It's been a bug for serveral releases now, i remember having troubles already a few months back but didn't pay much attention to it and thought i had a browser problem.

Just did some testing, and it seems to not work specifically for that Filterlist.
I created a new RSS filterlist, added some bogus filters, and on that new list i could add and then delete them as much a i want.
I do not want to lose / recreate my old list though, it's quite extensive and would be a pain in the ass to recreate.
but maybe it will help you pinpoint the problem.

User avatar
safihre
Administrator
Administrator
Posts: 3250
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre » May 29th, 2019, 4:07 am

Oke can you try the following: before clicking the trash bin, right click on the page and select Inspect Element. It will open Developers tools. There, open the console tab.
Click the trash icon. Is anything shown in the console?
In the network tab of the Developers tools, does it show anything when you click the trash icon?

Second, enable Debug logging in the Status window (on the main page, not Config) and then try the trash icon again. Go back to Status and Interface settings window and download the log by clicking Show Logging. Does it show anything special near the end?

AnonyMouse
Newbie
Newbie
Posts: 16
Joined: December 9th, 2017, 10:45 am

Re: 2.3.6Beta1 rss delete not working

Post by AnonyMouse » June 6th, 2019, 3:57 pm

If I just edit the ini and delete the fitler I want to ditch from the config, will that be ok, or do I need to update all the enumerations (i.e. if there end up being holes in the number sequence will something break)?

User avatar
safihre
Administrator
Administrator
Posts: 3250
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre » June 7th, 2019, 9:00 am

Should be fine if you manually delete I think.

Post Reply