Thanks for the fix for the "too many connections" issue

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
ErikBrown
Release Testers
Release Testers
Posts: 130
Joined: December 20th, 2009, 1:25 am
Location: Home

Thanks for the fix for the "too many connections" issue

Post by ErikBrown » May 12th, 2012, 5:43 am

Hi Shypike,

Thanks for fixing the "Too many connections" issue in 070 beta 5. I used to have very frequent Too many connection errors and often SABnzbd would from then on keep using less connections than configured. The only way to get the normal number of connections back was to re-start SABnzbd. I thought it was caused by my provider but beta 5 has completely solved this.

Erik

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: Thanks for the fix for the "too many connections" issue

Post by shypike » May 12th, 2012, 6:10 am

All of that because of a silly typo :(
Sorry.

ErikBrown
Release Testers
Release Testers
Posts: 130
Joined: December 20th, 2009, 1:25 am
Location: Home

Re: Thanks for the fix for the "too many connections" issue

Post by ErikBrown » May 12th, 2012, 3:09 pm

Hi Shypike,

It appears that the issue is not fully fixed. I do not get any errors messages of Too many connections anymore but the number of ports now appears always to be seven instead of eight as defined in the server settings. See the picture below (thread 3 is missing here):

Image

If I refresh the page, then another thread gets missing but always there will be only 7 threads.

I am not sure if this is relevant but whenever I choose the Status tab then I can see on my network switch that SABnzbd stops downloading till the page is displayed. This takes about 10 seconds or so. My PC is a AMD Athlon 64 3800+ 2400 MHz with 2 GB memory. This PC feels fast enough and it is only running SABnzbd. I have a very large download history and loads of files in the NZB backup folder. Could that cause the delay?

In case you would like more info, then please let me know.

Erik

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: Thanks for the fix for the "too many connections" issue

Post by shypike » May 12th, 2012, 4:00 pm

Only with the Classic skin there will be trouble with very large histories.
The other will struggle if you display all of the queue or history (or large parts).
I wouldn't take the Status->Connections display too serious, it's not a very accurate snapshot.

Post Reply