RSS feeds stuck in "Trying to fetch NZB..."

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by shypike »

It is possible that something goes wrong, but this is unrelated to the display issue.
Rather hard to reproduce and therefore to fix.

Jumbs
Newbie
Newbie
Posts: 38
Joined: May 2nd, 2011, 4:50 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by Jumbs »

I rolled back to beta3 and it seems to have fixed the problems. I hope that helps.

ErikBrown
Release Testers
Release Testers
Posts: 135
Joined: December 20th, 2009, 1:25 am
Location: Home

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by ErikBrown »

I also have downgraded to 0.7.17B3 because 0.7.17RC1 was too often causing issues. It was not just cosmetic for me. For instance see the image below. The first part of the graphic (till 13) shows that the download was not working. SABnzbd acts as if the download works but the speed shown does not fluctuate at all and the network router shows that no data is transferred to my download PC. At 13 I downgraded to 0.17.17B3 and you see that after that the speed is properly shown.

Image

Erik
Last edited by ErikBrown on February 14th, 2014, 3:31 am, edited 1 time in total.

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by shypike »

It sounds rather unlikely, given the small difference between B3 and RC1 and where the changes are.
Anyway, the change concerning password handling has been rolled back,
because I fixed the problem in a different way.
This weekend will see RC2, which should fix the issue once and for all.

BTW: I see another problem in your screenshot.
It says "new version 0.7.16" while you're running 0.7.17RC1.
Another thing to check :(

Another BTW: which operating system is each of you using?

ErikBrown
Release Testers
Release Testers
Posts: 135
Joined: December 20th, 2009, 1:25 am
Location: Home

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by ErikBrown »

Hi Shypike,

I use Windows XP SP3. Regarding your comment "It says "new version 0.7.16" while you're running 0.7.17RC1.", I was running RC1 but this screenshot was taken after I downgraded to B3

Erik

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by shypike »

ErikBrown wrote:I was running RC1 but this screenshot was taken after I downgraded to B3
Even so, it should not say that 0.7.16 is newer than what you now have!

ahpatel
Newbie
Newbie
Posts: 1
Joined: September 14th, 2011, 9:18 am

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by ahpatel »

Jumbs wrote:I rolled back to beta3 and it seems to have fixed the problems. I hope that helps.
I can confirm that the beta3 rollback suggestion solves this on Mac OS X Mavericks.

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by shypike »

Fixed in next release.
Cosmetic issue in the RC1 code.
Checking for further issues.

Samme
Newbie
Newbie
Posts: 1
Joined: February 17th, 2014, 6:54 am

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by Samme »

Is the fix out? Or maybe it just hasn't reached the Ubuntu repos yet?

Looking forward to it, thank for your work!

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by shypike »

Will be in RC2.
With a bit off luck by the end of the week.

Jumbs
Newbie
Newbie
Posts: 38
Joined: May 2nd, 2011, 4:50 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by Jumbs »

Thanks for your work on this.

As a developer i can relate to getting vague bug tickets.

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: RSS feeds stuck in "Trying to fetch NZB..."

Post by shypike »

Jumbs wrote: As a developer i can relate to getting vague bug tickets.
Well, this isn't the worst kind, because it's at least deterministic.
Crashes without identifiable scenarios are the worst.

Post Reply