[2.0.0 RC1] Download issues with an older nzb

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
nate1280
Newbie
Newbie
Posts: 10
Joined: March 27th, 2011, 9:02 pm

[2.0.0 RC1] Download issues with an older nzb

Post by nate1280 » March 26th, 2017, 6:15 pm

Getting a download failure in all released builds of 2.x.

I set the post processing to just download so I could validate the files in each attempt myself with multipar.

In 1.2.1 and 1.2.3, there is only 1 block missing (which it gets enough par2s to repair), however in all 2.x releases, its missing 140 (2.0.0a1) blocks, 145 blocks (2.0.0b1) and 150 (2.0.0rc1) blocks (found that rather odd)

usenet server settings are identical on all instances, and for beta and rc, I'm using the 64-bit version.

Not sure what other info to post here.

I do have debug logs from from 1.2.3, 2.0.0-alpha1, 2.0.0-beta1, and 2.0.0rc1, not sure where to send these, and of course the NZB in question if required.

User avatar
sander
Release Testers
Release Testers
Posts: 6749
Joined: January 22nd, 2008, 2:22 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by sander » March 27th, 2017, 1:06 am

on which OS?

User avatar
safihre
Administrator
Administrator
Posts: 3365
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: [2.0.0 RC1] Download issues with an older nzb

Post by safihre » March 27th, 2017, 3:39 am

He's on Windows (64 bit is only Windows).
Can you share the logs? They should be anonomyzed automatically when clicking Show logging in the Status window.

nate1280
Newbie
Newbie
Posts: 10
Joined: March 27th, 2011, 9:02 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by nate1280 » March 27th, 2017, 7:51 am

I'm running on Windows Server 2016.

I emailed the logs into [email protected] since I wasn't sure if I was able to mask/remove everything. I also attached the NZB, just in case.

From looking at the logs, its seems as tho the decoder is getting CRC errors on parts where it shouldn't. Other then that, there's nothing that stands out.

nate1280
Newbie
Newbie
Posts: 10
Joined: March 27th, 2011, 9:02 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by nate1280 » March 27th, 2017, 11:45 am

If anymore information is required or you didn't receive the logs please let me know.

nate1280
Newbie
Newbie
Posts: 10
Joined: March 27th, 2011, 9:02 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by nate1280 » March 29th, 2017, 4:58 pm

Gave 2.0.0RC2 a try since there were sabyenc changes (not sure if those were related to this bug and the logs i sent), but, still the same issue.

User avatar
safihre
Administrator
Administrator
Posts: 3365
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: [2.0.0 RC1] Download issues with an older nzb

Post by safihre » March 29th, 2017, 11:54 pm

Your NZB completes now fine in 2.0.0rc2, I don't get any CRC error anymore. You do?

nate1280
Newbie
Newbie
Posts: 10
Joined: March 27th, 2011, 9:02 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by nate1280 » March 30th, 2017, 7:03 am

Looking through the log file from 2.0.0rc2 (64bit), I'm still getting a lot of crc error entries.

And the resulting download requires 145 blocks to repair.

edit: just tried the 32bit version, and same result.

nate1280
Newbie
Newbie
Posts: 10
Joined: March 27th, 2011, 9:02 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by nate1280 » March 30th, 2017, 8:09 am

I emailed new log files, for both the 32 and 64bit versions.

eriji
Newbie
Newbie
Posts: 5
Joined: September 3rd, 2012, 7:29 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by eriji » March 31st, 2017, 5:30 am

I am having the same/similar problem on 2.0.0RC1 and 2.0.0RC2. It is a new problem that didn't exist on 1.2.3.

I have had at least 20 nzb's where SABnzbd will download the download it and then say it failed and could not repair.
I verify with QuickPar, and find that many parts are partial/malformed or missing.
I then use Newsleecher and individually download the missing / malformed parts, and they download fine. QuickPar verifies the re-downloaded parts and is able to repair, or it needs no repair.

Never seen this problem before.

Also, related, If I redownload the missing/malformed with Newsleecher, and then DO NOT repair with QuickPar, and ask SABnzbd to retry, it usually fails saying it still can't repair. But I use QuickPar and it is able to repair ok.
Pretty much on all of these nzb's that don't download right the first time, it won't correctly repair even if you give it good data to work with, SABnzbd needs perfect/repaired files on these failed first ones.

SABnzbd does occasionally repair downloaded nzb's on first try.

It seems that smaller downloads or newer downloads work better and seems to complete more reliably. The problem occurs on at least 4 out 5 of older releases. Could it be a timing problem where maybe on older or larger releases the newsserver is taking a bit longer to respond and something times out? Just a thought.

I'm using Giganews as primary, and it usually is quite good for completion. Newshosting as secondary and they are good as well.

[A nice feature would be if SABnzbd would retry on the other news server any parts that don't download correctly on the primary. In older releases for the very occasional errors that used to occur, I would do this individual part download and it works almost every time. Although, in this new case, I don't think SABnzbd knows that it didn't download correctly.]

I won't have time to post logs until tonight or tomorrow, so tell me what you want and how.

User avatar
safihre
Administrator
Administrator
Posts: 3365
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: [2.0.0 RC1] Download issues with an older nzb

Post by safihre » March 31st, 2017, 5:59 am

We would like to have those NZB's. Can you share them here or send them to [email protected]?
I thought to have fixed it in RC2, but then later with help of @nate1280 I found that there was another bug.

User avatar
safihre
Administrator
Administrator
Posts: 3365
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: [2.0.0 RC1] Download issues with an older nzb

Post by safihre » March 31st, 2017, 7:13 am

Could you try this version?
Can just extract it anywhere and run it (first shutdown your other SAB-instance!).
https://www.dropbox.com/s/pzm11ykjoruml ... n.zip?dl=1

eriji
Newbie
Newbie
Posts: 5
Joined: September 3rd, 2012, 7:29 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by eriji » April 1st, 2017, 6:55 pm

safihre wrote:We would like to have those NZB's. Can you share them here or send them to [email protected]?
I thought to have fixed it in RC2, but then later with help of @nate1280 I found that there was another bug.
Sorry I have been tied up with some emergencies. Sending the latest nzb that has that problem to the email address given, subject "Download issues with older nzb". This one is an odd one for another reason also, in that it had two par files, and one (the sample file) verified, and the other was either not downloaded or not in the nzb (i don't know which) BUT end result is that this one showed completed successfully in SABnzbd even though most of the files (for the main movie file) did not download correctly. I was able to download these with newsleecher and they downloaded perfectly and verified.

eriji
Newbie
Newbie
Posts: 5
Joined: September 3rd, 2012, 7:29 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by eriji » April 1st, 2017, 6:58 pm

safihre wrote:Could you try this version?
Can just extract it anywhere and run it (first shutdown your other SAB-instance!).
https://www.dropbox.com/s/pzm11ykjoruml ... n.zip?dl=1

Will be trying that version tonight.

eriji
Newbie
Newbie
Posts: 5
Joined: September 3rd, 2012, 7:29 pm

Re: [2.0.0 RC1] Download issues with an older nzb

Post by eriji » April 1st, 2017, 7:14 pm

eriji wrote:
safihre wrote:Could you try this version?
Can just extract it anywhere and run it (first shutdown your other SAB-instance!).
https://www.dropbox.com/s/pzm11ykjoruml ... n.zip?dl=1

Will be trying that version tonight.
Actually, I won't. It won't run on the system that I've got SABnzbd on. Its an older Dell system running Win 10 32 bit operating system on an x64 based processor.

Could the compatibility mode or something be part of whats causing the problem?
Does the other user have the same setup?

When I install SABnzbd 2.0 it installs fine, no warnings, and runs fine (seemingly). except of course for this problem and one other one:

I was a packrat and had all my completed history (from several years) in SABnzbd history. Previous releases, I never had any problem with this, it never seemed to slow down, searched the history fine, displayed it fine.

2.0 though, apparently had a problem with the number of items in the history, because it would become sluggish (well at least the web interface did, it didn't seem to affect downloading and other file operations) and take seconds to minutes to respond. Eventually, I had a hunch it was the history causing the problem, and deleted all the history except the failed ones that I had kept (half a dozen maybe.) This solved the problem completely with the sluggish interface.

Post Reply