2.3.1Beta1 - userscript no longer works

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
order512
Newbie
Newbie
Posts: 7
Joined: December 31st, 2016, 2:12 am

2.3.1Beta1 - userscript no longer works

Post by order512 » October 9th, 2017, 8:32 am

My .bat windows script was working fine in 2.3.0, but in 2.3.1Beta1 i see this:
Exit(-1) Cannot run script <PathToMyscript>

User avatar
safihre
Administrator
Administrator
Posts: 3241
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.1Beta1 - userscript no longer works

Post by safihre » October 9th, 2017, 9:44 am

Could you enable Debug logging in the Status Window, then try another download with the script.

After it fails, click Show logging in the Status Window, then in the logging somewhere it will say:

Code: Select all

Failed script <PathToMyscript>, Traceback:
Can you post what is listed in the lines below this?

order512
Newbie
Newbie
Posts: 7
Joined: December 31st, 2016, 2:12 am

Re: 2.3.1Beta1 - userscript no longer works

Post by order512 » October 9th, 2017, 11:53 am

2017-10-09 09:51:13,411::DEBUG::[newsunpack:198] Failed script myscript.bat, Traceback:
Traceback (most recent call last):
File "sabnzbd\newsunpack.pyo", line 175, in external_processing
File "subprocess.pyo", line 390, in __init__
File "subprocess.pyo", line 640, in _execute_child
TypeError: environment can only contain strings

User avatar
safihre
Administrator
Administrator
Posts: 3241
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.1Beta1 - userscript no longer works

Post by safihre » October 9th, 2017, 12:35 pm

Could you send me the NZB you are trying to download and the path to your complete folder? You can send it to [email protected]

And this is on Windows, right?

order512
Newbie
Newbie
Posts: 7
Joined: December 31st, 2016, 2:12 am

Re: 2.3.1Beta1 - userscript no longer works

Post by order512 » October 9th, 2017, 1:50 pm

I'm using windows 10.
The nzb is in a category where download folder is E:\, normal folder is D:\complete.
I have the issue with any nzb, i send you one by mail.

User avatar
safihre
Administrator
Administrator
Posts: 3241
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.1Beta1 - userscript no longer works

Post by safihre » October 9th, 2017, 4:21 pm

Bug found and will be fixed in next release of 2.3.1!

Post Reply