2.3.6Beta1 rss delete not working

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
Hairybiker
Newbie
Newbie
Posts: 38
Joined: October 24th, 2011, 4:18 am

2.3.6Beta1 rss delete not working

Post by Hairybiker » November 17th, 2018, 9:44 am

Running on Mint 19 64bit
When pressing delete on a RSS match item it will not delete, does nothing.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre » November 20th, 2018, 3:41 am

What Delete button do you mean? In the RSS-page or in the Queue?

Hairybiker
Newbie
Newbie
Posts: 38
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker » November 21st, 2018, 8:34 am

The one on the RSS page, to delete a setup search item.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre » November 21st, 2018, 9:24 am

Could you show us a screenshot?
I couldn't reproduce it.

Hairybiker
Newbie
Newbie
Posts: 38
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker » November 21st, 2018, 12:58 pm

Image

The trash can at the end.
Clicking on it does nothing. Tested on Chromium 70 on Win 7 and Linux Mint 19, checked using an incognito page as well with same result.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre » November 22nd, 2018, 2:23 am

That's very strange, I still can't reproduce it.
Could you right click in the browser, then Inspect Element and then open the Console tab.
If you click the delete-button, do you get an error?

Otherwise: in Status and Interface settings window on the main download-page, set logging-level to +Debug and then try again to remove the filter.
After that, click Show Logging Status and Interface settings window and see if there's some error near the end.

Hairybiker
Newbie
Newbie
Posts: 38
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker » November 22nd, 2018, 6:25 am

I get this on the console tab

jquery-3.2.1.min.js?v=2.3.6Beta1:2 Uncaught TypeError: $(...).tablesort is not a function
at HTMLDocument.<anonymous> (?feed=2.4:15177)
at mightThrow (jquery-3.2.1.min.js?v=2.3.6Beta1:2)
at process (jquery-3.2.1.min.js?v=2.3.6Beta1:2)
favicon.ico/:1 Failed to load resource: net::ERR_NAME_NOT_RESOLVED

No error in the debug log.

I am seeing some "Opening and ending tag mismatch: hr line 6 and body" from nzbindex.nl but that is all.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre » November 22nd, 2018, 8:09 am

That's very strange. Could you send me your rss_data.sab file from "admin_dir" (location: https://sabnzbd.org/wiki/advanced/directory-setup)

At [email protected]

Hairybiker
Newbie
Newbie
Posts: 38
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker » November 22nd, 2018, 9:04 am

sent

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre » November 26th, 2018, 7:08 am

Very strange.. still can't reproduce it :o
Could you send me the [rss] part of your sabnzbd,ini file?
I won't abuse your API-keys!

Hairybiker
Newbie
Newbie
Posts: 38
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker » November 26th, 2018, 10:04 am

sent

Post Reply