2.3.6 beta1 won't launch on OS X Sierra

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
HorseCalledHorse
Newbie
Newbie
Posts: 27
Joined: September 19th, 2011, 8:05 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by HorseCalledHorse » December 11th, 2018, 12:01 am

Cpuroast wrote:
December 10th, 2018, 9:43 pm
That should have no issue running 2.3.6 Beta 1

Is your version of macOS 10.12.6 up to date with all the patches and security updates?

You could also try shutting down sab, then trying a fresh copy of the DMG from here:
https://github.com/sabnzbd/sabnzbd/rele ... a1-osx.dmg

Maybe yours ended up being corrupted somehow.
Yeah, all up to date. I thought it should have no issue either, but for some reason or other it does. The beta and the two test versions all refuse to start. Tried the fresh copy you linked to above and got the same result.
Given that it failed for at least one other person, I'm wondering if something has changed with the build process.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by safihre » December 14th, 2018, 3:07 am

I identified 3 changes in the macOS specific Python packages.
Could you try these 3 versions and see which one works?
https://github.com/sabnzbd/sabbuild/rel ... .6osxtest1
https://github.com/sabnzbd/sabbuild/rel ... 3.6oxtest2
https://github.com/sabnzbd/sabbuild/rel ... .6osxtest3

HorseCalledHorse
Newbie
Newbie
Posts: 27
Joined: September 19th, 2011, 8:05 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by HorseCalledHorse » December 14th, 2018, 4:02 am

safihre wrote:
December 14th, 2018, 3:07 am
I identified 3 changes in the macOS specific Python packages.
Could you try these 3 versions and see which one works?
https://github.com/sabnzbd/sabbuild/rel ... .6osxtest1
https://github.com/sabnzbd/sabbuild/rel ... 3.6oxtest2
https://github.com/sabnzbd/sabbuild/rel ... .6osxtest3
Just tried them and none of three would launch.
Is there a chance I'm not downloading the right files? All the .dmg files have exactly the same name (SABnzbd-2.3.6Beta1-osx.dmg) so it gets a little confusing.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by safihre » December 14th, 2018, 4:05 am

I spun up a 10.13 virtual machine and will now test myself.
Strange stuff..

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by safihre » December 14th, 2018, 8:51 am

Oke so how about this version?
It works for me on 10.12 and 10.13:
https://github.com/sabnzbd/sabbuild/rel ... 36osxtest5

HorseCalledHorse
Newbie
Newbie
Posts: 27
Joined: September 19th, 2011, 8:05 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by HorseCalledHorse » December 14th, 2018, 2:35 pm

safihre wrote:
December 14th, 2018, 8:51 am
Oke so how about this version?
It works for me on 10.12 and 10.13:
https://github.com/sabnzbd/sabbuild/rel ... 36osxtest5
And it's working for me, too! Launched, connected on every test I tried, unpacked - did everything it should. I'll keep running it and see if any issues pop up.
Last edited by HorseCalledHorse on December 14th, 2018, 6:43 pm, edited 1 time in total.

Cpuroast
Release Testers
Release Testers
Posts: 125
Joined: December 15th, 2010, 11:19 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by Cpuroast » December 14th, 2018, 2:38 pm

Sounds promising, I'll try that new build on 10.9 through 10.14 in my VMs tonight.

Cpuroast
Release Testers
Release Testers
Posts: 125
Joined: December 15th, 2010, 11:19 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by Cpuroast » December 14th, 2018, 9:35 pm

Ok, so here is the verdict:

The original 2.3.6 Beta1 build from https://github.com/sabnzbd/sabnzbd/releases build runs perfectly on all my VMs from 10.9 through 10.14.

Test 5 however only runs on my 10.12, 10.13 and 10.14 VMs.

10.9.5 and 10.10.5 both tell me that the app bundle is damaged and can't be opened.
10.11.6 does however try to launch, but instantly crashes with this error message left in the crash log:

Dyld Error Message:
Symbol not found: _getentropy
Referenced from: /Volumes/VOLUME/SABnzbd.app/Contents/Frameworks/Python.framework/Versions/2.7/Python (which was built for Mac OS X 10.12)
Expected in: /usr/lib/libSystem.B.dylib

It all depends on what the official support plans are, if 10.9 through to 10.11 are dropped, then the new build is fine, if not, then more build testing is required.

I suspect HorseCalledHorse is running into hardware incompatibility with some instruction being used at compile time which isn't supported by his CPU, where as Test 5 is running into software incompatibility where the the build simply doesn't target anything older than 10.12.

Data from http://gs.statcounter.com/macos-version ... /worldwide indicates that Mavericks (10.9) is barely used anymore:

As of November 2018

Mojave (10.14): 26.76%
High Sierra (10.13): 33.33%
Sierra (10.12): 14.92%
El Capitan (10.11): 11.94%
Yosemite (10.10): 7.45%
Mavericks (10.9: 2.46%

We could probably afford to drop 10.9, but 10.10 and 10.11 are still quite used.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by safihre » December 15th, 2018, 3:09 am

Cpuroast thanks for testing!
How strange that the original Beta build runs on your 10.11 VM but not on my VM.. Could indeed be an emulated hardware problem.
Now I'm not sure what to do.. Or what changed in the build system at TravisCI that caused all this.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by safihre » December 17th, 2018, 6:58 am

I think I fixed it, but at the cost of immense frustration (as reflected by my commit messages :P)
Could you all give this release a try?
https://github.com/sabnzbd/sabbuild/releases/tag/test13

Cpuroast
Release Testers
Release Testers
Posts: 125
Joined: December 15th, 2010, 11:19 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by Cpuroast » December 18th, 2018, 6:12 am

Good news , test 13 launches correctly on my 10.9.5 through 10.14.2 VMs :)

Cpuroast
Release Testers
Release Testers
Posts: 125
Joined: December 15th, 2010, 11:19 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by Cpuroast » December 18th, 2018, 6:37 am

Your RC1 build also launches correctly on my 10.9.5 through 10.14.2 VMs

Cpuroast
Release Testers
Release Testers
Posts: 125
Joined: December 15th, 2010, 11:19 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by Cpuroast » December 18th, 2018, 6:39 am

We just have to confirm with HorseCalledHorse that the new build runs fine on his older CPU.

User avatar
safihre
Administrator
Administrator
Posts: 2967
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by safihre » December 18th, 2018, 8:40 am

Coolcoolcool.

HorseCalledHorse
Newbie
Newbie
Posts: 27
Joined: September 19th, 2011, 8:05 pm

Re: 2.3.6 beta1 won't launch on OS X Sierra

Post by HorseCalledHorse » December 20th, 2018, 3:12 pm

Cpuroast wrote:
December 18th, 2018, 6:39 am
We just have to confirm with HorseCalledHorse that the new build runs fine on his older CPU.
Sorry guys - been out of the loop. But yes, can confirm RC1 is working great for me! ;D
Thanks for all the hard work, safihre.

Post Reply