Access Denied after upgrade to 3.3.0Beta3

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
dtj0h
Newbie
Newbie
Posts: 6
Joined: May 4th, 2021, 7:06 am

Access Denied after upgrade to 3.3.0Beta3

Post by dtj0h »

Hopefully one of you guys can point me in to the right direction, because I seem to miss what is going on. Hehe.

So, couple of days ago I decided to upgrade to the latest beta available on the ubuntu repo from jcfp. I upgraded with the following path according to my apt history log:

3.2.0~beta2-0ubuntu1~jcfp3~18.04 > 3.3.0~beta3-0ubuntu1~jcfp1~18.04

today I checked again and updated to 3.3.0~beta3-0ubuntu1~jcfp2~18.04 because of the error I am getting.

When going to the URL of sabnzbd it gives me nothing more than "access denied" atm. I've searched the forum and the rest of the internet, it gave me hints to host_whitelist and local_ranges. I've tried deleting them just for testing what would happen, but it would return them to the config after restarting ( stop, edit, start) with values:

local_ranges = ,
host_whitelist = $hostname, (where $hostname is my hostname of course)

When checking the logging of sabnzbd, it gives me nothing more than:

2021-05-04 14:16:48,133::DEBUG::[interface:140] Request GET / from $IP [Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.82 Safari/537.36] {}
2021-05-04 14:16:48,133::INFO::[notifier:122] Sending notification: Warning - Refused connection from: $IP [Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.82 Safari/537.36] (type=warning, job_cat=None)
2021-05-04 14:16:48,133::WARNING::[interface:376] Refused connection from: $IP [Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.82 Safari/537.36]

This doesn't look like the refused part when hostname is wrong or something. Also Sonarr isn't able to use the API as well, same error with different path/get of course. I did not try to downgrade again so I don' t know if that would solve my issues, but in all these years I've been using Sabnzbd it's the first time I am getting this error. Again hopefully somebody can point me in the right direction as I don't see what the problem is, hehe. Thanks in advance!

User avatar
sander
Release Testers
Release Testers
Posts: 7482
Joined: January 22nd, 2008, 2:22 pm

Re: Access Denied after upgrade

Post by sander »

Is your SABnzbd on a public IP address?

https://github.com/sabnzbd/sabnzbd/issues/1872

Solution: start SABnzbd from CLI with "--inet_exposure=5"

User avatar
safihre
Administrator
Administrator
Posts: 4284
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Access Denied after upgrade

Post by safihre »

@sander: the CLI option is not part of Beta3 yet.
@dtj0h: you will need to set your inet_exposure in your sabnzbd.ini

Just wondering: is the SABnzbd instance not in your network?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

dtj0h
Newbie
Newbie
Posts: 6
Joined: May 4th, 2021, 7:06 am

Re: Access Denied after upgrade

Post by dtj0h »

Thanks for responding so quickly guys.

Hehe nope, it's on a 'public' interface, firewalled of course.

So everything I do with the ini file is getting erased after I start SABnzbd. I should be under [misc] right? Something else I need to erase from the config or something?

edit: I put 'inet_exposure = 5' in it, maybe that's not right?

User avatar
sander
Release Testers
Release Testers
Posts: 7482
Joined: January 22nd, 2008, 2:22 pm

Re: Access Denied after upgrade to 3.3.0Beta3

Post by sander »

@dtj0h I was too early: the CLI parameter to fix it is not in Beta3.

Workarounds for now:
downgrade to 3.3.0Beta2 or 3.2.1 (which won't say Access Denied)
upgrade to the git version (which has the CLI option to avoid the Access Denied)

dtj0h
Newbie
Newbie
Posts: 6
Joined: May 4th, 2021, 7:06 am

Re: Access Denied after upgrade to 3.3.0Beta3

Post by dtj0h »

Ok yea, well the easiest thing for me to do right now is to downgrade, so I'll do that. But if I would upgrade to the new release some time in the future, would I have to use the CLI option/edit ini file with something else than default? It's good for me to know, as there will be a day when I decide to upgrade again, hehe. Thanks for helping me out so quickly guys. Much appreciated.

User avatar
sander
Release Testers
Release Testers
Posts: 7482
Joined: January 22nd, 2008, 2:22 pm

Re: Access Denied after upgrade to 3.3.0Beta3

Post by sander »

Before I answer your question, again my question:

Is SABnzbd running on a public IPv4 address? So on a VPS or seedbox? You can check via SAB -> Wrench symbol, at "Local IPv4 address " ...

dtj0h
Newbie
Newbie
Posts: 6
Joined: May 4th, 2021, 7:06 am

Re: Access Denied after upgrade to 3.3.0Beta3

Post by dtj0h »

Ah you might have missed this in my initial response:

"Hehe nope, it's on a 'public' interface, firewalled of course."

So, yes it's on a public v4 and public v6 address.

User avatar
jcfp
Release Testers
Release Testers
Posts: 898
Joined: February 7th, 2008, 12:45 pm

Re: Access Denied after upgrade

Post by jcfp »

dtj0h wrote:
May 4th, 2021, 8:57 am
So everything I do with the ini file is getting erased after I start SABnzbd. I should be under [misc] right? Something else I need to erase from the config or something?

edit: I put 'inet_exposure = 5' in it, maybe that's not right?
You have to shutdown sabnzbd before editing the ini file. Setting 'inet_exposure = 5' should work; do note that the setting isn't new, so you should modify the value of the existing one rather than adding it. Once you are done editing, save the ini file and fire up sabnzbd again.

dtj0h
Newbie
Newbie
Posts: 6
Joined: May 4th, 2021, 7:06 am

Re: Access Denied after upgrade to 3.3.0Beta3

Post by dtj0h »

Well when I was running 3.3.0-beta3 that was not working for me. Last night I downgraded to 3.2.1 as sander suggested to do because it was not in that specific release.

I did shutdown SABnzbd before editing the ini file, but when starting it up again the line with 'inet_exposure' disappeared again (erased from config). I did doublecheck a couple of times if the line was correctly saved in the ini file, but that was the case. I'm not sure what is happening now, as you and safihre both said it should be put in the ini file and sander said it wasn't supported in de beta3 version yet.

Hehe, anyway, if you want me to test, i will gladly upgrade again, let me know!

User avatar
sander
Release Testers
Release Testers
Posts: 7482
Joined: January 22nd, 2008, 2:22 pm

Re: Access Denied after upgrade to 3.3.0Beta3

Post by sander »

I assume 3.2.1 is working for you?

If so, most easy to stay on it until something newer than 3.3.0Beta3 appears.

dtj0h
Newbie
Newbie
Posts: 6
Joined: May 4th, 2021, 7:06 am

Re: Access Denied after upgrade to 3.3.0Beta3

Post by dtj0h »

Yes the 3.2.1 version works as a charm again! So again, thanks for your help, much appreciated. If you guys ever need VPS server(s) for hosting/testing/coding purposes, let me know and I'll see what I can do.

Post Reply