Unable to start on Ubuntu 16.04: ChannelFailures: TypeError(

Support for the Debian/Ubuntu package, created by JCFP.
Post Reply
ppow
Newbie
Newbie
Posts: 9
Joined: October 23rd, 2016, 10:15 pm

Unable to start on Ubuntu 16.04: ChannelFailures: TypeError(

Post by ppow » April 21st, 2017, 2:47 am

Get the following:

Code: Select all

2017-04-21 07:19:49,491::ERROR::[_cplogging:219] [21/Apr/2017:07:19:49] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 245, in start
    self.publish('start')
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 223, in publish
    level=40, traceback=True)
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 517, in log
    self.publish('log', msg, level)
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 225, in publish
    raise exc
ChannelFailures: TypeError('not enough arguments for format string',)

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to start on Ubuntu 16.04

Post by sander » April 21st, 2017, 3:04 am

what are the lines before that logging?

ppow
Newbie
Newbie
Posts: 9
Joined: October 23rd, 2016, 10:15 pm

Re: Unable to start on Ubuntu 16.04

Post by ppow » April 21st, 2017, 3:11 am

That's all I'm getting when trying to manually start.

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to start on Ubuntu 16.04

Post by sander » April 21st, 2017, 3:14 am

I can't believe that.

ppow
Newbie
Newbie
Posts: 9
Joined: October 23rd, 2016, 10:15 pm

Re: Unable to start on Ubuntu 16.04

Post by ppow » April 21st, 2017, 3:22 am

I don't know what to tell you. I type sabnzbdplus to manually start and that is the error I get.
Nothing after that.

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to start on Ubuntu 16.04

Post by sander » April 21st, 2017, 3:27 am

ppow wrote: Nothing after that.
I do believe that. But I asked the lines before the lines you posted ... :)

ppow
Newbie
Newbie
Posts: 9
Joined: October 23rd, 2016, 10:15 pm

Re: Unable to start on Ubuntu 16.04

Post by ppow » April 21st, 2017, 3:30 am

No. Nothing before that either.

User avatar
safihre
Administrator
Administrator
Posts: 1704
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Unable to start on Ubuntu 16.04

Post by safihre » April 21st, 2017, 3:31 am

To show more logging, start SABnzbd like this:

Code: Select all

sabnzbdplus -l 2

ppow
Newbie
Newbie
Posts: 9
Joined: October 23rd, 2016, 10:15 pm

Re: Unable to start on Ubuntu 16.04

Post by ppow » April 21st, 2017, 3:41 am

Thanks. Here's the output.

Code: Select all

2017-04-21 08:36:46,063::INFO::[sabnzbdplus:1155] --------------------------------
2017-04-21 08:36:46,064::INFO::[sabnzbdplus:1156] sabnzbdplus-2.0.1RC1 (rev=2f52590587bf3e06100e410da1b83f35383244cb)
2017-04-21 08:36:46,064::INFO::[sabnzbdplus:1157] Full executable path = /usr/bin/sabnzbdplus
2017-04-21 08:36:46,064::INFO::[sabnzbdplus:1169] Platform = posix
2017-04-21 08:36:46,064::INFO::[sabnzbdplus:1170] Python-version = 2.7.12 (default, Nov 19 2016, 06:48:10)
[GCC 5.4.0 20160609]
2017-04-21 08:36:46,064::INFO::[sabnzbdplus:1171] Arguments = /usr/bin/sabnzbdplus -l 2
2017-04-21 08:36:46,065::INFO::[sabnzbdplus:1176] Preferred encoding = UTF-8
2017-04-21 08:36:46,065::DEBUG::[sabnzbdplus:1190] My local IPv4 address = 
2017-04-21 08:36:46,294::DEBUG::[sabnzbdplus:1196] My public IPv4 address = 
2017-04-21 08:36:46,295::DEBUG::[sabnzbdplus:1204] Could not determine my IPv6 address
2017-04-21 08:36:46,306::DEBUG::[sabnzbdplus:1210] CPU Pystone available performance is 138580
2017-04-21 08:36:46,307::DEBUG::[sabnzbdplus:1215] CPU model name is Intel(R) Xeon(R) CPU E5-2650L v3 @ 1.80GHz
2017-04-21 08:36:46,307::INFO::[sabnzbdplus:1217] Read INI file /root/.sabnzbd/sabnzbd.ini
2017-04-21 08:36:46,308::INFO::[__init__:995] Loading data for rss_data.sab from /root/.sabnzbd/admin/rss_data.sab
2017-04-21 08:36:46,308::INFO::[__init__:995] Loading data for totals10.sab from /root/.sabnzbd/admin/totals10.sab
2017-04-21 08:36:46,308::DEBUG::[bpsmeter:189] Read quota q=0.0 l=0.0 reset=0
2017-04-21 08:36:46,309::INFO::[postproc:93] Loading postproc queue
2017-04-21 08:36:46,309::INFO::[__init__:995] Loading data for postproc2.sab from /root/.sabnzbd/admin/postproc2.sab
2017-04-21 08:36:46,309::INFO::[__init__:995] Loading data for queue10.sab from /root/.sabnzbd/admin/queue10.sab
2017-04-21 08:36:46,310::DEBUG::[downloader:165] Initializing downloader/decoder
2017-04-21 08:36:46,310::INFO::[__init__:995] Loading data for watched_data2.sab from /root/.sabnzbd/admin/watched_data2.sab
2017-04-21 08:36:46,310::INFO::[__init__:995] Loading data for Rating.sab from /root/.sabnzbd/admin/Rating.sab
2017-04-21 08:36:46,310::INFO::[__init__:998] /root/.sabnzbd/admin/Rating.sab missing
2017-04-21 08:36:46,311::DEBUG::[scheduler:175] Scheduling RSS interval task every 60 min (delay=45)
2017-04-21 08:36:46,311::INFO::[scheduler:187] Setting schedule for midnight BPS reset
2017-04-21 08:36:46,311::DEBUG::[__init__:585] PAUSED_ALL inactive
2017-04-21 08:36:46,320::INFO::[__init__:351] All processes started
2017-04-21 08:36:46,320::INFO::[sabnzbdplus:287] Web dir is /usr/share/sabnzbdplus/interfaces/Glitter
2017-04-21 08:36:46,321::INFO::[sabnzbdplus:287] Web dir is /usr/share/sabnzbdplus/interfaces/Config
2017-04-21 08:36:46,340::INFO::[sabnzbdplus:398] SABYenc module (v3.0.2)... found!
2017-04-21 08:36:46,341::INFO::[sabnzbdplus:415] Cryptography module (v1.2.3)... found!
2017-04-21 08:36:46,341::INFO::[sabnzbdplus:420] par2 binary... found (/usr/bin/par2)
2017-04-21 08:36:46,341::INFO::[sabnzbdplus:425] par2cmdline binary... found (/usr/bin/par2)
2017-04-21 08:36:46,341::INFO::[sabnzbdplus:428] UNRAR binary... found (/usr/bin/unrar)
2017-04-21 08:36:46,342::DEBUG::[sabnzbdplus:436] UNRAR binary version 5.30
2017-04-21 08:36:46,342::INFO::[sabnzbdplus:441] unzip binary... found (/usr/bin/unzip)
2017-04-21 08:36:46,342::INFO::[sabnzbdplus:446] 7za binary... found (/usr/bin/7za)
2017-04-21 08:36:46,342::INFO::[sabnzbdplus:452] nice binary... found (/usr/bin/nice)
2017-04-21 08:36:46,342::INFO::[sabnzbdplus:456] ionice binary... found (/usr/bin/ionice)
2017-04-21 08:36:46,342::INFO::[sabnzbdplus:1262] SSL version OpenSSL 1.0.2g  1 Mar 2016
2017-04-21 08:36:46,343::INFO::[sabnzbdplus:1263] SSL supported protocols ['TLS v1.2', 'TLS v1.1', 'TLS v1']
2017-04-21 08:36:46,344::INFO::[sabnzbdplus:1374] Starting web-interface on 0.0.0.0:8080
2017-04-21 08:36:46,344::INFO::[_cplogging:219] [21/Apr/2017:08:36:46] ENGINE Bus STARTING
2017-04-21 08:36:46,346::INFO::[_cplogging:219] [21/Apr/2017:08:36:46] ENGINE Started monitor thread '_TimeoutMonitor'.
2017-04-21 08:36:51,387::ERROR::[_cplogging:219] [21/Apr/2017:08:36:51] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 245, in start
    self.publish('start')
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 223, in publish
    level=40, traceback=True)
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 517, in log
    self.publish('log', msg, level)
  File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 225, in publish
    raise exc
ChannelFailures: TypeError('not enough arguments for format string',)

2017-04-21 08:36:51,388::INFO::[_cplogging:219] [21/Apr/2017:08:36:51] ENGINE Bus STOPPING
2017-04-21 08:36:51,388::INFO::[_cplogging:219] [21/Apr/2017:08:36:51] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('0.0.0.0', 8080)) already shut down
2017-04-21 08:36:51,388::INFO::[_cplogging:219] [21/Apr/2017:08:36:51] ENGINE Stopped thread '_TimeoutMonitor'.
2017-04-21 08:36:51,388::INFO::[_cplogging:219] [21/Apr/2017:08:36:51] ENGINE Bus STOPPED
2017-04-21 08:36:51,389::INFO::[_cplogging:219] [21/Apr/2017:08:36:51] ENGINE Bus EXITING
2017-04-21 08:36:51,389::INFO::[_cplogging:219] [21/Apr/2017:08:36:51] ENGINE Bus EXITED
IP address removed.

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to start on Ubuntu 16.04

Post by sander » April 21st, 2017, 4:01 am

What is the output of:

Code: Select all

sudo netstat -apon | grep -i listen | grep -vi listening

ppow
Newbie
Newbie
Posts: 9
Joined: October 23rd, 2016, 10:15 pm

Re: Unable to start on Ubuntu 16.04

Post by ppow » April 21st, 2017, 5:07 am

Code: Select all

tcp        0      0 0.0.0.0:8989            0.0.0.0:*               LISTEN      1612/mono        off (0.00/0/0)
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      3190/python      off (0.00/0/0)
tcp        0      0 127.0.0.1:36816         0.0.0.0:*               LISTEN      1633/Plex Plug-in [ off (0.00/0/0)
tcp        0      0 0.0.0.0:32400           0.0.0.0:*               LISTEN      1500/Plex Media Ser off (0.00/0/0)
tcp        0      0 127.0.0.1:32401         0.0.0.0:*               LISTEN      1500/Plex Media Ser off (0.00/0/0)
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1463/sshd        off (0.00/0/0)
tcp6       0      0 :::22                   :::*                    LISTEN      1463/sshd        off (0.00/0/0)

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to start on Ubuntu 16.04

Post by sander » April 21st, 2017, 5:32 am

Code: Select all

tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      3190/python 
... so there's already something running on port 8080. It might be SABnzbd itself. Find out ...

ppow
Newbie
Newbie
Posts: 9
Joined: October 23rd, 2016, 10:15 pm

Re: Unable to start on Ubuntu 16.04

Post by ppow » April 21st, 2017, 5:47 am

Huh. ??? That's strange. It was SABnzbd running on port 8080. But I had changed the port a while back because I was getting strange remote traffic on that port. But it's working now.

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to start on Ubuntu 16.04

Post by sander » April 21st, 2017, 7:23 am

ppow wrote:Huh. ??? That's strange. It was SABnzbd running on port 8080. But I had changed the port a while back because I was getting strange remote traffic on that port. But it's working now.
You're running 2.0.1RC1 , and there is a new feature in 2.0.1RC1 to avoid "choose another port". Maybe there is correlation?

User avatar
safihre
Administrator
Administrator
Posts: 1704
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Unable to start on Ubuntu 16.04

Post by safihre » April 21st, 2017, 10:06 am

I will fix the error to be less stupid!
Should display a nice error.

Post Reply