Howto: updating in Debian proper

Support for the Debian/Ubuntu package, created by JCFP.
cyrben
Newbie
Newbie
Posts: 13
Joined: September 29th, 2014, 8:42 am

Re: Howto: updating in Debian proper

Post by cyrben » October 1st, 2014, 6:13 pm

[email protected]:~$ sudo apt-get remove sabnzbdplus
[sudo] password for user:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'sabnzbdplus' is not installed, so not removed
The following packages were automatically installed and are no longer required:
javascript-common libjs-excanvas libjs-mochikit libtidy-0.99-0
python-cheetah python-configobj python-feedparser python-libxml2
python-openssl python-utidylib python-yenc wwwconfig-common
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~$ sudo apt-get install sabnzbdplus
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
sabnzbdplus-theme-classic sabnzbdplus-theme-plush sabnzbdplus-theme-smpl
Suggested packages:
sabnzbdplus-theme-mobile python-notify python-dbus
The following NEW packages will be installed:
sabnzbdplus sabnzbdplus-theme-classic sabnzbdplus-theme-plush
sabnzbdplus-theme-smpl
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,496 kB of archives.
After this operation, 4,732 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ppa.launchpad.net/jcfp/ppa/ubuntu/ precise/main sabnzbdplus-theme-plush all 0.7.18-0ubuntu1~jcfp1~precise [229 kB]
Get:2 http://ppa.launchpad.net/jcfp/ppa/ubuntu/ precise/main sabnzbdplus all 0.7.18-0ubuntu1~jcfp1~precise [1,160 kB]
Get:3 http://ppa.launchpad.net/jcfp/ppa/ubuntu/ precise/main sabnzbdplus-theme-classic all 0.7.18-0ubuntu1~jcfp1~precise [30.7 kB]
Get:4 http://ppa.launchpad.net/jcfp/ppa/ubuntu/ precise/main sabnzbdplus-theme-smpl all 0.7.18-0ubuntu1~jcfp1~precise [75.9 kB]
Fetched 1,496 kB in 0s (2,889 kB/s)
Selecting previously unselected package sabnzbdplus-theme-plush.
(Reading database ... 37131 files and directories currently installed.)
Unpacking sabnzbdplus-theme-plush (from .../sabnzbdplus-theme-plush_0.7.18-0ubuntu1~jcfp1~precise_all.deb) ...
Selecting previously unselected package sabnzbdplus.
Unpacking sabnzbdplus (from .../sabnzbdplus_0.7.18-0ubuntu1~jcfp1~precise_all.deb) ...
Selecting previously unselected package sabnzbdplus-theme-classic.
Unpacking sabnzbdplus-theme-classic (from .../sabnzbdplus-theme-classic_0.7.18-0ubuntu1~jcfp1~precise_all.deb) ...
Selecting previously unselected package sabnzbdplus-theme-smpl.
Unpacking sabnzbdplus-theme-smpl (from .../sabnzbdplus-theme-smpl_0.7.18-0ubuntu1~jcfp1~precise_all.deb) ...
Processing triggers for man-db ...
Setting up sabnzbdplus-theme-plush (0.7.18-0ubuntu1~jcfp1~precise) ...
Setting up sabnzbdplus (0.7.18-0ubuntu1~jcfp1~precise) ...
Installing new version of config file /etc/init.d/sabnzbdplus ...
[ ok ] Starting SABnzbd+ binary newsgrabber:.
Setting up sabnzbdplus-theme-classic (0.7.18-0ubuntu1~jcfp1~precise) ...
Setting up sabnzbdplus-theme-smpl (0.7.18-0ubuntu1~jcfp1~precise) ...
[email protected]:~$ sabnzbdplus --version | head -3

sabnzbdplus-0.7.18

t works ! I would be more careful in the future ..
If you were in France , I would have paid you a meal at the restaurant.
Congratulations for your work!

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Howto: updating in Debian proper

Post by sander » October 2nd, 2014, 11:23 am

Cool!

So where in France is that restaurant?

cyrben
Newbie
Newbie
Posts: 13
Joined: September 29th, 2014, 8:42 am

Re: Howto: updating in Debian proper

Post by cyrben » October 2nd, 2014, 12:43 pm

:D Hello.

Paris, the most beautiful city of the world..of course

:D

fudgi
Newbie
Newbie
Posts: 2
Joined: May 21st, 2017, 8:20 am

Re: Howto: updating in Debian proper

Post by fudgi » May 21st, 2017, 8:25 am

Hi, i hope someone can help me with Debian wheezy:

I had already installed sabnzbd 1.0.2 and now wanted to upgrade to 2.0.0 and did everything what the first post said which worked fone, till i did:

>> apt-get -o APT::Install-Recommends=1 install sabnzbdplus
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
libapache2-mod-rpaf : Hängt ab von: apache2-api-20120211
psa-imp : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
psa-ingo : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
psa-kronolith : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
psa-mnemo : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
sabnzbdplus : Beschädigt: sabnzbdplus-theme-classic aber 1.0.2-0ubuntu1~jcfp1~precise soll installiert werden
Beschädigt: sabnzbdplus-theme-glitter aber 1.0.2-0ubuntu1~jcfp1~precise soll installiert werden
Beschädigt: sabnzbdplus-theme-plush aber 0.6.15-1 soll installiert werden
Beschädigt: sabnzbdplus-theme-smpl aber 1.0.2-0ubuntu1~jcfp1~precise soll installiert werden
sabnzbdplus-theme-smpl : Hängt ab von: sabnzbdplus (= 1.0.2-0ubuntu1~jcfp1~precise) aber 2.0.1~rc1-0ubuntu1~jcfp1~precise soll installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

as far as i understand psa-horde for example is missing... but it cant be installed... anyone got n idea what i can do?

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Howto: updating in Debian proper

Post by sander » May 21st, 2017, 2:51 pm

Did you run "apt --fix-broken install" ?

fudgi
Newbie
Newbie
Posts: 2
Joined: May 21st, 2017, 8:20 am

Re: Howto: updating in Debian proper

Post by fudgi » May 23rd, 2017, 1:11 pm

yes i have, did nothing for me

User avatar
jcfp
Release Testers
Release Testers
Posts: 849
Joined: February 7th, 2008, 12:45 pm

Re: Howto: updating in Debian proper

Post by jcfp » May 23rd, 2017, 1:37 pm

You have plenty of other problems, none of which are in any way related to sab:
fudgi wrote: libapache2-mod-rpaf : Hängt ab von: apache2-api-20120211
psa-imp : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
psa-ingo : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
psa-kronolith : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
psa-mnemo : Hängt ab von: psa-horde (>= 5.1.6) ist aber nicht installierbar
With a previous version of sabnzbdplus already installed (from either standard debian repositories or from the ppa) the apt-get update && apt-get dist-upgrade step takes care of the entire package update. No need for any subsequent apt-get -o APT::Install-Recommends=1 install sabnzbdplus in that situation. I cannot predict what happens when unrelated broken stuff gets in the way though.

odoll
Newbie
Newbie
Posts: 6
Joined: July 9th, 2011, 8:24 am

Which is the right Ubuntu version for Debian Stretch (9)?

Post by odoll » June 19th, 2017, 3:57 am

As an early bird ;-) I upgraded my Cubietruck arm based Debian Jessie (8.8) to Stretch (9.0) yesterday.

I usually used the sabnzbdplus_2.1.0-0ubuntu1~jcfp1~precise_all.deb - also in Jessie - to install it via "dpkg -i".

I thought it would be time to skip the manual steps in the future and added the following two lines to sources.list:
  • ppa.launchpad.net/jcfp/ppa/ubuntu xenial main
    ppa.launchpad.net/jcfp/ppa/ubuntu xenial main
as I thought this would be the closest LTS match, as of
  • 17.04 zesty stretch / sid
    16.10 yakkety stretch / sid
    16.04 xenial stretch / sid
    15.10 wily jessie / sid
    15.04 vivid jessie / sid
    14.10 utopic jessie / sid
    14.04 trusty jessie / sid
    13.10 saucy wheezy / sid
    13.04 raring wheezy / sid
    12.10 quantal wheezy / sid
    12.04 precise wheezy / sid
    11.10 oneiric wheezy / sid
    11.04 natty squeeze / sid
    10.10 maverick squeeze / sid
    10.04 lucid squeeze / sid
After the upgrade everything still works fine, incl. sabnzbd, however I get the following warning / error:
  • [email protected]:~# apt-get update
    [...]
    Hit:4 ppa.launchpad.net/jcfp/ppa/ubuntu xenial InRelease
    [...]
    Reading package lists... Done
    [email protected]:~# apt-get upgrade
    [...]
    The following packages have been kept back:
    sabnzbdplus
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    [email protected]:~# apt-get -s install sabnzbdplus
    [...]
    The following packages have unmet dependencies:
    sabnzbdplus : Depends: libjs-jquery (< 3) but 3.1.1-2 is to be installed
    E: Unable to correct problems, you have held broken packages.
So which package for Ubuntu would work with Stretch?

PS: had the "remove" links to be able to post this!

User avatar
sander
Release Testers
Release Testers
Posts: 6050
Joined: January 22nd, 2008, 2:22 pm

Re: Howto: updating in Debian proper

Post by sander » June 19th, 2017, 6:26 am

@odoll:

with "trusty" it works for me on Stretch.

Code: Select all

# cat /etc/apt/sources.list
deb http://deb.debian.org/debian stretch main contrib non-free
deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free

deb http://ppa.launchpad.net/jcfp/ppa/ubuntu trusty main

odoll
Newbie
Newbie
Posts: 6
Joined: July 9th, 2011, 8:24 am

Re: Howto: updating in Debian proper

Post by odoll » June 19th, 2017, 9:15 am

Thx Sander, for me as well (though I find it odd)

Code: Select all

[email protected]:~# apt-get install sabnzbdplus
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libjs-jquery libjs-jquery-ui
Suggested packages:
  libjs-jquery-ui-docs python-gtk2 python-notify
Recommended packages:
  consolekit libavahi-compat-libdnssd1 python-dbus
The following NEW packages will be installed:
  libjs-jquery libjs-jquery-ui
The following packages will be upgraded:
  sabnzbdplus
1 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,655 kB of archives.
After this operation, 2,869 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ftp.de.debian.org/debian stretch/main armhf libjs-jquery all 3.1.1-2 [154 kB]
Get:2 http://ppa.launchpad.net/jcfp/ppa/ubuntu trusty/main armhf sabnzbdplus all 2.1.0-0ubuntu1~jcfp1~trusty [1,269 kB]
Get:3 http://ftp.de.debian.org/debian stretch/main armhf libjs-jquery-ui all 1.12.1+dfsg-4 [232 kB]
Fetched 1,655 kB in 3s (504 kB/s)
Selecting previously unselected package libjs-jquery.
(Reading database ... 60286 files and directories currently installed.)
Preparing to unpack .../libjs-jquery_3.1.1-2_all.deb ...
Unpacking libjs-jquery (3.1.1-2) ...
Selecting previously unselected package libjs-jquery-ui.
Preparing to unpack .../libjs-jquery-ui_1.12.1+dfsg-4_all.deb ...
Unpacking libjs-jquery-ui (1.12.1+dfsg-4) ...
Preparing to unpack .../sabnzbdplus_2.1.0-0ubuntu1~jcfp1~trusty_all.deb ...
[ ok ] Stopping SABnzbd+ binary newsgrabber:.
Unpacking sabnzbdplus (2.1.0-0ubuntu1~jcfp1~trusty) over (2.1.0-0ubuntu1~jcfp1~precise) ...
Setting up libjs-jquery (3.1.1-2) ...
Processing triggers for mime-support (3.60) ...
Setting up libjs-jquery-ui (1.12.1+dfsg-4) ...
Processing triggers for systemd (232-25) ...
Setting up sabnzbdplus (2.1.0-0ubuntu1~jcfp1~trusty) ...
insserv: script mtab.sh: service mtab already provided!
[ ok ] Starting SABnzbd+ binary newsgrabber:.
Processing triggers for man-db (2.7.6.1-2) ...

User avatar
jcfp
Release Testers
Release Testers
Posts: 849
Joined: February 7th, 2008, 12:45 pm

Re: Which is the right Ubuntu version for Debian Stretch (9)

Post by jcfp » June 20th, 2017, 3:44 am

odoll wrote:sabnzbdplus : Depends: libjs-jquery (< 3) but 3.1.1-2 is to be installed
That upper limit was put in place to avoid some javascript issues and incompatibilities that have since been fixed. Just uploaded a bunch of updated files to the ppa, xenial should work on stretch now.

Thanks for reporting!

Post Reply