avahi-daemon won't let me complete installation - Ubuntu 16.04

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
LollyGagger
Newbie
Newbie
Posts: 17
Joined: August 8th, 2016, 11:07 pm

avahi-daemon won't let me complete installation - Ubuntu 16.04

Post by LollyGagger » November 1st, 2017, 10:30 pm

I followed the JCFP PPA directions for installing sabnzbdplus on a fresh Ubuntu 16.04 Linux Container on Proxmox. But I can't get past the below...

Code: Select all

[email protected]:~$ sudo apt-get install par2-tbb
[sudo] password for mozab:
Reading package lists... Done
Building dependency tree
Reading state information... Done
par2-tbb is already the newest version (0.4+20150503-0ubuntu1~jcfp1~xenial).
The following package was automatically installed and is no longer required:
  libgomp1
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up avahi-daemon (0.6.32~rc+dfsg-1ubuntu2) ...
Job for avahi-daemon.service failed because the control process exited with error code. See "systemctl status avahi-daemon.service" and "journalctl -xe" for details.
invoke-rc.d: initscript avahi-daemon, action "start" failed.
* avahi-daemon.service - Avahi mDNS/DNS-SD Stack
   Loaded: loaded (/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2017-11-02 03:10:57 UTC; 4ms ago
  Process: 301 ExecStart=/usr/sbin/avahi-daemon -s (code=exited, status=255)
 Main PID: 301 (code=exited, status=255)

Nov 02 03:10:57 sabnzbd systemd[1]: Starting Avahi mDNS/DNS-SD Stack...
Nov 02 03:10:57 sabnzbd avahi-daemon[301]: Found user 'avahi' (UID 110) and group 'avahi' (GID 117).
Nov 02 03:10:57 sabnzbd systemd[1]: avahi-daemon.service: Main process exited, code=exited, status=255/n/a
Nov 02 03:10:57 sabnzbd systemd[1]: Failed to start Avahi mDNS/DNS-SD Stack.
Nov 02 03:10:57 sabnzbd systemd[1]: avahi-daemon.service: Unit entered failed state.
Nov 02 03:10:57 sabnzbd systemd[1]: avahi-daemon.service: Failed with result 'exit-code'.
dpkg: error processing package avahi-daemon (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libnss-mdns:amd64:
 libnss-mdns:amd64 depends on avahi-daemon (>= 0.6.16-1); however:
  Package avahi-daemon is not configured yet.

dpkg: error processing package libnss-mdns:amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 avahi-daemon
 libnss-mdns:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$ sudo avahi-daemon --configure
avahi-daemon: unrecognized option '--configure'
So it doesn't want to let me install, because avahi-daemon is not configured. But when I try the suggested command to configure it, it says it's not a real command.

I couldn't find anyone else with this issue while installing, and I'm not sure what else to try.

User avatar
sander
Release Testers
Release Testers
Posts: 6131
Joined: January 22nd, 2008, 2:22 pm

Re: avahi-daemon won't let me complete installation - Ubuntu 16.04

Post by sander » November 2nd, 2017, 1:55 am

You're trying to install par2-tbb, but it is already installed "par2-tbb is already the newest version". So no need to do that.

And you're running in a container, so why bother about avahi / bonjour?

Just run sabnzbd.

LollyGagger
Newbie
Newbie
Posts: 17
Joined: August 8th, 2016, 11:07 pm

Re: avahi-daemon won't let me complete installation - Ubuntu 16.04

Post by LollyGagger » November 2nd, 2017, 8:36 am

Thanks, I wasn't sure what else avahi accomplished aside from bluetooth stuff (I had never heard of it).

I tried to run it anyways, and it says it's running, but I can't get anything to showup with localip:800 on my browser.

Code: Select all

[email protected]:~$ systemctl status sabnzbdplus
* sabnzbdplus.service - LSB: SABnzbd+ binary newsgrabber
   Loaded: loaded (/etc/init.d/sabnzbdplus; bad; vendor preset: enabled)
   Active: active (running) since Thu 2017-11-02 13:25:27 UTC; 31s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 197 ExecStart=/etc/init.d/sabnzbdplus start (code=exited, status=0/SU
   CGroup: /system.slice/sabnzbdplus.service
           `-358 /usr/bin/python -OO /usr/bin/sabnzbdplus --daemon --pidfile /va
lines 1-7/7 (END)
* sabnzbdplus.service - LSB: SABnzbd+ binary newsgrabber
   Loaded: loaded (/etc/init.d/sabnzbdplus; bad; vendor preset: enabled)
   Active: active (running) since Thu 2017-11-02 13:25:27 UTC; 31s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 197 ExecStart=/etc/init.d/sabnzbdplus start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/sabnzbdplus.service
           `-358 /usr/bin/python -OO /usr/bin/sabnzbdplus --daemon --pidfile /var/run/sabnzbdplus/pid
The only potentially pertinent entry in journalctl I could find was this:

Code: Select all

Nov 02 13:26:26 sabnzbd console-kit-daemon[400]: (process:506): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Nov 02 13:26:26 sabnzbd console-kit-daemon[400]: missing action

User avatar
sander
Release Testers
Release Testers
Posts: 6131
Joined: January 22nd, 2008, 2:22 pm

Re: avahi-daemon won't let me complete installation - Ubuntu 16.04

Post by sander » November 2nd, 2017, 9:03 am

with localip:800
800? Why? That's not correct

If inside a container, you have to expose the correct port to the host machine ...

systemctl ... ? Why? What if you start sabnzbd from the command line.


IMHO You're trying to do a few (complex) things at the same time. Keep it simple, I would say.

LollyGagger
Newbie
Newbie
Posts: 17
Joined: August 8th, 2016, 11:07 pm

Re: avahi-daemon won't let me complete installation - Ubuntu 16.04

Post by LollyGagger » November 2nd, 2017, 10:52 am

Sorry, that was a typo. I didn't change any of the default settings, I was attempting localip:8080. I did systemctl just as a habit to check whether services are running.

But the point is: it said the service was running (without any errors), but I couldn't access it via localip:8080.

ufw is disabled and this is the output of netstat -n:

Code: Select all

[email protected]:~$ netstat -n
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 192.168.1.17:22         192.168.1.35:64765      ESTABLISHED
tcp        0      0 192.168.1.17:45654      192.168.1.66:445        ESTABLISHED
tcp        0    240 192.168.1.17:22         192.168.1.35:64672      ESTABLISHED
tcp       32      0 192.168.1.17:59380      104.25.236.23:443       CLOSE_WAIT
I've set this up before (just 2 months ago) in the same ubuntu 16.04 container, and did not have to manually expose a port to access it on my LAN; the installation just made it available on port 8080.

Did I miss a step somewhere in this guide?
https://sabnzbd.org/wiki/installation/i ... buntu-repo

If I type `sabnzbd` in the command line it runs, but i need it to autostart and run as a service upon boot. I followed the "How To Run As a Service" portion of that guide, and it shows that it's active and running upon startup, but port 8080 doesn't open unless I manually type sabznbd for some reason.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: avahi-daemon won't let me complete installation - Ubuntu 16.04

Post by jcfp » November 3rd, 2017, 2:25 am

LollyGagger wrote:
November 2nd, 2017, 10:52 am

Code: Select all

[email protected]:~$ netstat -n
Active Internet connections (w/o servers)
... 'without servers' won't show where sab's web interface is, try netstat -tlnp instead
LollyGagger wrote:
November 2nd, 2017, 10:52 am
I've set this up before (just 2 months ago) in the same ubuntu 16.04 container, and did not have to manually expose a port to access it on my LAN; the installation just made it available on port 8080.
That may depend on many things, including container/vm setup and defaults. But first things first.

LollyGagger
Newbie
Newbie
Posts: 17
Joined: August 8th, 2016, 11:07 pm

Re: avahi-daemon won't let me complete installation - Ubuntu 16.04

Post by LollyGagger » November 3rd, 2017, 6:36 am

Manually setting the host IP as 0.0.0.0 did the trick.

Post Reply