Howto: updating in Debian proper

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
beaudett
Newbie
Newbie
Posts: 6
Joined: August 23rd, 2018, 7:48 am

Re: Howto: updating in Debian proper

Post by beaudett » August 27th, 2018, 10:01 am

ok .. I managed to get rid of the error.

I re-installed the following:
apt-get install build-essential libssl-dev libffi-dev python-dev
pip install cryptography --upgrade
apt-get remove sabnzbdplus
apt-get install sabnzbdplus
sabnzbdplus --version | head -3

[email protected]:/home/pi# sabnzbdplus --version | head -3

sabnzbdplus-2.3.4

Thanks for your help

User avatar
sander
Release Testers
Release Testers
Posts: 6672
Joined: January 22nd, 2008, 2:22 pm

Re: Howto: updating in Debian proper

Post by sander » October 26th, 2018, 2:01 pm

AFAIK I don't see the instruction for installing sabyenc via the PPA via Debian.

So here it is for Debian 9.x, all as root:

Code: Select all

echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial main" | tee -a /etc/apt/sources.list
echo "deb http://ppa.launchpad.net/jcfp/sab-addons/ubuntu xenial main" | tee -a /etc/apt/sources.list

apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
apt-get update && apt-get dist-upgrade

apt-get -o APT::Install-Recommends=1 install sabnzbdplus python-sabyenc
and there it is:

Code: Select all

# python -c "import sabyenc; print sabyenc.__version__ "
3.3.5
I had to do this do:

Code: Select all

apt-get install par2 unrar unzip p7zip-rar   -y
And SAB is happy:

Code: Select all

2018-10-26 21:00:40,884::INFO::[sabnzbdplus:397] SABYenc module (v3.3.5)... found!
2018-10-26 21:00:40,886::INFO::[sabnzbdplus:416] Cryptography module... NOT found!
2018-10-26 21:00:40,888::INFO::[sabnzbdplus:419] par2 binary... found (/usr/bin/par2)
2018-10-26 21:00:40,889::INFO::[sabnzbdplus:429] UNRAR binary... found (/usr/bin/unrar)
2018-10-26 21:00:40,891::INFO::[sabnzbdplus:437] UNRAR binary version 5.30
2018-10-26 21:00:40,893::INFO::[sabnzbdplus:442] unzip binary... found (/usr/bin/unzip)
2018-10-26 21:00:40,894::INFO::[sabnzbdplus:447] 7za binary... found (/usr/bin/7za)
As this is on ARM (armhf), I'm again impressed this ecosystem works for different architectures.

pinn
Newbie
Newbie
Posts: 12
Joined: September 18th, 2011, 4:08 am

Re: Howto: updating in Debian proper

Post by pinn » January 22nd, 2019, 5:19 am

sander wrote:
October 26th, 2018, 2:01 pm
AFAIK I don't see the instruction for installing sabyenc via the PPA via Debian.

So here it is for Debian 9.x, all as root:

Code: Select all

echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial main" | tee -a /etc/apt/sources.list
echo "deb http://ppa.launchpad.net/jcfp/sab-addons/ubuntu xenial main" | tee -a /etc/apt/sources.list

apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
apt-get update && apt-get dist-upgrade

apt-get -o APT::Install-Recommends=1 install sabnzbdplus python-sabyenc
and there it is:

Code: Select all

# python -c "import sabyenc; print sabyenc.__version__ "
3.3.5
I had to do this do:

Code: Select all

apt-get install par2 unrar unzip p7zip-rar   -y
And SAB is happy:

Code: Select all

2018-10-26 21:00:40,884::INFO::[sabnzbdplus:397] SABYenc module (v3.3.5)... found!
2018-10-26 21:00:40,886::INFO::[sabnzbdplus:416] Cryptography module... NOT found!
2018-10-26 21:00:40,888::INFO::[sabnzbdplus:419] par2 binary... found (/usr/bin/par2)
2018-10-26 21:00:40,889::INFO::[sabnzbdplus:429] UNRAR binary... found (/usr/bin/unrar)
2018-10-26 21:00:40,891::INFO::[sabnzbdplus:437] UNRAR binary version 5.30
2018-10-26 21:00:40,893::INFO::[sabnzbdplus:442] unzip binary... found (/usr/bin/unzip)
2018-10-26 21:00:40,894::INFO::[sabnzbdplus:447] 7za binary... found (/usr/bin/7za)
As this is on ARM (armhf), I'm again impressed this ecosystem works for different architectures.
Hi,

Trying to follow your instructions to update an installation on a vero4k/raspberry pi. I'm new to linux so running into some difficulties. When I run the command , I get the following:

[email protected]:~$ su echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial main" | tee -a /etc/apt/sources.list
echo "deb http://ppa.launchpad.net/jcfp/sab-addons/ubuntu xenial main" | tee -a /etc/apt/sources.list

apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x987031 23E0F52B2BE16D586EF13930B14BB9F05F
apt-get update && apt-get dist-upgrade

apt-get -o APT::Install-Recommends=1 install sabnzbdplus python-sabyenctee: /etc /apt/sources.list: Permission denied
No passwd entry for user 'echo'
[email protected]:~$ echo "deb http://ppa.launchpad.net/jcfp/sab-addons/ubuntu xenial ma in" | tee -a /etc/apt/sources.list
tee: /etc/apt/sources.list: Permission denied
deb http://ppa.launchpad.net/jcfp/sab-addons/ubuntu xenial main
[email protected]:~$
[email protected]:~$ apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv- keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
Executing: /tmp/apt-key-gpghome.r2cB0sq5M8/gpg.1.sh --keyserver hkp://pool.sks-k eyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
gpg: key F13930B14BB9F05F: public key "Launchpad PPA for jcfp" imported
gpg: Total number processed: 1
gpg: imported: 1
gpg: no writable keyring found: Not found
gpg: error reading '[stdin]': General error
gpg: import from '[stdin]' failed: General error
gpg: Total number processed: 0
[email protected]:~$ apt-get update && apt-get dist-upgrade
Reading package lists... Done
W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Operation not permitted)
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
[email protected]:~$
[email protected]:~$ apt-get -o APT::Install-Recommends=1 install sabnzbdplus python-sabyenc
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
[email protected]:~$ su apt-get -o APT::Install-Recommends=1 install sabnzbdplus python-sabyenc

User avatar
sander
Release Testers
Release Testers
Posts: 6672
Joined: January 22nd, 2008, 2:22 pm

Re: Howto: updating in Debian proper

Post by sander » January 22nd, 2019, 5:25 am

Do you mean what "all as root" means?

You must execute the commands as root. You're trying it to do as normal user ... which gives errors.

pinn
Newbie
Newbie
Posts: 12
Joined: September 18th, 2011, 4:08 am

Re: Howto: updating in Debian proper

Post by pinn » January 22nd, 2019, 5:31 am

sander wrote:
January 22nd, 2019, 5:25 am
Do you mean what "all as root" means?
That is what I attempted:

[email protected]:~$ su echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial main" | tee -a /etc/apt/sources.list
tee: /etc/apt/sources.list: Permission denied
No passwd entry for user 'echo'

User avatar
sander
Release Testers
Release Testers
Posts: 6672
Joined: January 22nd, 2008, 2:22 pm

Re: Howto: updating in Debian proper

Post by sander » January 22nd, 2019, 5:58 am

Easier: become and stay root, with

Code: Select all

sudo su -
Then execute the commands in that root/ sudo / su prompt

pinn
Newbie
Newbie
Posts: 12
Joined: September 18th, 2011, 4:08 am

Re: Howto: updating in Debian proper

Post by pinn » January 22nd, 2019, 6:22 am

sander wrote:
January 22nd, 2019, 5:58 am
Easier: become and stay root, with

Code: Select all

sudo su -
Then execute the commands in that root/ sudo / su prompt
Thanks - that got it. On latest version now but am presented with:

SABnzbd was started with encoding ANSI_X3.4-1968, this should be UTF-8. Expect problems with Unicoded file and directory names in downloads.

I have seen the post here re. this viewtopic.php?t=22483#p111217

but unsure how to proceed - I am in the Uk so is that what I should select?

Sorry for the basic questions!

---------------------

Found the answer here: https://www.raspberrypi.org/forums/view ... hp?t=38231

When attempting to activate the en_US.UTF-8 UTF-8 locale, I was hitting the Enter key. The enter key does NOT select the locale option. Instead it activates the <Ok> button effectively advancing to the next screen without activating the locale. What I needed to do was to highlight the en_US.UTF-8 UTF-8 and mark it as active using the spacebar. Then press enter or tab over to the <Ok> button

--------

Thanks for all your help!

Schugar
Newbie
Newbie
Posts: 24
Joined: October 3rd, 2012, 3:45 pm

Re: Howto: updating in Debian proper

Post by Schugar » March 16th, 2019, 2:21 pm

I can install sabnzbdplus on my raspberry pi with raspbian stretch. It failed to import the public key. This is what i have when i import the key

Code: Select all

apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
Executing: /tmp/apt-key-gpghome.qMPMdFibD0/gpg.1.sh --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
gpg: key F13930B14BB9F05F: public key "Launchpad PPA for jcfp" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: no writable keyring found: Not found
gpg: error reading '[stdin]': General error
gpg: import from '[stdin]' failed: General error
gpg: Total number processed: 0
and when i update the source

Code: Select all

sudo apt update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Get:3 http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial InRelease [17.5 kB]     
Err:3 http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial InRelease               
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F13930B14BB9F05F
Reading package lists... Done
W: GPG error: http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F13930B14BB9F05F
E: The repository 'http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

User avatar
sander
Release Testers
Release Testers
Posts: 6672
Joined: January 22nd, 2008, 2:22 pm

Re: Howto: updating in Debian proper

Post by sander » March 16th, 2019, 4:08 pm

Did you put "sudo" as first command?

Schugar
Newbie
Newbie
Posts: 24
Joined: October 3rd, 2012, 3:45 pm

Re: Howto: updating in Debian proper

Post by Schugar » March 16th, 2019, 4:32 pm

Yes. This is the output. It takes very long time before the error is displayed.

Code: Select all

sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
Executing: /tmp/apt-key-gpghome.eB6VTqNw9Q/gpg.1.sh --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
gpg: keyserver receive failed: No data

Schugar
Newbie
Newbie
Posts: 24
Joined: October 3rd, 2012, 3:45 pm

Re: Howto: updating in Debian proper

Post by Schugar » March 17th, 2019, 11:08 am

Works now. Perhaps there was a problem with the server?

Post Reply