Ubuntu 20.04 new install not checking/downloading

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

Hi,
I hope I have not posted in the wrong area.
I currently have an issue with SabNZBplus loading properly but not activating any check process or download process for a valid NZB file. The logs on info, error and/or debug do not show any issues.
The system just does not do anything - it checks the NZB is OK (from log perspective) and then does nothing (system sits in run state with no additional data retrieved according to dashboard)

Current install and status:
- latest build from nobetas on Ubuntu 20.04. I think this is the 3.0.0 /dev (from log)
- I also have both repositories loaded based on 'sudo add-apt-repository ppa:jcfp/nobetas' and 'sudo add-apt-repository ppa:jcfp/sab-addons'
- The install was based on the two commands:
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get install sabnzbdplus python-sabyenc
(although the install of python-sabyenc fails telling me there is no package to retrieve - although the log clearly shows that sabyenc is loaded as version 4)
- The program installed normally, loads normally, performs successful server tests against usenet servers, loads up new NZB's normally, and appears to function normally but does nothing.
- The log informs me it thinks everything is normal from a program module perspective, using Python v3
- The repository updated the current install from 2.3.9 to 3.0.0 when I updated to Ubuntu 20.04 and since then it has not functioned.
- I then totally removed the package and any dependencies, removed user .sabnzbd directory and did full new clean install - still the same problem

I have used sabnzbd for many years with great success from Ubuntu 16.04 onwards through each 6 month version upgrade.
I have always used the nobetas repositories to ensure i am on the latest stable version.

I also noticed that even though I am using the nobetas repository I appear to have been moved to the alpha or dev version (3.0.0) for Ubuntu 20.04 ??

Only upon this upgrade to Ubuntu 20.04 and what appears to be the non stable version have I encountered this problem.
Any assistance on troubleshooting the problem would be gratfully appreciated.

Regards,
Parrameister

User avatar
sander
Release Testers
Release Testers
Posts: 6910
Joined: January 22nd, 2008, 2:22 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by sander »

In SABnzbd's upper right corner, click on the wrench symbol ("Status and interface options"), then click on first tab Status, and there click on "Test download" 100MB or 1000MB.

What is the result?

parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

Hi,
I ran the test as you suggested.
It did exactly the same as per my first post using a normal NZB.
It had a short burst of activity to grab about 10-12k of data (small) then did nothing.
It displayed "checking..."
I then pressed pause on the job and it continued but removed the word "checking" and looked like the normal mode for download.
It then sat there and did nothing - so I deleted>removed the job and shutdown.

Part of the log is below (I apologise for the length - so have trimmed pieces that were almost similar entries (like grabbing various rar parts or establishing multiple connections (which I have set to 20).
I also removed any url reference and file symbols as I cannot post links.
020-05-21 21:48:47,130::INFO::[sabnzbdplus:1097] sabnzbdplus-3.0.0-develop (rev=unknown)
2020-05-21 21:48:47,130::INFO::[sabnzbdplus:1098] Full executable path = >usr>bin>sabnzbdplus
2020-05-21 21:48:47,130::INFO::[sabnzbdplus:1108] Platform = posix
2020-05-21 21:48:47,130::INFO::[sabnzbdplus:1109] Python-version = 3.8.2 (default, Apr 27 2020, 15:53:34)
[GCC 9.3.0]
2020-05-21 21:48:47,130::INFO::[sabnzbdplus:1110] Arguments = >usr>bin>sabnzbdplus --browser 1
2020-05-21 21:48:47,130::INFO::[sabnzbdplus:1114] Not inside a docker container
2020-05-21 21:48:47,131::INFO::[sabnzbdplus:1117] Preferred encoding = UTF-8
2020-05-21 21:48:47,131::INFO::[sabnzbdplus:1124] SSL version = OpenSSL 1.1.1f 31 Mar 2020
2020-05-21 21:48:47,132::DEBUG::[sabnzbdplus:1137] Available certificates: {'x509': 0, 'crl': 0, 'x509_ca': 0}
2020-05-21 21:48:47,132::DEBUG::[sabnzbdplus:1144] My local IPv4 address = <REMOVED>
2020-05-21 21:48:48,542::DEBUG::[sabnzbdplus:1150] My public IPv4 address = <REMOVED>
2020-05-21 21:48:48,542::DEBUG::[sabnzbdplus:1158] Could not determine my IPv6 address
2020-05-21 21:48:48,871::DEBUG::[sabnzbdplus:1164] CPU Pystone available performance = 274448
2020-05-21 21:48:48,890::DEBUG::[sabnzbdplus:1169] CPU model = Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz
2020-05-21 21:48:48,890::INFO::[sabnzbdplus:1171] Using INI file >home><USERNAME>>.sabnzbd>sabnzbd.ini
2020-05-21 21:48:48,891::DEBUG::[filesystem:450] Applying permissions 0o775 (octal) to >media><USERNAME>>DataDisk>Downloads>incomplete
2020-05-21 21:48:48,906::DEBUG::[__init__:916] [sabnzbd.load_admin] Loading data for rss_data.sab from >home><USERNAME>>.sabnzbd>admin>rss_data.sab
2020-05-21 21:48:48,906::DEBUG::[__init__:916] [sabnzbd.load_admin] Loading data for totals10.sab from >home><USERNAME>>.sabnzbd>admin>totals10.sab
2020-05-21 21:48:48,906::DEBUG::[downloader:164] Initializing downloader>decoder
2020-05-21 21:48:48,907::INFO::[postproc:129] Loading postproc queue
2020-05-21 21:48:48,907::DEBUG::[__init__:916] [sabnzbd.load_admin] Loading data for postproc2.sab from >home><USERNAME>>.sabnzbd>admin>postproc2.sab
2020-05-21 21:48:48,907::DEBUG::[__init__:916] [sabnzbd.load_admin] Loading data for queue10.sab from >home><USERNAME>>.sabnzbd>admin>queue10.sab
2020-05-21 21:48:48,907::DEBUG::[__init__:916] [sabnzbd.load_admin] Loading data for watched_data2.sab from >home><USERNAME>>.sabnzbd>admin>watched_data2.sab
2020-05-21 21:48:48,908::INFO::[__init__:912] [sabnzbd.load_admin] >home><USERNAME>>.sabnzbd>admin>Rating.sab missing
2020-05-21 21:48:48,908::DEBUG::[scheduler:180] Scheduling RSS interval task every 60 min (delay=48)
2020-05-21 21:48:48,908::INFO::[scheduler:197] Setting schedule for midnight BPS reset
2020-05-21 21:48:48,908::DEBUG::[__init__:580] PAUSED_ALL inactive
2020-05-21 21:48:48,908::INFO::[__init__:340] All processes started
2020-05-21 21:48:48,909::INFO::[sabnzbdplus:278] Template location for Glitter is >usr>share>sabnzbdplus>interfaces>Plush
2020-05-21 21:48:48,909::INFO::[sabnzbdplus:278] Template location for Config is >usr>share>sabnzbdplus>interfaces>Config
2020-05-21 21:48:48,910::INFO::[config:852] Writing settings to INI file >home><USERNAME>>.sabnzbd>sabnzbd.ini
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:379] SABYenc module (v4.0.1)... found!
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:391] Cryptography module (v2.8)... found!
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:394] par2 binary... found (>usr>bin>par2)
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:406] UNRAR binary... found (>usr>bin>unrar)
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:414] UNRAR binary version 5.61
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:421] unzip binary... found (>usr>bin>unzip)
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:426] 7za binary... found (>usr>bin>7za)
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:432] nice binary... found (>usr>bin>nice)
2020-05-21 21:48:49,085::INFO::[sabnzbdplus:436] ionice binary... found (>usr>bin>ionice)
2020-05-21 21:48:49,086::INFO::[sabnzbdplus:1324] Starting web-interface on 127.0.0.1:8080
2020-05-21 21:48:49,086::INFO::[_cplogging:219] [21>May>2020:21:48:49] ENGINE Bus STARTING
2020-05-21 21:48:49,088::INFO::[_cplogging:219] [21>May>2020:21:48:49] ENGINE Started monitor thread '_TimeoutMonitor'.
2020-05-21 21:48:49,210::INFO::[_cplogging:219] [21>May>2020:21:48:49] ENGINE Serving on link--127.0.0.1:8080
2020-05-21 21:48:49,210::INFO::[_cplogging:219] [21>May>2020:21:48:49] ENGINE Bus STARTED
2020-05-21 21:48:49,211::INFO::[sabnzbdplus:1366] Starting sabnzbdplus-3.0.0-develop
2020-05-21 21:48:49,212::DEBUG::[__init__:351] Starting postprocessor
2020-05-21 21:48:49,217::DEBUG::[__init__:354] Starting assembler
2020-05-21 21:48:49,219::DEBUG::[__init__:357] Starting downloader
2020-05-21 21:48:49,221::DEBUG::[scheduler:209] Starting scheduler
2020-05-21 21:48:49,224::DEBUG::[__init__:362] Starting dirscanner
2020-05-21 21:48:49,226::INFO::[dirscanner:370] Dirscanner starting up
2020-05-21 21:48:49,228::DEBUG::[__init__:367] Starting urlgrabber
2020-05-21 21:48:49,229::INFO::[postproc:219] Completed Download Folder >media><USERNAME>>DataDisk>Downloads>complete is not on FAT
2020-05-21 21:48:49,231::INFO::[urlgrabber:83] URLGrabber starting up
2020-05-21 21:48:49,231::INFO::[panic:206] Launching browser with link--127.0.0.1:8080>sabnzbd
2020-05-21 21:48:49,533::INFO::[notifier:180] Send to NotifyOSD: SABnzbd > SABnzbd 3.0.0-develop started
2020-05-21 21:48:49,538::DEBUG::[misc:335] Version check disabled by Debian>Ubuntu packaging
2020-05-21 21:48:49,538::INFO::[zconfig:76] Bonjour>ZeroConfig does not support "localhost"
2020-05-21 21:48:49,677::DEBUG::[__init__:1127] Test IPv6: Cannot reach IPv6 test host. Disabling IPv6
2020-05-21 21:48:49,677::DEBUG::[downloader:411] External IPv6 test result: False
2020-05-21 21:48:50,498::DEBUG::[downloader:415] SSL verification test: True

parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

Part 2 of my post :
I cannot post the part of the log that shows the test (constraints as new user and links)
The log appears to show a normal progression to grabbing the test NZB getting data by connecting to usenet server.
But then nothing happens and the time that the job needs to complete keeps climbing each second.
Regards,
Parrameister

User avatar
sander
Release Testers
Release Testers
Posts: 6910
Joined: January 22nd, 2008, 2:22 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by sander »

You have left out the most interesting part: the downloading...

User avatar
sander
Release Testers
Release Testers
Posts: 6910
Joined: January 22nd, 2008, 2:22 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by sander »

parrameister wrote:
May 21st, 2020, 7:52 am
Part 2 of my post :
I cannot post the part of the log that shows the test (constraints as new user and links)
The log appears to show a normal progression to grabbing the test NZB getting data by connecting to usenet server.
But then nothing happens and the time that the job needs to complete keeps climbing each second.
Regards,
Parrameister

You can use pastebin , and put the url with spaces here.

parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

Hi Sander,
I have put the second part of log (contains first part as well) into pastebin (as you suggested)
The log is at: pastbin.com /raw/ Z54Eqs2D

Hope it provides some insight into my issue.

User avatar
sander
Release Testers
Release Testers
Posts: 6910
Joined: January 22nd, 2008, 2:22 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by sander »

http://pastebin.com/raw/Z54Eqs2D

This is bad:

2020-05-21 21:56:01,379::INFO::[downloader:491] [email protected]: Initiating connection
2020-05-21 21:56:01,918::INFO::[happyeyeballs:146] Quickest IP address for eu.newsdemon.com (port 563, ssl 1, preferipv6 True) is None
2020-05-21 21:56:01,918::DEBUG::[happyeyeballs:150] Happy Eyeballs lookup and port connect took 539 ms
2020-05-21 21:56:01,919::DEBUG::[downloader:135] eu.newsdemon.com: No successful IP connection was possible
2020-05-21 21:56:01,920::INFO::[downloader:491] [email protected]: Initiating connection
2020-05-21 21:56:01,921::DEBUG::[downloader:112] eu.newsdemon.com: Re-using address eu.newsdemon.com

No IP address found, because no test connection was possible.

nothing for us.newsdemon.com

So check your DNS, your network, your Newsserver login.

In SABnzbd's upper right corner, click on the wrench symbol ("Status and interface options"), then click on first tab Status: what do you see at IP, public IP, and DNS?

parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

Sander,
Everything appears to be correct (I masked some of my IP addresses below - but they values in them and not 'X''s!)
The values were:
Local IPv4 address: 10.10.X.X
Public IPv4 address: 37.XXX.X.X
IPv6 address: None
Nameserver / DNS Lookup: OK

I did a lookup of my IP and it corresponds with the value above:

I am using a VPN - which is based on a TCP connection and not UDP.
The VPN is based on OpenVPN. I seem to be able to do other normal web activities over this link - browsing/downloading/etc.
I use the firefox browsr (have for years)
The same machine is dual boot Windows 10 /Linux (Ubuntu 20.04).
I tried connecting over VPN in Windows 10 (I use a provided VPN windows client) and run the windows version of sabnzbd 2.3.9 in the same browser firefox
This connects and works as per expected retrieving files from the same usenet servers.

I ran test again checked in log and still get hose entries:
2020-05-23 16:30:18,491::DEBUG::[downloader:135] us.newsdemon.com: No successful IP connection was possible
2020-05-23 16:30:19,746::INFO::[newswrapper:195] -[email protected]: Connected using TLSv1.2 (AES128-SHA)
2020-05-23 16:30:27,347::INFO::[happyeyeballs:146] Quickest IP address for eu.newsdemon.com (port 563, ssl 1, preferipv6 True) is None
2020-05-23 16:30:27,347::DEBUG::[happyeyeballs:150] Happy Eyeballs lookup and port connect took 436 ms
2020-05-23 16:30:27,347::DEBUG::[downloader:135] eu.newsdemon.com: No successful IP connection was possible
2020-05-23 16:30:28,371::INFO::[newswrapper:195] -[email protected]: Connected using TLSv1.2 (AES128-SHA)

It is nothing to do with the TLS version or crypto type is it ?

User avatar
sander
Release Testers
Release Testers
Posts: 6910
Joined: January 22nd, 2008, 2:22 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by sander »

http://127.0.0.1:8080/sabnzbd/config/server/ -> eu.newsdemon.com -> Test Server ... what is the result?

It is nothing to do with the TLS version or crypto type is it ?
You can try yourself.

parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

Sander,
I always get a successful connection on Test Server.
I have also added another server (which is the usenet main server geo load balanced instead of specific us and eu servers)
I put eu and us servers as priority 1 and 2 and put the main server news.newsdemon.com to priority 0.
I also got successful test server results.

I ran test again but logs still show no IP address is allocated (as per the earlier posts)
Basically that is th epart that seems to fail - although everything else appears normal.

I also went and disabled my firewall as a double check - but still get the same result as above.

I then went back to windows and ran the VPN and sabnzbd 2.3.9 to see if that still works with the same server and login details.
I checked in the Windows version and the crypto and TLS versions were the same and OK in the usenet server test from the FAQ check site.
It successfully completes the test.

Very strange. Has anyone else reported issues with Ubuntu 20.04 ?

parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

Just as an additional test - I also tried without the VPN (i.e. straight internet) on and I still get the same result - IP address is none.

User avatar
jcfp
Release Testers
Release Testers
Posts: 930
Joined: February 7th, 2008, 12:45 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by jcfp »

Happyeyeballs returning None is a bug caused by a hardcoded tls version (issue #1396 on github fixed in commit 26e1a72). That code is used to try to determine the optimal server ip to connect to, but its failure shouldn't prevent sab from connecting anyway.

Did you setup us.newsdemon.com with a lower priority than the eu server?
I also noticed that even though I am using the nobetas repository I appear to have been moved to the alpha or dev version (3.0.0) for Ubuntu 20.04 ??
What you installed is the package from the official ubuntu repositories, based on a git snapshot of version 3.0.0. The nobetas ppa provides 2.3.9, but since that's a lower version you still end up installing 3.0.0. Note that the nobetas ppa will only be updated once 3.0.0 goes final, in the meantime you might want to switch over to the regular ppa.

parrameister
Newbie
Newbie
Posts: 8
Joined: May 20th, 2020, 11:19 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by parrameister »

jcfp, thanks for the response.

In answer to your question I tried various priorities across the mix of servers. Mostly, I did have eu above the us in priority when I tested that way.
I also tested with them all being set to 0.

So my install has the npbetas ppa setup followed by an apt-get-update and upgrade, then the apt-get install sabnzbdplus.
This as you have pointed out installs the 3.0.0 version.

I also removed the package and turned off the nobetas ppa, refreshed cache, did an update/upgrade command and then installed sabnzbd from the Ubuntu software store. This still installed the 3.0.0 version.
So - how do I use/setup the regular ppa so I get 2.3.9 ? or will 2.3.9 not work with Ubuntu 20.04 because it uses Python 2 ?

Again thanks for any input....

User avatar
jcfp
Release Testers
Release Testers
Posts: 930
Joined: February 7th, 2008, 12:45 pm

Re: Ubuntu 20.04 new install not checking/downloading

Post by jcfp »

It's possible to select the version to install on the command line, e.g. sudo apt-get install sabnzbdplus=2.3.* but it would still be an uphill battle in a best case scenario, with python2 versions of both yenc and sabyenc missing for sure and possible some other pretty much essential modules as well. Better try with 3.0.0 beta1, the ppa was updated to that today.

Post Reply