Upgrade Not working [ubuntu 18.04]

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
xfaith
Newbie
Newbie
Posts: 5
Joined: January 12th, 2013, 12:04 am

Upgrade Not working [ubuntu 18.04]

Post by xfaith »

So I was on an older version and decided to try and update,

Ubuntu 18.04.
Was on say 2. something (about a year old)

I typed sudo apt install sabnzbdplus

Which I am not sure if it uses the jcfp package, but trying to run
sabnzbdplus i get the following error:

Not all required Python modules are available, please check requirements.txt
Missiing module: sgmllib

Where is the requirements.txt file?
I cant seem to install the sgmllib
I have python: 3.9 and I believe 3.6

Almost thinking to start from scratch on this server, but looking to see if I can at least get it up in running.

Puzzled
Jr. Member
Jr. Member
Posts: 89
Joined: September 2nd, 2017, 3:02 am

Re: Upgrade Not working

Post by Puzzled »

sgmllib is not included in Python 3 so it sounds like you're trying to run SABnzbd v2.x using Python 3.

xfaith
Newbie
Newbie
Posts: 5
Joined: January 12th, 2013, 12:04 am

Re: Upgrade Not working

Post by xfaith »

cant respond

xfaith
Newbie
Newbie
Posts: 5
Joined: January 12th, 2013, 12:04 am

Re: Upgrade Not working

Post by xfaith »

So I think its installed, it show as Active(exited) under status, but I do not see any process running using ps -ef, nor any open ports. I looked for sabnzbd.py on the system but no luck, tried following the /etc/default and the daemon to find the start file I guess. Totally confused now as I am using the ubuntu ppa for the install, and it shows installed

Not sure what else i could post that might help someone narrow down whats going on.

User avatar
sander
Release Testers
Release Testers
Posts: 7478
Joined: January 22nd, 2008, 2:22 pm

Re: Upgrade Not working

Post by sander »

First things first: what do you get when you type

Code: Select all

sabnzbdplus
(plus <ENTER>)

xfaith
Newbie
Newbie
Posts: 5
Joined: January 12th, 2013, 12:04 am

Re: Upgrade Not working [ubuntu 18.04]

Post by xfaith »

If it type just sabnzbdplus it looks like its trying to load it via python2 (its the missing module) sgmllib.

if i type sudo service sabnzdbplus start it looks to say its acitve. But i think its giving a false positive on it being active.,

User avatar
sander
Release Testers
Release Testers
Posts: 7478
Joined: January 22nd, 2008, 2:22 pm

Re: Upgrade Not working [ubuntu 18.04]

Post by sander »

Uninstall sabnzbdplus

Then again type "sabznbdplus" + ENTER ... what do you get?

Post Reply