Problem on Debian Wheezy armhf

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
User avatar
sander
Release Testers
Release Testers
Posts: 7192
Joined: January 22nd, 2008, 2:22 pm

Problem on Debian Wheezy armhf

Post by sander »

I have Debian GNU/Linux 7.6 (wheezy) on armhf (a Cubox). The plain sabnzbd / sabnzbdplus (version 0.6.15) is running. I want the uptodate SABnzbd.

After a

Code: Select all

echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu $(lsb_release -c -s) main" | sudo tee -a /etc/apt/sources.list && sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
sudo apt-get update
... I get this:

Code: Select all

Err http://ppa.launchpad.net wheezy/main armhf Packages              
  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/jcfp/ppa/ubuntu/dists/wheezy/main/binary-armhf/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
BTW: why is "binary-armhf" tried? Is there a binary needed?

Also the following results in an error:

Code: Select all

echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu lucid main" | tee -a /etc/apt/sources.list
sudo apt-get update
W: Failed to fetch http://ppa.launchpad.net/jcfp/ppa/ubuntu/dists/lucid/Release  Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

Tips how to solve this?

User avatar
sander
Release Testers
Release Testers
Posts: 7192
Joined: January 22nd, 2008, 2:22 pm

Re: Problem on Debian Wheezy armhf

Post by sander »

As

http://ppa.launchpad.net/jcfp/ppa/ubunt ... ary-armhf/ (lucid) does not exist
http://ppa.launchpad.net/jcfp/ppa/ubunt ... ary-armhf/ (trusty) does exist

I tried:

Code: Select all

echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu trusty main" | tee -a /etc/apt/sources.list
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
apt-get update
apt-get upgrade
No error messages. OK. Let's proceed:

Code: Select all

sudo apt-get remove sabnzbdplus 
sudo apt-get install  sabnzbdplus 
results in

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sabnzbdplus : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable
E: Unable to correct problems, you have held broken packages.
Hmmm. Not good.

Tips?

User avatar
jcfp
Release Testers
Release Testers
Posts: 937
Joined: February 7th, 2008, 12:45 pm

Re: Problem on Debian Wheezy armhf

Post by jcfp »

Use http://forums.sabnzbd.org/viewtopic.php?f=16&t=9844 for debian, not the instructions targeting ubuntu.

As you probably figured out, lsb_release on debian unsurprisingly returns a debian release name that doesn't exist on any ppa, causing the 404.
BTW: why is "binary-armhf" tried? Is there a binary needed?
Binary as in 'not the source package'. Listings of available goodies on repositories are organized by hardware-architecture, with arch-independent stuff such as sab simply added to the list for any and all archs. Hence that name.
sabnzbdplus : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable
This probably fails because the chosen ubuntu release is too new compared to wheezy, tripping over the multi-arch support (notice how it says 'python:any' rather than just 'python'). Precise is the closest match for wheezy, should do armhf too.

User avatar
sander
Release Testers
Release Testers
Posts: 7192
Joined: January 22nd, 2008, 2:22 pm

Re: Problem on Debian Wheezy armhf

Post by sander »

OK, now with precise:

Code: Select all

nano /etc/apt/sources.list
echo "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu precise main" | tee -a /etc/apt/sources.list
apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
apt-get update
apt-get upgrade
apt-get remove sabnzbdplus-theme-plush 
apt-get remove sabnzbdplus
apt-get install sabnzbdplus
... and ... bingo! :)

Code: Select all

sabnzbdplus --version | head -3

sabnzbdplus-0.7.18

Thank you!

EDIT:

Ouch: http://forums.sabnzbd.org/viewtopic.php?f=16&t=9844 already says "For wheezy, substitute lucid with precise in the first command:"
Hmmm ... I should read better ... :o

Post Reply