Running SABnzbd as a different user?

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
philz90
Newbie
Newbie
Posts: 1
Joined: July 1st, 2017, 8:15 am

Running SABnzbd as a different user?

Post by philz90 » July 1st, 2017, 8:31 am

Hi everyone,

I am trying to run Sabnzbd as a different user. So far I have found this topic: https://forums.sabnzbd.org/viewtopic.php?p=62589#p62589

What is interesting though, is that I did not have any file from Sabnzbd in etc/default/.

So I created /etc/default/sabnzbdplus and inserted:

Code: Select all

USER=Testuser
This did not work (after a reboot). Still Sabnzbd as user for the process. So I inserted:

Code: Select all

SABNZBD_USER=Testuser
Which also did not work. Last try was:

Code: Select all

SABNZBDPLUS_USER=Testuser
Still no luck. Is there anything left I could try?
Thank you so much for your answers! :)


Cheers,
Philz90

edit:
Information about what I am running:

Code: Select all

Distro: Linux version 4.9.0-0.bpo.3-amd64 ([email protected]) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP Debian 4.9.25-1~bpo8+1 (2017-05-19)

Code: Select all

SAB Version: 2.0.1 [be5bebb]

Code: Select all

Python Version: 2.7.9 (default, Jun 29 2016, 13:08:31) [GCC 4.9.2] [UTF-8]

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: Running SABnzbd as a different user?

Post by jcfp » July 1st, 2017, 9:40 am

philz90 wrote:
July 1st, 2017, 8:31 am
What is interesting though, is that I did not have any file from Sabnzbd in etc/default/.

So I created /etc/default/sabnzbdplus and inserted:
How did you install sabnzbd? The debian packages for the program do come with an init.d script and a corresponding config file in /etc/default/, where one can set the username for the service. That setting is empty by default though and no account for this purpose is created on install either.

Post Reply