Page 1 of 1

Help test the python3 version of sabnzbd [18.04 LTS (bionic) only]

Posted: October 5th, 2019, 9:46 am
by jcfp
There's working but still experimental sabnzbdplus packages using python3 on https://launchpad.net/~jcfp/+archive/ubuntu/private
These were originally intended only for my own private use, but since I've yet to find any major bugs, feel free to have a go at it. The repo is based on a snapshot of the 'develop' branch, so not completely bleeding edge. Existing program and service configuration should work out of the box, do make a backup though.

Code: Select all

# 18.04 LTS (bionic) only!
sudo add-apt-repository ppa:jcfp/private
sudo apt-get update
sudo apt-get dist-upgrade
# or "sudo apt-get install sabnzbdplus" if it's a fresh install
Do: report any bugs you come across. Anything sab itself is to blame for goes on github, for everything else (such as packaging bugs) simply reply to this topic.

Don't: attract the attention of too many newbies to this repo, base some widely published docker on it, put the info on reddit, etc. It's there for the short term, and meant for getting feedback from users capable of writing somewhat useful bug reports.

Re: Help test the python3 version of sabnzbd [18.04 LTS (bionic) only]

Posted: October 6th, 2019, 5:33 am
by sander
Hi jcfp, thank you for doing this.

My laptop is on 19.04 (so not eligible), but my "brixit" box is on 18.04, and it works:

Code: Select all

[email protected]:~$ sabnzbdplus 
2019-10-06 12:32:05,060::INFO::[sabnzbdplus:1097] --------------------------------
2019-10-06 12:32:05,061::INFO::[sabnzbdplus:1098] sabnzbdplus-3.0.0-develop (rev=unknown)
2019-10-06 12:32:05,061::INFO::[sabnzbdplus:1099] Full executable path = /usr/bin/sabnzbdplus
2019-10-06 12:32:05,062::INFO::[sabnzbdplus:1109] Platform = posix
2019-10-06 12:32:05,062::INFO::[sabnzbdplus:1110] Python-version = 3.6.8 (default, Aug 20 2019, 17:12:48) 
[GCC 8.3.0]
Nice.

EDIT: now also activated on my VPS with Ubuntu 18.04
EDIT2: I upgraded my arm64 to Ubuntu 18.04, and sabnzb-3.0.0-ppa runs on that too.

Re: Help test the python3 version of sabnzbd [18.04 LTS (bionic) only]

Posted: October 9th, 2019, 3:08 am
by sander
Problem on my ARM64 Ubuntu 18.04:

See https://github.com/sabnzbd/sabnzbd/issu ... -539698186

So: After a fresh install, the file /etc/default/sabnzbdplus is missing, so I cannot run as a service.

EDIT: solved