(Unofficial) Ubuntu repository for SABnzbd+

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Locked
User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

(Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » March 14th, 2008, 4:05 pm

Using this repository, you can easily install the latest version of the program and its dependencies. Whenever an even newer version of the program is released, you will be automatically notified the same as with any other package update.

As of 28 OCT 2017 supported releases are precise (12.04 LTS), trusty (14.04 LTS), xenial (16.04 LTS), zesty (17.04), artful (17.10) and bionic (18.04 LTS). In order to satisfy all dependencies, both Ubuntu's universe and multiverse repositories must be enabled on your system. Debian users: sabnzbdplus is readily available in squeeze and newer (in contrib); if you're looking to update your Debian install to the latest release please continue here.

You have the choice between two channels: regular or "no betas". The former includes most alpha/beta/rc releases, while the latter is a new, less risky option that only ever gets final releases. Just take your pick!


    The Howto    
First, add the repository. Choose either the regular channel...

Code: Select all

sudo add-apt-repository ppa:jcfp/ppa
...or (if you wish to avoid installing alpha/beta/rc releases) go for the nobetas option:

Code: Select all

sudo add-apt-repository ppa:jcfp/nobetas
Next, tell apt to update:

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
In case you already had an older version of the sabnzbdplus package installed, your system is now fully up to date.
If not, proceed to install the program. All dependencies will be automatically taken care of in this step:

Code: Select all

sudo apt-get -o APT::Install-Recommends=1 install sabnzbdplus
And that's it. To start the program, you have several options (listed in no particular order):
  • From your desktop menu: find the Sabnzbd+ item in the Networking section.
  • As a system service. This will automatically start the program on boot (in the background before you even log in) using the init script provided by the package. Edit /etc/default/sabnzbdplus as per instructions in that file. To test if things work as expected, run:

    Code: Select all

    sudo service sabnzbdplus start
    Although no browser will be auto-started when running the program like this, the web interface is still available at the usual location of http://localhost:8080/ (or whatever other host and port you configured).
  • From the command line. Just execute:

    Code: Select all

    sabnzbdplus
Enjoy!
Last edited by jcfp on May 7th, 2011, 10:11 am, edited 1 time in total.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » March 21st, 2008, 8:35 am

The source package for version 0.3.4 was uploaded to the repository last night, and was successfully built and published shortly thereafter.

DeXeS
Release Testers
Release Testers
Posts: 222
Joined: January 28th, 2008, 1:04 pm
Location: The Netherlands

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by DeXeS » March 21st, 2008, 9:02 am

nice! will use it when reinstalling my ubuntu machine. :)

blis102
Newbie
Newbie
Posts: 1
Joined: April 25th, 2008, 7:16 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by blis102 » April 25th, 2008, 7:24 pm

Awesome work!

After a little bit of messing around I got it to work just fine. Not sure what problem I was running into but its working great now!
Last edited by inpheaux on June 2nd, 2008, 4:46 pm, edited 1 time in total.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » June 2nd, 2008, 5:19 pm

0.4.0rc2 has been uploaded and built. Compared to 0.3.4 the perl dependencies have gone, a recommended dependency for python-pyopenssl has been added (for ssl support), and of course sabnzbd+ has been greatly improved ;D.

In case you are upgrading from the 0.3.4 package and have your system set to not automatically install recommended packages, it might be necessary to install the python-pyopenssl package manually if you want ssl support to work. Otherwise nothing needs to be done but follow normal update procedures when prompted by the system.

The instructions for using the repository in the start post have been rewritten in a bit more generic way, and should work with the current as well as any future version.
Last edited by jcfp on June 2nd, 2008, 7:19 pm, edited 1 time in total.

User avatar
shypike
Administrator
Administrator
Posts: 21005
Joined: January 18th, 2008, 12:49 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by shypike » June 3rd, 2008, 3:49 am

Thank you!

Zyzzya100
Newbie
Newbie
Posts: 2
Joined: June 16th, 2008, 8:38 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by Zyzzya100 » June 16th, 2008, 8:52 am

Nice work with this.

One question though, any idea how to start the program via an ssh session and be able to kill the session without killing the program?  Right now I can start it just fine, but if I close the session it kills sabnzbd+.

User avatar
switch
Moderator
Moderator
Posts: 1512
Joined: January 17th, 2008, 3:55 pm
Location: UK

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by switch » June 16th, 2008, 8:54 am

Try starting sabnzbd with the -d flag (python sabnzbd.py -d)

Zyzzya100
Newbie
Newbie
Posts: 2
Joined: June 16th, 2008, 8:38 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by Zyzzya100 » June 16th, 2008, 10:55 am

switch wrote: Try starting sabnzbd with the -d flag (python sabnzbd.py -d)
That did it, thanks!

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » June 18th, 2008, 1:40 pm

RC3 should be available in 5... 4... 3... 2... 1...  8)

setTopbox
Newbie
Newbie
Posts: 15
Joined: June 18th, 2008, 12:04 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by setTopbox » June 21st, 2008, 2:19 am

Hi,

Thanks for the repository,  much appreciated.    I think there is a small typo in the url if anyone is having trouble with their sources.list.
http://ppa.launchpad.net/jcfp/ubuntu/di ... i386/    "gutsy"  should be "gusty"  which was why I was getting a 404.

Anyways I just thought I would point that out if anyone was getting 404's.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » June 21st, 2008, 5:04 am

setTopbox wrote:Hi,

Thanks for the repository,  much appreciated. I think there is a small typo in the url if anyone is having trouble with their sources.list.
[...] "gutsy"  should be "gusty"  which was why I was getting a 404.

Anyways I just thought I would point that out if anyone was getting 404's.
Thanks for your comments. That url you give loads fine here though, and "gutsy" is in fact the correct release name for Ubuntu 7.10. No idea about the 404 you got, maybe some temporary connection or server problem?

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » July 2nd, 2008, 8:31 am

rc5 is available; some changes were made to the package:
  • Replaced dependency on obsoleted package python-pyopenssl by python-openssl (hardy only).
  • Moved the unrar dependency from suggested to recommended.
Now let's just hope the final comes out before my vacation starts :P

User avatar
shypike
Administrator
Administrator
Posts: 21005
Joined: January 18th, 2008, 12:49 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by shypike » July 2nd, 2008, 10:17 am

Within a week, we hope.
One question about your package.
Do you pre-compile the Python source to PYO files (eg by running "python -OO SABnzbd.py --help")?
This makes startup a bit faster and saves some memory.

Otherwise a fine package.

setTopbox
Newbie
Newbie
Posts: 15
Joined: June 18th, 2008, 12:04 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by setTopbox » July 2nd, 2008, 10:03 pm

jcfp wrote:
setTopbox wrote:Hi,

Thanks for the repository,  much appreciated. I think there is a small typo in the url if anyone is having trouble with their sources.list.
[...] "gutsy"  should be "gusty"  which was why I was getting a 404.

Anyways I just thought I would point that out if anyone was getting 404's.
Thanks for your comments. That url you give loads fine here though, and "gutsy" is in fact the correct release name for Ubuntu 7.10. No idea about the 404 you got, maybe some temporary connection or server problem?
well I feel a little bit silly :)  Not sure what the problem was actually,  putting the URL into a browser was no problem.  But when I would sudo apt-get install it would 404.  I'll try again.  Obviously it's on my end.  Thanks again.

Locked