(Unofficial) Ubuntu repository for SABnzbd+

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Locked
subsense
Newbie
Newbie
Posts: 17
Joined: August 22nd, 2009, 3:17 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by subsense » August 25th, 2009, 2:56 pm

And thanks again, I had to look further though. :-*
It's working like a charm now.
Now let's find a gracefull way to shut is down again, Through the web interface this can be done.
But from xbmc in a shutdown script....

TY!

methanoid
Newbie
Newbie
Posts: 36
Joined: March 7th, 2008, 6:33 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by methanoid » October 22nd, 2009, 8:30 am

Might seem obvious to some but "WHY"? Whats wrong with a standard apt-get install sabnzbdplus from the command line and use that?

Was just about to install SAB on my XBMC Live (Ubuntu based) Asrock 330 and paused....

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » October 22nd, 2009, 12:20 pm

this should explain it pretty well.

menders
Newbie
Newbie
Posts: 2
Joined: November 12th, 2009, 11:29 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by menders » November 12th, 2009, 11:34 am

I'm having a hard time getting sabnzbd to start when my computer boots. I'm on karmic and was using the package from the official repos but switched to your PPA to see if it would make a difference and it hasn't. Here's /etc/default/sabnzbdplus:

Code: Select all

# This file is sourced by /etc/init.d/sabnzbdplus
#
# When SABnzbd+ is started using the init script, the
# --daemon option is always used, and the program is
# started under the account of $USER, as set below.
#
# Each setting is marked either "required" or "optional";
# leaving any required setting unconfigured will cause
# the service to not start.

# [required] user or uid of account to run the program as:
USER=menders

# [optional] full path to the configuration file of your choice;
#            otherwise, the default location (in $USER's home
#            directory) is used:
CONFIG=

# [optional] hostname/ip and port number to listen on:
HOST=0.0.0.0
PORT=8080

# [optional] extra command line options, if any:
EXTRAOPTS=
It starts up fine if I run /etc/init.d/sabnzbdplus start after the system has booted.

Code: Select all

[email protected]:~$ who -r
         run-level 2  2009-11-12 08:22
[email protected]:~$ ls -l /etc/rc2.d/*sabnzbdplus
lrwxrwxrwx 1 root root 21 2009-11-12 08:20 /etc/rc2.d/S98sabnzbdplus -> ../init.d/sabnzbdplus
Any ideas? I'm stumped.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » November 12th, 2009, 2:26 pm

menders wrote:It starts up fine if I run /etc/init.d/sabnzbdplus start after the system has booted.
Setup looks good, and with 0.0.0.0 networking shouldn't be the problem. Partitions/discs that aren't available on bootup? Encrypted homedir? USB drives that only get automounted after login?

menders
Newbie
Newbie
Posts: 2
Joined: November 12th, 2009, 11:29 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by menders » November 12th, 2009, 2:36 pm

Gah! Encrypted home directory!

I feel dumb for missing the obvious. Let me turn off ecryptfs.

Edit: Thanks, jcfp! That was it. ;) Do you want to add a warning to your first post so other users don't make this mistake?
Last edited by menders on November 12th, 2009, 4:21 pm, edited 1 time in total.

beecher
Newbie
Newbie
Posts: 2
Joined: November 15th, 2009, 6:38 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by beecher » November 15th, 2009, 6:25 pm

Hi,

Would it be possible to package SABnzbd+ with multi-core par2 instead of the single threaded version. It is available here: http://chuchusoft.com/par2_tbb/download.html

Thanks.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » November 16th, 2009, 9:58 am

menders wrote:Do you want to add a warning to your first post so other users don't make this mistake?
Creating a list of common errors is a long term, low priority item...
beecher wrote:Would it be possible to package SABnzbd+ with multi-core par2 instead of the single threaded version. It is available here: http://chuchusoft.com/par2_tbb/download.html
The package do not include any par2 executable, it simply relies on the par2 package to provide this. Apart from that, I'm not interested in packaging or maintaining this multicore par2 stuff: I don't have the hardware to test it or benefit from such a thing, and getting those releases to compile can be quite messy in my experience.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » November 26th, 2009, 1:40 pm

Now that 0.5 has finally reached public beta, the start post and the package itself are about to be updated as well. Most importantly:
  • Templates changed: smpl is now the default/fallback interface; the former "Default" is now known as "Classic" and available as sabnzbdplus-theme-classic. Iphone is no more, it's replacement is called "Mobile" and packaged as sabnzbdplus-theme-mobile. It will be automatically installed if you had -theme-iphone installed in 0.4.x but probably needs you to select it again in the config if you want to use it.
  • Anything other than karmic has seen only very limited testing; if you have dependency problems and so on please do report immediately by simply replying to this thread.
  • Gutsy support was dropped, for the time being it is still available as 0.4.12 but it won't receive any more updates.
  • The project Gods tell us that "It is recommended you finish your current queue before upgrading, as a new queue and history will be used for 0.5.x (the old one will still remain, you just need to downgrade)". In case you got upgraded to 0.5 prematurely, don't worry: 1) shutdown any instance of 0.5, 2) download the 0.4.12 source release (SABnzbd-0.4.12-src.tar.gz) from sourceforge, 3) extract it, 4) change into the directory that contains SABnzbd.py, 5) run that using 'python2.5 SABnzbd.py' until your queue is done, and finally 6) switch back to 0.5 by stopping any instance of 0.4, and starting 0.5 using 'sabnzbdplus' or via the init script.
  • Support for end-of-queue action (like shutdown or hibernate) may work if you install the python-dbus and dbus packages. If you use such features on your system, please test and report back. Thanks
Last edited by jcfp on November 26th, 2009, 1:51 pm, edited 1 time in total.

jon-at-an
Newbie
Newbie
Posts: 1
Joined: November 28th, 2009, 10:48 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jon-at-an » November 30th, 2009, 4:55 am

Just to report that sabnzbd+ 0.5beta is broken on intrepid  :'(
sabnzbdplus-theme-smpl 0.5.0~beta1-0ubuntu1~jcfp1~intrepid require libjs-mochikit >= 1.4 but on intrepid official version is 1.3.1-1
This can easely be workaround by manually installing  libjs-mochiki 1.4.2 from jaunty since there is no dependancy. (took me 2 days to figure out the solution since i'm a linux newby :)
Works fine for me now... don't know if you can make something about it...

Thank for the ubuntu package :)

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » November 30th, 2009, 5:19 am

jon-at-an wrote:Just to report that sabnzbd+ 0.5beta is broken on intrepid  :'(
sabnzbdplus-theme-smpl 0.5.0~beta1-0ubuntu1~jcfp1~intrepid require libjs-mochikit >= 1.4 but on intrepid official version is 1.3.1-1
Thanks for reporting. Fix uploaded, issue affected only intrepid.

ezflow
Newbie
Newbie
Posts: 2
Joined: December 3rd, 2009, 1:48 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by ezflow » December 3rd, 2009, 1:53 pm

When i upgrade to the latest beta 0.5 version, i get the following error in firefox:

500 Internal Server Error
The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
  File "/usr/share/sabnzbdplus/cherrypy/_cprequest.py", line 593, in respond
    self.process_headers()
  File "/usr/share/sabnzbdplus/cherrypy/_cprequest.py", line 661, in process_headers
    self.cookie.load(value)
  File "/usr/lib/python2.6/Cookie.py", line 625, in load
    self.__ParseString(rawdata)
  File "/usr/lib/python2.6/Cookie.py", line 656, in __ParseString
    self.__set(K, rval, cval)
  File "/usr/lib/python2.6/Cookie.py", line 578, in __set
    M.set(key, real_value, coded_value)
  File "/usr/lib/python2.6/Cookie.py", line 455, in set
    raise CookieError("Illegal key value: %s" % key)
CookieError: Illegal key value: wpgb_visit_last-http://localhost

i also removed it completely and then installed the beta but still the same issue.
running ubuntu karmic 64bit

thanks.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » December 3rd, 2009, 2:10 pm

ezflow wrote:500 Internal Server Error
The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
  File "/usr/share/sabnzbdplus/cherrypy/_cprequest.py", line 593, in respond
    self.process_headers()
  File "/usr/share/sabnzbdplus/cherrypy/_cprequest.py", line 661, in process_headers
    self.cookie.load(value)
  File "/usr/lib/python2.6/Cookie.py", line 625, in load
    self.__ParseString(rawdata)
  File "/usr/lib/python2.6/Cookie.py", line 656, in __ParseString
    self.__set(K, rval, cval)
  File "/usr/lib/python2.6/Cookie.py", line 578, in __set
    M.set(key, real_value, coded_value)
  File "/usr/lib/python2.6/Cookie.py", line 455, in set
    raise CookieError("Illegal key value: %s" % key)
CookieError: Illegal key value: wpgb_visit_last-http://localhost
That looks alot like this bug in cherrypy. Included cherrypy3 version (also in the ppa package) in sabnzbd+ looks like its older than the commit that should fix that. Try clearing browser cache, if the problem persists file a bug in the beta releases forum to be sure devs notice.

ezflow
Newbie
Newbie
Posts: 2
Joined: December 3rd, 2009, 1:48 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by ezflow » December 4th, 2009, 11:11 am

jcfp wrote:
That looks alot like this bug in cherrypy. Included cherrypy3 version (also in the ppa package) in sabnzbd+ looks like its older than the commit that should fix that. Try clearing browser cache, if the problem persists file a bug in the beta releases forum to be sure devs notice.
why didnt i thought of it before, thnx clearing my cookies fixed it :)

dutch1
Newbie
Newbie
Posts: 4
Joined: December 4th, 2009, 8:04 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by dutch1 » December 4th, 2009, 1:54 pm

thank you my friend
it works

but still a newbee

hans

Locked