(Unofficial) Ubuntu repository for SABnzbd+

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
probedb
Newbie
Newbie
Posts: 17
Joined: July 11th, 2009, 3:35 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by probedb » December 7th, 2009, 4:11 pm

I've posted another bug over here.... https://forums.sabnzbd.org/index.php?to ... icseen#new

This is with Ubuntu 9.10 (sorry keep forgetting the names :) ).

Basically it starts and crashes after 30 seconds to a minute or so. 0.4.9 was fine :/

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » December 10th, 2009, 3:34 pm

probedb wrote:I've posted another bug over here.... https://forums.sabnzbd.org/index.php?to ... icseen#new
Basically it starts and crashes after 30 seconds to a minute or so. 0.4.9 was fine :/
Right now that doesn't look like anything packaging related.

probedb
Newbie
Newbie
Posts: 17
Joined: July 11th, 2009, 3:35 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by probedb » December 10th, 2009, 3:46 pm

jcfp wrote:
probedb wrote:I've posted another bug over here.... https://forums.sabnzbd.org/index.php?to ... icseen#new
Basically it starts and crashes after 30 seconds to a minute or so. 0.4.9 was fine :/
Right now that doesn't look like anything packaging related.
Thanks for the reply. I'm flattening my box this weekend so we'll see what happens with a clean install.

stabu
Jr. Member
Jr. Member
Posts: 64
Joined: December 10th, 2008, 10:02 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by stabu » December 13th, 2009, 8:57 pm

Just updated though the repo and got this error


File "/usr/bin/sabnzbdplus", line 1202, in
    main()
  File "/usr/bin/sabnzbdplus", line 804, in main
    res, msg = config.read_config(inifile)
  File "/usr/share/sabnzbdplus/sabnzbd/decorators.py", line 30, in newFunction
    return f(*args, **kw)
  File "/usr/share/sabnzbdplus/sabnzbd/config.py", line 646, in read_config
    compatibility_fix(CFG['misc'])
  File "/usr/lib/pymodules/python2.6/configobj.py", line 580, in __getitem__
    val = dict.__getitem__(self, key)
KeyError: 'misc'

nm i fixed it, just reinstalled it. ini file was messed up
Last edited by stabu on December 13th, 2009, 9:09 pm, edited 1 time in total.

amerrykan
Newbie
Newbie
Posts: 6
Joined: February 27th, 2009, 1:54 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by amerrykan » January 6th, 2010, 2:50 am

just wanted to pop in and say thank you for your hard work on the SABnzbd+ repository for Ubuntu!

nomad980
Newbie
Newbie
Posts: 6
Joined: December 8th, 2009, 11:04 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by nomad980 » January 10th, 2010, 7:48 pm

Two things:
1) Thanks for making this repo makes life so much easier.
2) Having a few problems with the 0.5.0b5 and same issues with b6:
  a) It seems to crash every so often, with or without downloads in the queue.
  b) If I change the categories the downloads belong to, they are sent to the last place on the queue.
  c) The pages seem to load really slow now compare to when it was on the previous version before 5.

When I check the log it gives me errno 24

Any idea what I can do to get this working again?

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » January 11th, 2010, 6:33 am

nomad980 wrote:   a) It seems to crash every so often, with or without downloads in the queue.
  b) If I change the categories the downloads belong to, they are sent to the last place on the queue.
  c) The pages seem to load really slow now compare to when it was on the previous version before 5.

When I check the log it gives me errno 24
For b): post your issue on the beta forum. Packaging doesn't touch such things and I know nothing about this specific funtionality.

From your other thread this error 24 is about too many open files, which is probably a system limitation. By default, Linux restricts the number of open files to 1024 (google hints: ulimit lsof limits.conf). If something is overloading your system (databases are a common culprit), that might also cause c) (obviously...) and a) (oom killer? check system logs). Most of that is outside the scope of this thread though. You could try to rule out packaging by shutting down any sabnzbdplus process and then running the program directly from a -src.tar.gz download on sourceforge (extract, then run python SABnzbd.py), and see if the problems persist. All dependencies are already there so it should work 'out of the box'.

In general, your post contains very little information but whatever is there hints to general systems administration issues and/or an overloaded system.

nomad980
Newbie
Newbie
Posts: 6
Joined: December 8th, 2009, 11:04 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by nomad980 » January 13th, 2010, 3:38 pm

Thanks for the quick reply jcfp. I changed the limit in the limits.conf. The reason I posted here was because I was told to report it to the maintainer of the repo. The problem happened with the one on the repo and the one from the tar file. I am probably going to go through all my services and running processes to see what could be causing this problem. But all this started happening after 9.10 and 0.5.0 never really had the problem before.

fatboynotsoslim
Newbie
Newbie
Posts: 7
Joined: April 8th, 2009, 10:38 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by fatboynotsoslim » January 18th, 2010, 3:55 pm

jcfp, I've  been using your ubuntu mirror for Jauntry for a long time, thanks for putting in the effort to create it.

Question though, am I able to revert back from the latest beta6 of 0.50? I'm getting very unstable behavior that requires me to physically stop sab (via kill -9 id) every morning, as it just locks up during the night (I download 3-9am) and obviously this isn't ideal. I dont know if its sab of my internet connection, but beta 4 and 5 worked admirably.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » January 19th, 2010, 2:19 am

fatboynotsoslim wrote:Question though, am I able to revert back from the latest beta6 of 0.50? I'm getting very unstable behavior that requires me to physically stop sab (via kill -9 id) every morning, as it just locks up during the night (I download 3-9am) and obviously this isn't ideal. I dont know if its sab of my internet connection, but beta 4 and 5 worked admirably.
Alas, old stuff is actually deleted automatically within 24 hours once superseded by a newer release. Any logs (sab or system) that might help you find out what's wrong?

fatboynotsoslim
Newbie
Newbie
Posts: 7
Joined: April 8th, 2009, 10:38 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by fatboynotsoslim » January 19th, 2010, 3:14 am

jcfp wrote:
fatboynotsoslim wrote:Question though, am I able to revert back from the latest beta6 of 0.50? I'm getting very unstable behavior that requires me to physically stop sab (via kill -9 id) every morning, as it just locks up during the night (I download 3-9am) and obviously this isn't ideal. I dont know if its sab of my internet connection, but beta 4 and 5 worked admirably.
Alas, old stuff is actually deleted automatically within 24 hours once superseded by a newer release. Any logs (sab or system) that might help you find out what's wrong?
I've yet to check my system logs, but basically Sabnzbd will get stuck on a few connections, and selecting force disconnect or restart, 'sudo /etc/init.d/sabnzbdplus stop' wont kill the process. Had to kill the process then start it up again in /etc/init.d. It happened once or twice on earlier versions, hence why I was thinking about ruling out beta6 first, since its happened about 3 times in the last week.

Then again, it was stormy weather last night, and storms + adsl2 don't mix here. The internet could have dropped out and sab acted wierdly from that.

From the sabnzbd.log, here are some interesting lines:

Code: Select all

2010-01-19 03:07:21,655::INFO::[downloader:449] [email protected]:563: Initiating connection
2010-01-19 03:07:32,479::INFO::[newswrapper:203] Failed to connect: (110, '[Errno -2] Name or service not known') [email protected]:563
Happens to most of the threads, none connect then:
2010-01-19 04:52:43,927::INFO::[__init__:753] Restarting crashed scheduler
... Same error
2010-01-19 07:33:26,900::INFO::[__init__:753] Restarting crashed scheduler
2010-01-19 07:34:01,946::INFO::[__init__:278] SABnzbd shutting down...
Thats when I manually reset it, and it started up fine.
EDIT: Just found this referenced in my sabnzbd.error.log file, since it mentioned scheduler and had a timeframe from this morning, I figured it could be related. The socket.ssl error is repeated a lot.

Code: Select all

/usr/share/sabnzbdplus/sabnzbd/utils/ssmtplib.py:116: DeprecationWarning: socket.ssl() is deprecated.  Use ssl.wrap_socket() instead.
  sslobj = socket.ssl(self.sock, self.keyfile, self.certfile)
ERROR DURING SCHEDULER EXECUTION list index out of range
Traceback (most recent call last):
  File "/usr/share/sabnzbdplus/sabnzbd/utils/kronos.py", line 276, in _run
    self.sched.run()
  File "/usr/lib/python2.6/sched.py", line 111, in run
    delayfunc(time - now)
  File "/usr/share/sabnzbdplus/sabnzbd/utils/kronos.py", line 103, in __delayfunc
    toptime = self._getqueuetoptime()
  File "/usr/share/sabnzbdplus/sabnzbd/utils/kronos.py", line 262, in _getqueuetoptime
    return self.sched._queue[0].time
IndexError: list index out of range
Last edited by fatboynotsoslim on January 19th, 2010, 3:16 am, edited 1 time in total.

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » January 19th, 2010, 4:46 am

Nice :(. Report this as a bug in the beta releases forum; be sure to include logging excerpts just like you have here. If you need a b5 (or rc2) package for comparison or further investigation, drop me a pm.

s1nglebarrel
Newbie
Newbie
Posts: 9
Joined: October 24th, 2009, 10:02 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by s1nglebarrel » January 23rd, 2010, 8:46 am

I am getting some weird behavior on the latest RC3 release. After updating when I launc sabnzbd via init.d it fails and drops errors in the logs like the ones below

Code: Select all

Exception in thread HTTPServer Thread-10:
Traceback (most recent call last):
  File "/usr/lib/python2.5/threading.py", line 486, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.5/threading.py", line 446, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 75, in _start_http_thread
    self.httpserver.start()
  File "/usr/share/sabnzbdplus/cherrypy/wsgiserver/__init__.py", line 1629, in start
    raise socket.error, msg
error: (99, 'Cannot assign requested address')
and..

Code: Select all

2010-01-22 13:25:46,854::ERROR::[misc:453] You have no permisson to use port 8181
However if I manually launch sabnzbd with the following command it works (i am logged in as root) just like before.

sabnzbd -d -f /etc/sabnzbd/sabnzbd.ini

Any thoughts?

User avatar
jcfp
Release Testers
Release Testers
Posts: 851
Joined: February 7th, 2008, 12:45 pm

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by jcfp » January 23rd, 2010, 12:31 pm

s1nglebarrel wrote: I am getting some weird behavior on the latest RC3 release. After updating when I launc sabnzbd via init.d it fails and drops errors in the logs like the ones below
The rc3 package has a minor change in the behaviour of the init script. Previously, it would only use the HOST and PORT settings in /etc/default/sabnzbdplus if both were set; now, setting just one of 'm also takes effect. As a result, if you had only the PORT set (which had no effect at all), it will now start using that as --server :port which is where the hostname guessing game begins. Unfortunately, Ubuntu isn't very steadfast in how it handles that.

If the above applies to your setup, try setting something useful for HOST.

Sav
Newbie
Newbie
Posts: 1
Joined: February 10th, 2010, 2:49 am

Re: (Unofficial) Ubuntu repository for SABnzbd+

Post by Sav » February 10th, 2010, 2:51 am

Thanks for this, I was having issues trying to get RC6 installed(I was probably doing somthing wrong), added this repository and its's working.  ;D

Locked