Sabnzdbdplus doesnt start after upgrade

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
hertzal
Newbie
Newbie
Posts: 5
Joined: December 1st, 2011, 6:50 am

Sabnzdbdplus doesnt start after upgrade

Post by hertzal » December 1st, 2011, 6:53 am

Hi guys,

first of all thank you for that great software - i've been using it for a year now....but now i ran into a problem which it seems i cannot resolve it by myself.

i've did an "apt-get update" today .....and also updated the sabnzbdplus deamon as there was an update.

but now i am not able to start the deamon again ....he is crashing with the following error:
Exception in thread HTTPServer Thread-32:
Traceback (most recent call last):
File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
self.run()
File "/usr/lib/python2.6/threading.py", line 484, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 75, in _start_http_thread
self.httpserver.start()
File "/usr/share/sabnzbdplus/cherrypy/wsgiserver/__init__.py", line 1644, in start
raise socket.error, msg
error: [Errno 98] Address already in use


i've tried to change the host ip-adress, the ports for SSL and for HTTP ....but nothing solved the problem.

any ideas how to resolve that problem?! many thanks and cheers!
hertzal

highball
Newbie
Newbie
Posts: 4
Joined: December 1st, 2011, 5:05 am

Re: Sabnzdbdplus doesnt start after upgrade

Post by highball » December 1st, 2011, 7:41 am

Hi to all...

not a solution but nearly the same for me ... "error: [Errno 99] Cannot assign requested address"
Ubuntu 11.04 and an update today with "deb http://ppa.launchpad.net/jcfp/ppa/ubuntu oneiric main" brings me to sabnzbdplus version 0.6.11
But it cannot be started as a deamon (host 0.0.0.0:8080) with the following error.log:
-----------------------------------------------------------------------------------------------------------
Exception in thread HTTPServer Thread-9:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "/usr/lib/python2.7/threading.py", line 505, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 75, in _start_http_thread
self.httpserver.start()
File "/usr/share/sabnzbdplus/cherrypy/wsgiserver/__init__.py", line 1644, in start
raise socket.error, msg
error: [Errno 99] Cannot assign requested address

Exception in thread HTTPServer Thread-9:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "/usr/lib/python2.7/threading.py", line 505, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 75, in _start_http_thread
self.httpserver.start()
File "/usr/share/sabnzbdplus/cherrypy/wsgiserver/__init__.py", line 1644, in start
raise socket.error, msg
error: [Errno 99] Cannot assign requested address

Exception in thread HTTPServer Thread-9:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "/usr/lib/python2.7/threading.py", line 505, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 75, in _start_http_thread
self.httpserver.start()
File "/usr/share/sabnzbdplus/cherrypy/wsgiserver/__init__.py", line 1644, in start
raise socket.error, msg
error: [Errno 99] Cannot assign requested address

Exception in thread HTTPServer Thread-9:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "/usr/lib/python2.7/threading.py", line 505, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 75, in _start_http_thread
self.httpserver.start()
File "/usr/share/sabnzbdplus/cherrypy/wsgiserver/__init__.py", line 1644, in start
raise socket.error, msg
error: [Errno 99] Cannot assign requested address
-----------------------------------------------------------------------------------------------------------
Nothing has changed between the update... only some packages of ubuntu get also updated :-( The "normal" sabnzb LOG shows the following errors:
-----------------------------------------------------------------------------------------------------------
2011-12-01 13:32:46,975::INFO::[sabnzbdplus:1190] --------------------------------
2011-12-01 13:32:46,976::INFO::[sabnzbdplus:1191] sabnzbdplus-0.6.11 (rev=5643b5682f90af5f53e3e6ae6e90e5d3322e8fc7)
2011-12-01 13:32:46,976::INFO::[sabnzbdplus:1203] Platform = posix
2011-12-01 13:32:46,977::INFO::[sabnzbdplus:1204] Python-version = 2.7.2+ (default, Oct 4 2011, 20:06:09)
[GCC 4.6.1]
2011-12-01 13:32:46,977::INFO::[sabnzbdplus:1205] Arguments = "/usr/bin/sabnzbdplus", "--daemon", "--server", "0.0.0.0:8080"
2011-12-01 13:32:46,978::INFO::[sabnzbdplus:1218] Read INI file /home/sabnzb/.sabnzbd/sabnzbd.ini
2011-12-01 13:32:47,022::INFO::[__init__:864] Loading data for bookmarks.sab from /home/sabnzb/.sabnzbd/admin/bookmarks.sab
2011-12-01 13:32:47,023::INFO::[__init__:864] Loading data for rss_data.sab from /home/sabnzb/.sabnzbd/admin/rss_data.sab
2011-12-01 13:32:47,024::INFO::[__init__:864] Loading data for totals9.sab from /home/sabnzb/.sabnzbd/admin/totals9.sab
2011-12-01 13:32:47,026::INFO::[postproc:89] Loading postproc queue
2011-12-01 13:32:47,026::INFO::[__init__:864] Loading data for postproc1.sab from /home/sabnzb/.sabnzbd/admin/postproc1.sab
2011-12-01 13:32:47,028::INFO::[__init__:864] Loading data for queue9.sab from /home/sabnzb/.sabnzbd/admin/queue9.sab
2011-12-01 13:32:47,400::INFO::[__init__:864] Loading data for watched_data.sab from /home/sabnzb/.sabnzbd/admin/watched_data.sab
2011-12-01 13:32:47,403::INFO::[downloader:194] Resuming
2011-12-01 13:32:47,421::INFO::[__init__:289] All processes started
2011-12-01 13:32:47,422::INFO::[sabnzbdplus:332] Web dir is /usr/share/sabnzbdplus/interfaces/Plush
2011-12-01 13:32:47,423::INFO::[sabnzbdplus:332] Web dir is /usr/share/sabnzbdplus/interfaces/Mobile
2011-12-01 13:32:47,473::INFO::[sabnzbdplus:442] _yenc module... found!
2011-12-01 13:32:47,474::INFO::[sabnzbdplus:450] par2 binary... found (/usr/bin/par2)
2011-12-01 13:32:47,476::INFO::[sabnzbdplus:458] unrar binary... found (/usr/bin/unrar)
2011-12-01 13:32:47,477::INFO::[sabnzbdplus:463] unzip binary... found (/usr/bin/unzip)
2011-12-01 13:32:47,478::INFO::[sabnzbdplus:469] nice binary... found (/usr/bin/nice)
2011-12-01 13:32:47,480::INFO::[sabnzbdplus:473] ionice binary... found (/usr/bin/ionice)
2011-12-01 13:32:47,481::INFO::[sabnzbdplus:478] pyOpenSSL... found (True)
2011-12-01 13:32:47,494::INFO::[sabnzbdplus:1385] Starting web-interface on 0.0.0.0:8080
2011-12-01 13:32:47,499::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus STARTING
2011-12-01 13:32:47,522::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Started monitor thread '_TimeoutMonitor'.
2011-12-01 13:32:47,534::ERROR::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Error in HTTP server: shutting down
Traceback (most recent call last):
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 75, in _start_http_thread
self.httpserver.start()
File "/usr/share/sabnzbdplus/cherrypy/wsgiserver/__init__.py", line 1644, in start
raise socket.error, msg
error: [Errno 99] Cannot assign requested address

2011-12-01 13:32:47,536::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus STOPPING
2011-12-01 13:32:47,537::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE HTTP Server None already shut down
2011-12-01 13:32:47,538::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('::1', 8080)) already shut down
2011-12-01 13:32:47,557::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Stopped thread '_TimeoutMonitor'.
2011-12-01 13:32:47,558::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus STOPPED
2011-12-01 13:32:47,559::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus EXITING
2011-12-01 13:32:47,560::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus EXITED
2011-12-01 13:32:47,628::ERROR::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Error in 'start' listener <bound method ServerAdapter.start of <cherrypy.process.servers.ServerAdapter object at 0x1b68c50>>
Traceback (most recent call last):
File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 147, in publish
output.append(listener(*args, **kwargs))
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 62, in start
self.wait()
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 97, in wait
raise self.interrupt
error: [Errno 99] Cannot assign requested address

2011-12-01 13:32:47,733::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Serving on 0.0.0.0:8080
2011-12-01 13:32:47,735::ERROR::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 184, in start
self.publish('start')
File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 147, in publish
output.append(listener(*args, **kwargs))
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 62, in start
self.wait()
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 97, in wait
raise self.interrupt
error: [Errno 99] Cannot assign requested address

2011-12-01 13:32:47,737::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus STOPPING
2011-12-01 13:32:47,743::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('0.0.0.0', 8080)) shut down
2011-12-01 13:32:47,744::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer(('::1', 8080)) already shut down
2011-12-01 13:32:47,745::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE No thread running for _TimeoutMonitor.
2011-12-01 13:32:47,745::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus STOPPED
2011-12-01 13:32:47,746::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus EXITING
2011-12-01 13:32:47,747::INFO::[_cplogging:55] [01/Dec/2011:13:32:47] ENGINE Bus EXITED
2011-12-01 13:32:47,747::ERROR::[sabnzbdplus:1400] Failed to start web-interface:
Traceback (most recent call last):
File "/usr/bin/sabnzbdplus", line 1392, in main
cherrypy.engine.start()
File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 184, in start
self.publish('start')
File "/usr/share/sabnzbdplus/cherrypy/process/wspbus.py", line 147, in publish
output.append(listener(*args, **kwargs))
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 62, in start
self.wait()
File "/usr/share/sabnzbdplus/cherrypy/process/servers.py", line 97, in wait
raise self.interrupt
error: [Errno 99] Cannot assign requested address
2011-12-01 13:32:47,750::ERROR::[sabnzbdplus:302] Fehler beim Starten der Weboberfl¦che. : [Errno 99] Cannot assign requested address
2011-12-01 13:32:47,751::INFO::[__init__:325] SABnzbd shutting down...
2011-12-01 13:32:47,751::INFO::[__init__:840] Saving data for bookmarks.sab in /home/sabnzb/.sabnzbd/admin/bookmarks.sab
2011-12-01 13:32:47,752::INFO::[urlgrabber:70] URLGrabber shutting down
2011-12-01 13:32:47,754::INFO::[__init__:840] Saving data for watched_data.sab in /home/sabnzb/.sabnzbd/admin/watched_data.sab
2011-12-01 13:32:47,755::INFO::[dirscanner:254] Dirscanner shutting down
2011-12-01 13:32:47,756::INFO::[postproc:83] Saving postproc queue
2011-12-01 13:32:47,756::INFO::[__init__:840] Saving data for postproc1.sab in /home/sabnzb/.sabnzbd/admin/postproc1.sab
2011-12-01 13:32:47,758::INFO::[nzbqueue:167] Saving queue
2011-12-01 13:32:48,154::INFO::[__init__:840] Saving data for queue9.sab in /home/sabnzb/.sabnzbd/admin/queue9.sab
2011-12-01 13:32:48,155::INFO::[__init__:840] Saving data for totals9.sab in /home/sabnzb/.sabnzbd/admin/totals9.sab
2011-12-01 13:32:48,157::INFO::[__init__:840] Saving data for rss_data.sab in /home/sabnzb/.sabnzbd/admin/rss_data.sab
2011-12-01 13:32:48,158::INFO::[__init__:840] Saving data for bookmarks.sab in /home/sabnzb/.sabnzbd/admin/bookmarks.sab
2011-12-01 13:32:48,160::INFO::[__init__:840] Saving data for watched_data.sab in /home/sabnzb/.sabnzbd/admin/watched_data.sab
2011-12-01 13:32:48,161::INFO::[postproc:83] Saving postproc queue
2011-12-01 13:32:48,162::INFO::[__init__:840] Saving data for postproc1.sab in /home/sabnzb/.sabnzbd/admin/postproc1.sab
2011-12-01 13:32:48,163::INFO::[__init__:385] All processes stopped
-----------------------------------------------------------------------------------------------------------
The manual call (not as deamon) like: "sabnzbdplus --server 127.0.0.1:8080" is working, but without access from network machines. If i try to start with "sabnzbdplus --server 0.0.0.0:8080" it gives me the same error like the deamon :-(

Thanks in advance
highball

User avatar
jcfp
Release Testers
Release Testers
Posts: 912
Joined: February 7th, 2008, 12:45 pm

Re: Sabnzdbdplus doesnt start after upgrade

Post by jcfp » December 1st, 2011, 9:20 am

I cannot reproduce either scenario (0.0.0.0 works fine here), but there have been relevant code changes in sab recently, so we'll have to wait for the man in charge.

Did any of you have this problem with 0.6.11-rc1? It was available from the ppa for about 10 days, so if you update daily you should have been using that version for the past week or so.

highball
Newbie
Newbie
Posts: 4
Joined: December 1st, 2011, 5:05 am

Re: Sabnzdbdplus doesnt start after upgrade

Post by highball » December 1st, 2011, 9:37 am

I have had this problem also with RC1... I updated on Tuesday to RC1 and have mentioned this problem (there were also many Ubuntu updates) today I have updated to final with apt-get and the problem was not gone... :-( so I decided to take a look here...

As mentioned the problem does not appeard with 127.0.0.1:8080....

Thanks and best regards
highball

hertzal
Newbie
Newbie
Posts: 5
Joined: December 1st, 2011, 6:50 am

Re: Sabnzdbdplus doesnt start after upgrade

Post by hertzal » December 1st, 2011, 10:43 am

I have not test it with RC1 ....but previous version worked well.
i can commit that when i start it without deamon mode, everything seems to be working....but thats not what i need to .....

thanks!

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: Sabnzdbdplus doesnt start after upgrade

Post by shypike » December 1st, 2011, 1:12 pm

Do you happen to have an IPv4-only system (so no IPv6 support at all)?
Another user reported an issue with this.

highball
Newbie
Newbie
Posts: 4
Joined: December 1st, 2011, 5:05 am

Re: Sabnzdbdplus doesnt start after upgrade

Post by highball » December 2nd, 2011, 3:37 am

Thanks! This solved my issue :-)

I have enabled IPv6 on my Ubuntusystem and... it works again: The deamon is runing and starting normal as before :-)

Thanks, thanks, thanks!

Best regards
highball

hertzal
Newbie
Newbie
Posts: 5
Joined: December 1st, 2011, 6:50 am

Re: Sabnzdbdplus doesnt start after upgrade

Post by hertzal » December 2nd, 2011, 8:44 am

i do not have ipv4 enabled on my ubuntu system .........how can i do that ? i have an virtual server .....


thanks!

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: Sabnzdbdplus doesnt start after upgrade

Post by shypike » December 2nd, 2011, 8:52 am

Work-around is to use an empty hostname.
When you use 0.0.0.0, then 127.0.0.1 and ::1 will also be used.
BTW: There will be a new release real soon.

hertzal
Newbie
Newbie
Posts: 5
Joined: December 1st, 2011, 6:50 am

Re: Sabnzdbdplus doesnt start after upgrade

Post by hertzal » December 2nd, 2011, 2:42 pm

i've used 0.0.0.0 since i've installed sabnzbd and i never changed that .......but it doesnt work either......

ok thanks for info ....i'll wait for new version and will try to upgrade soon.

cheers,

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: Sabnzdbdplus doesnt start after upgrade

Post by shypike » December 2nd, 2011, 6:53 pm

In the previous post I told you not to use 0.0.0.0...

butor94
Newbie
Newbie
Posts: 1
Joined: December 5th, 2011, 4:28 pm

Re: Sabnzdbdplus doesnt start after upgrade

Post by butor94 » December 5th, 2011, 4:47 pm

hi there !
first please apologize me for my english..

I upgraded tonight my ubuntu server to 10.04 and when i did it, i saw the job deleting some sabnzbd items.
Now by adding the good source in the sources.list I've been able to reinstall it but I cant make it run properly.

On my server I have only two users : root & butor
the file
/home/butor/.sabnzbd/sabnzbd.ini
survived to my reinstall

Now I just want to launch sabnzbd with this user only to make the sab working with the good ini file...

how can I do this ?

thank you for reading

hertzal
Newbie
Newbie
Posts: 5
Joined: December 1st, 2011, 6:50 am

Re: Sabnzdbdplus doesnt start after upgrade

Post by hertzal » December 12th, 2011, 3:15 pm

you will need to go to /etc/default/sabnzbdplus there you can enter the user in the configuration which should start the daemon - then he should take automatically that ini file (if $HOME is set correct)

good luck!

plenty
Newbie
Newbie
Posts: 1
Joined: February 10th, 2014, 6:55 pm

Re: Sabnzdbdplus doesnt start after upgrade

Post by plenty » February 10th, 2014, 7:07 pm

Old post, I know - but for anyone arriving here for help with "Address Already in Use" within their error logs..
For me, deleting & leaving blank the 'Sabnzbd Host' catagory as previously suggested solved my problem.

Also - If you're using the scheduling function to download throughout the night (perhaps if you're hooked up to sickbeard too), make sure you're not running multiple instances of sabnzbd, which can also cause this error.
If, like me you're running linux, you can check with the following command;

Code: Select all

ps aux | grep sabnzbd
If you see more than one instance, note the number, & kill one or more of them with,

Code: Select all

sudo kill -9 {number}

Post Reply