SABNZBD errors running included Post processing script

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

SABNZBD errors running included Post processing script

Post by dJOS » April 11th, 2018, 2:56 am

G'day all, Im losing my mind, I've been a SABNZBD user for years and just recently thought I'd add the included DeObfuscate py script to one of my categories that seems to be full of Obfuscated files these days.

Anyway, I'm running Windows 2008 R2 Server, SABNZBD 2.3.2, Active Python 2.7.14 and I have all the Paths set including PATHEXT as per the (very light on details) guide - as a result I can successfully run "Python" from anywhere via the command line and it runs no problem. I can also run any py file directly from the command line without issues, including DeObfuscate py.

However, when SABNZBD tries to run the included DeObfuscate py script, it fails with the below error:
"python" is not recognized as an internal or external command, operable program or batch file.
I've googled the hell out of this but i'm completely failing to find a solution.

Can anyone please help?

User avatar
safihre
Administrator
Administrator
Posts: 2889
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: SABNZBD errors running included Post processing script

Post by safihre » April 11th, 2018, 11:15 am

I'm sorry but that OS us really ancient, I can make some suggestions.
Probably it's because you run Sab as a service?
Try installing the real python from python.org, and make sure to check Add Python to path during the installation.

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 11th, 2018, 4:17 pm

safihre wrote:
April 11th, 2018, 11:15 am
I'm sorry but that OS us really ancient, I can make some suggestions.
Probably it's because you run Sab as a service?
Try installing the real python from python org, and make sure to check Add Python to path during the installation.
Yeah I am running it as a service but with admin rights.

Ok I'll try using the "real" python. I had tried it before but I'd installed a v3 version, it wasn't till later that I discovered SABNZBD needs v2 instead.

User avatar
safihre
Administrator
Administrator
Posts: 2889
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: SABNZBD errors running included Post processing script

Post by safihre » April 12th, 2018, 1:33 am

Indeed on the Python website you have to get the 2.7 version.
Otherwise you'll have to Google how to add python to the system wide (nog just user) PATH.

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 12th, 2018, 1:45 am

I'm in the middle of a complete server rebuild with 2012 R2, see what happens after that.

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 13th, 2018, 6:07 pm

Ok so after a complete server upgrade (clean) to Windows Server 2012 R2 I dont get those errors running the scripts anymore .... however the script isnt renaming the files either. I've tried using Sorting and it isnt renaming them either

For some reason I cant work out, now SABNZBD is just dumping an obfuscated file in the relevant output directory and now I dont even get a helpfully named directory with the obfuscated file in it with Sorting and DeObfuscate off - I dont have "Ignore any folders inside archives" turned on. ???

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 13th, 2018, 8:27 pm

Ok so the scripts are actually running now, however because SABNZBD is for some reason removing the folders, and only moving the files, I get the following errors in the log:

Code: Select all

SABnzbd version:  2.3.2
Job location:  D:\ServerFolders\Videos\MotorSport\Formula 1
Par2-command:  C:\Program Files\SABnzbd\win\par2\multipar\par2j64.exe

------------------------

No par2 files found to process.

------------------------

Trying to see if there are large files to rename

------------------------

Found: D:\ServerFolders\Videos\MotorSport\Formula 1\c3eec716c9ae4347bd13fb851008e422.mkv
Found: D:\ServerFolders\Videos\MotorSport\Formula 1\F1 2018 Bahrain GP Practice One.mkv

------------------------

Found multiple larger files, aborting.
No par2 files or large files found
now this destination folder has multiple files already in it, the actual DL job was:

Code: Select all

Formula1 2018 Chinese Grand Prix Paddock Uncut PDTV x264-GRiP-Obfuscated
I'm guessing it would work if sabnzbd wasnt removing the Dir's (it never used to).

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 13th, 2018, 9:21 pm

dJOS wrote:
April 13th, 2018, 8:27 pm
I'm guessing it would work if sabnzbd wasnt removing the Dir's (it never used to).
And I was right, plus it was my fault! :-[

I'd added an asterix to the end of my F1 category folder destination at some point in my mucking around and it was removing the folders! *facepalm*

Now everything works perfectly! Huzzah! ;D

User avatar
safihre
Administrator
Administrator
Posts: 2889
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: SABNZBD errors running included Post processing script

Post by safihre » April 14th, 2018, 3:46 am

Was just about to respond that but you already figured it out :)

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 14th, 2018, 4:22 am

Although the script seems to run when I add an NZB manually using the relevant category but not when rss grabs it using that category. Hmm, weird.

User avatar
safihre
Administrator
Administrator
Posts: 2889
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: SABNZBD errors running included Post processing script

Post by safihre » April 14th, 2018, 11:10 am

Make sure the Accept rule in Rss (or any of the one above it) don't have any Script set. Only Default, not None.

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 14th, 2018, 5:00 pm

Cheers, I'll try that.

User avatar
dJOS
Newbie
Newbie
Posts: 9
Joined: April 11th, 2018, 2:07 am

Re: SABNZBD errors running included Post processing script

Post by dJOS » April 14th, 2018, 5:05 pm

safihre wrote:
April 14th, 2018, 11:10 am
Make sure the Accept rule in Rss (or any of the one above it) don't have any Script set. Only Default, not None.
Yeah you were right, one of the RSS accept rules had "none" set for script instead of default.

Post Reply