sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
Mighty
Newbie
Newbie
Posts: 9
Joined: June 17th, 2019, 12:20 am

sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by Mighty » October 7th, 2019, 2:08 pm

While actually downloading, sabnzbd doesn't seem to tax the CPU much. I can fill up my bandwidth. And, adjusting connections down doesn't appear to affect the CPU usage noticeably.

But, when sabnzbd is verifying, checking, unpacking the download the CPU usage sits at 98-99%. Task manager confirms that it's sabnzbd using 80-90% all by itself. Python is taking only a fraction of a percent. It's a process called par2 that's junk everything up.

Am I just too optimistic on using this a DS418play for this? If so, does anyone have a link to instructions on how to offload sabnzbd onto another machine? I'm not concerned about the time to complete the download. It's just that, as it stands, I can't watch anything on Plex because there's not enough CPU left to do anything.

Just to clarify, this is the Synology-native version of sabnzbd, not the Docker version.

And, I have rebooted a couple of times.

Thanks.

User avatar
sander
Release Testers
Release Testers
Posts: 6745
Joined: January 22nd, 2008, 2:22 pm

Re: sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by sander » October 7th, 2019, 3:04 pm

Mighty wrote:
October 7th, 2019, 2:08 pm
I'm not concerned about the time to complete the download. It's just that, as it stands, I can't watch anything on Plex because there's not enough CPU left to do anything.
On Linux/Unix-like systems (like your NAS), you can set nice and ionice to give lower prio to SABnzbd / rar / par2, so that other process can get more CPU.
See https://sabnzbd.org/wiki/configuration/ ... tches#nice

In SABnzbd: config -> switches

Mighty
Newbie
Newbie
Posts: 9
Joined: June 17th, 2019, 12:20 am

Re: sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by Mighty » October 8th, 2019, 3:27 am

Thank you. If I can ever get the sabnzbd page to actually load, I'll give those a try

Mighty
Newbie
Newbie
Posts: 9
Joined: June 17th, 2019, 12:20 am

Re: sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by Mighty » October 8th, 2019, 6:17 am

Finally managed to get at the settings page, by stopping and restarting sabnzbd.

These last coupla hours, it appears I've been I/O bound. Unfortunately, the ionice field in the Switches page is grayed out. It has -c2 -n4, but I'm not sure if it's actually calling ionice with those parameters. If so, they're not enough, and I have no way to change them.

Is this an instance of why I saw someone recommending the Docker version of sabnzbd instead of the Synology version?

Any other workarounds? Is there somewhere else I can set those numbers to override what's in that page?

I took a look at the Extra par2 parameters. I thought I'd try -t0.

The nice setting was already -t15, which from the documentation sounds high. I went ahead and changed that to 20, to see if it makes a difference.

Anything else I can try?

User avatar
sander
Release Testers
Release Testers
Posts: 6745
Joined: January 22nd, 2008, 2:22 pm

Re: sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by sander » October 8th, 2019, 8:39 am

ionice greyed out? Then install "ionice" on your system (if you can).

EDIT

I found ionice on my own Synology ... installed in/by SABnzbd:

[email protected]:/# find . -name ionice
./volume1/@appstore/sabnzbd/bin/ionice

Mighty
Newbie
Newbie
Posts: 9
Joined: June 17th, 2019, 12:20 am

Re: sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by Mighty » October 8th, 2019, 5:53 pm

For some reason, it's behaving better today.

The log on the main sabnzbd screen tells me that -t0 is an invalid parameter, so I guess that didn't change the behavior. Maybe upping the nice number helped.

I don't have Putty on this machine. I'll check for ionice later tonight.

Also, probably unrelated, for some reason, Radarr lost its connection to sabnzbd. I had to change the host from the name to the IP address. Tried back and forth a few times, and the name isn't resolving. Dunno why it was working for a while and then decided to stop. Confusing.

Again, thanks for your help.

User avatar
sander
Release Testers
Release Testers
Posts: 6745
Joined: January 22nd, 2008, 2:22 pm

Re: sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by sander » October 8th, 2019, 11:28 pm

a nice parameter is "-n15", not something with "-t0"

Mighty
Newbie
Newbie
Posts: 9
Joined: June 17th, 2019, 12:20 am

Re: sabnzbd 2.3.9 on a DS418play at 100% CPU usage

Post by Mighty » October 9th, 2019, 5:24 am

Sorry, in my head I had filled in all the information. The -t0 was invalid for PAR2. At least, according to what it yelled at me.

The find command did not find ionice. I installed sabnzbd through the Synology Package Manager just a coupla days ago. I went looking into the @appstore/sabnzbd/bin folder and I do not see ionice. I do see nice and something called renice. Just looked it up, so I see what it's for, changing the priority on already-running tasks.

I did a quick search for installing ionice on Synology, but didn't get any useful looking hits.

Again, it's behaving a little better, today. I was able to finish watching a movie while it was downloading. Albeit, I did have to stream it at Original bitrate (transcoding only ran for a few seconds at a time) and I had to restart it four or five times in a half hour. Also, for any movie it has to verify or repair, it runs the CPU usage back up near the max. It's as if it's ignoring the nice command.

Post Reply