Sabnzbd not loading WebUI after update on FreeNAS

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
frank16616
Newbie
Newbie
Posts: 3
Joined: April 20th, 2021, 5:43 am

Sabnzbd not loading WebUI after update on FreeNAS

Post by frank16616 »

I have Sabnzbd running in a jail on my FreeNAS machine.

FreeNAS version: 11.3-U5
sabnzbd version: 3.0.2

After doing some updates through the plugins screen, I am no longer able to access the WebUI for Sabnzbd.

I found the below while trying to work out what is wrong.

Code: Select all

Traceback (most recent call last):
  File "/usr/local/bin/SABnzbd,py", line 1721, in <module>
    main()
  File "/usr/local/bin/SABnzbd,py", line 1224, in main
    sabnzbd.initialize(pause, clean_up, evalSched=True, repair=repair)
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/decorators,py", line 36, in call_func
    return f(*args, **kw)
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/__init__,py", line 323, in initialize
    rss.init()
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/rss,py", line 48, in init
    __RSS = RSSQueue()
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/rss,py", line 209, in __init__
    patch_feedparser()
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/rss,py", line 648, in patch_feedparser
    feedparser._FeedParserMixin.namespaces["http: //www.newznab .com/DTD/2010/feeds/attributes/"] = "newznab"
AttributeError: module 'feedparser' has no attribute '_FeedParserMixin'
Any help would be very much appreciated.

User avatar
sander
Release Testers
Release Testers
Posts: 7416
Joined: January 22nd, 2008, 2:22 pm

Re: Sabnzbd not loading on FreeNAS: AttributeError: module 'feedparser' has no attribute '_FeedParserMixin'

Post by sander »

Did you Google

AttributeError: module 'feedparser' has no attribute '_FeedParserMixin'

... one of the first hits will tell you what/why.

frank16616
Newbie
Newbie
Posts: 3
Joined: April 20th, 2021, 5:43 am

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by frank16616 »

Yes, I had done but didn't find what I needed to see the first time.

After a lot more reading and trying things out, I have managed to sort this out.

User avatar
sander
Release Testers
Release Testers
Posts: 7416
Joined: January 22nd, 2008, 2:22 pm

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by sander »

Great.

Can you share how you did it, so that other users can benefit from that?

oldozguy
Newbie
Newbie
Posts: 6
Joined: April 27th, 2017, 7:35 am

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by oldozguy »

I have the same setup... and also got failure after pkg upgrade.

I tried deleting sabnzbd, and reinstalling 3.0.1... but even after restarting my jail I still have no sabnzbd! Nothing listening on port 8080... and I am not so familiar with where to find logs.

Any help appreciated.

frank16616
Newbie
Newbie
Posts: 3
Joined: April 20th, 2021, 5:43 am

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by frank16616 »

Hi,

I meant to write down my steps on Tuesday, but it has been a busy week for me.

I used the below command to install feedparser 6.0.2 in the jail I have Sabnzbd running in.

Code: Select all

pip install feedparser
I seem to remember needing to install pip as well. If you need to as well, try the below link.
https://computingforgeeks .com/how-to-install-pip-python-package-manager-on-freebsd-12/

Let me know if you have any more questions and I will try and help.

rdr_than_urdad
Newbie
Newbie
Posts: 4
Joined: April 23rd, 2021, 11:29 pm

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by rdr_than_urdad »

I was able to install feedparser 6.02 but still not able to get to Sabnzbd WebUI, am I missing something else? Is there anywhere else I could look for more info on errors?

If I do 'service sabnzbd start' I get 'Starting sabnzbd' but can't reach it, and doing 'service sabnzbd status' shows 'sabnzbd is not running'. Nothing listening on port 8080 either.

Any help would be greatly appreciated!

Python Version: 3.7.10
FreeNAS version: 11.3-U5
sabnzbd version: 3.02

the error from logs that I get:
AttributeError: module 'feedparser' has no attribute '_FeedParserMixin

unfortunately I can't post the full log since it thinks I'm posting a URL

User avatar
safihre
Administrator
Administrator
Posts: 4228
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by safihre »

Can you update Sabnzbd to the latest version? Or that's not possible? I think just running from the sources package on the Downloads page should work, since you already have all the dependencies.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

skulneck
Newbie
Newbie
Posts: 2
Joined: November 30th, 2014, 2:26 pm

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by skulneck »

@frank16616 I'm running a very old SABnzbd 2.3.9 on my FreeNAS 11.3-U5 box. Can you give me commands you ran to update SABnzbd to the latest version?

I assume I'll run the update command from the ../iocage/jails/sabnzbd/root/ directory from my sabnzbd jail.

Thnx,
-TAC

rdr_than_urdad
Newbie
Newbie
Posts: 4
Joined: April 23rd, 2021, 11:29 pm

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by rdr_than_urdad »

I'm unable to get the latest version on freenas, if I do command pkg install sabnzbd plus i get the followhing which shows it's installing sabnzbdplus: 3.0.2,1 which seems like is not the latest version:

New packages to be INSTALLED:
p7zip: 16.02_3
par2cmdline-tbb: 20100203_22
py37-cffi: 1.14.5
py37-chardet: 3.0.4_3,1
py37-cheetah3: 3.2.6_1
py37-cheroot: 8.5.2
py37-cherrypy: 17.4.2
py37-configobj: 5.0.6_1
py37-contextlib2: 0.6.0.p1
py37-cryptography: 2.9.2
py37-feedparser: 6.0.2_2
py37-formencode: 1.3.0
py37-jaraco: 1
py37-jaraco.functools: 3.3.0
py37-markdown: 2.6.11_1
py37-more-itertools: 8.7.0
py37-portend: 2.5_1
py37-pycparser: 2.20
py37-pytz: 2020.5,1
py37-sabyenc3: 4.0.2
py37-sgmllib3k: 1.0.0
py37-six: 1.15.0
py37-sqlite3: 3.7.10_7
py37-sqlobject: 1.6.0_1
py37-tempora: 4.0.1
py37-zclockfile: 2.0
sabnzbdplus: 3.0.2,1
tbb: 2020.3_3
unrar: 6.00,6


ultimately it seems like it's the installation of py37-feedparser: 6.0.2_2 that is the main cause of this issue, however, I am unable to downgrade this package, I've tried a few different things but nothing has worked yet. Any suggestions?

Gold-Finger007_ZA
Newbie
Newbie
Posts: 2
Joined: April 29th, 2021, 2:46 am

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by Gold-Finger007_ZA »

Installing feedparser 5.2.1 worked for me

I have been racking my brain around to find a way to get my SabNZBD working again, even tried NZBget(horrible to use, my news server didn't want to authenticate and any other news servers i use would get blocked after a few minutes).

Updated FreeNAS 11.3-U5 to the new TrueNAS-12.0-STABLE version, Uninstalled and re-installed Sabnzb(still on 3.0.2, couldn't get a way to downgrade to the older version), none of these things got my SabNZBD to work again.

Finally got it working after reading this thread and multiple other threads.

Here is how I fixed mine:

1. I installed pip python package manager

Code: Select all

pkg install py37-pip
2. I then downgraded my feedparser that was on 6.0.2 back to 5.2.1

Code: Select all

pip install feedparser==5.2.1
And the WebUI was back up and working.

Hope this helps everyone else who's having this issue.

rdr_than_urdad
Newbie
Newbie
Posts: 4
Joined: April 23rd, 2021, 11:29 pm

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by rdr_than_urdad »

Gold-Finger007_ZA wrote:
April 29th, 2021, 3:15 am
Installing feedparser 5.2.1 worked for me

I have been racking my brain around to find a way to get my SabNZBD working again, even tried NZBget(horrible to use, my news server didn't want to authenticate and any other news servers i use would get blocked after a few minutes).

Updated FreeNAS 11.3-U5 to the new TrueNAS-12.0-STABLE version, Uninstalled and re-installed Sabnzb(still on 3.0.2, couldn't get a way to downgrade to the older version), none of these things got my SabNZBD to work again.

Finally got it working after reading this thread and multiple other threads.

Here is how I fixed mine:

1. I installed pip python package manager

Code: Select all

pkg install py37-pip
2. I then downgraded my feedparser that was on 6.0.2 back to 5.2.1

Code: Select all

pip install feedparser==5.2.1
And the WebUI was back up and working.

Hope this helps everyone else who's having this issue.

Thank you so much!! This fixed my issue thank you!

Gold-Finger007_ZA
Newbie
Newbie
Posts: 2
Joined: April 29th, 2021, 2:46 am

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by Gold-Finger007_ZA »

rdr_than_urdad wrote:
April 29th, 2021, 4:48 pm
Thank you so much!! This fixed my issue thank you!
Hi,

Glad I could help man..

I will definitely look up the new version of anything I update on FreeNAS before I do it again to prevent this from happening again.

sasquatch
Newbie
Newbie
Posts: 1
Joined: April 26th, 2021, 8:24 pm

Re: Sabnzbd not loading WebUI after update on FreeNAS

Post by sasquatch »

Same here.
Thanks dude or dudette.

Post Reply