Connection is not secure warning

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
thusband
Newbie
Newbie
Posts: 22
Joined: April 16th, 2016, 6:04 pm

Connection is not secure warning

Post by thusband »

Every once in a while I get a warning that SABnzbd is not secure and I have to disable security warnings. Something about an invalid certificate? I'm using the latest stable SABnzbd on a Win 10 NUC using the latest Chrome browser along with Sonarr, Radarr, NZB Hydra and Plex.

Today SABnzbd completely grayed out and I couldn't access anything. After poking around a popup finally appeared allowing me to disable the warning. I still have the not secure warning showing at the top where the site address is. It looks like everything is running now but I'm not sure for how long.

How do I fix this permanently?

Many thanks.

User avatar
sander
Release Testers
Release Testers
Posts: 7477
Joined: January 22nd, 2008, 2:22 pm

Re: Connection is not secure warning

Post by sander »

Which connection: from your browser to you SABnzbd, or from SABnzbd to your newsserver?

thusband
Newbie
Newbie
Posts: 22
Joined: April 16th, 2016, 6:04 pm

Re: Connection is not secure warning

Post by thusband »

Sorry, it's from the browser to SABnzbd. The screen goes a little gray and nothing works. It's just SABnzbd, all the other applications work.

In the security warning it's says something about an invalid certificate. Probably a Chrome thing?

User avatar
sander
Release Testers
Release Testers
Posts: 7477
Joined: January 22nd, 2008, 2:22 pm

Re: Connection is not secure warning

Post by sander »

Chrome is becoming more and more strict on what it considers safe:

Chrome now only considers safe: valid SSL with HTTPS.
Chrome considers unsafe: HTTP
Chrome considers unsafe: self-signed SSL with HTTPS

On your LAN, you have private IP addresses for which you cannot get a valid SSL. So ... no solution possible on your LAN to makes Chrome happy.

Well ... you could generate a SSL and then import it at OS and/or Browser level. I tried it once, and it looked complicated. I believe this is what companies do on their WANs.

Having written the above ... I cannot remember my Chrome is complaing about the SAB connection to 192.168.1.4 ... weird.

thusband
Newbie
Newbie
Posts: 22
Joined: April 16th, 2016, 6:04 pm

Re: Connection is not secure warning

Post by thusband »

OK thanks. I guess I'll live with it. SABnzbd performs flawlessly.

User avatar
sander
Release Testers
Release Testers
Posts: 7477
Joined: January 22nd, 2008, 2:22 pm

Re: Connection is not secure warning

Post by sander »

I checked, and I access my SAB instances via HTTP (not HTTPS), and Chrome does not complain ... just a small note left of the URL "not secure". No popups etc

http://127.0.0.1:8080/
http://192.168.1.4:8080/

So ... worth a try: turn off "Enable HTTPS" in SABnzbd on http://127.0.0.1:8080/config/general/

Because of the Chrome behaviour, SAB now says, at "Enable HTTPS": "WARNING Modern web browsers and other clients will not accept self-signed certificates and will give a warning and/or won't connect at all."

... so 'better' to leave HTTPS off and use plain HTTP.

barkietrin7
Newbie
Newbie
Posts: 2
Joined: June 10th, 2020, 1:19 pm

Re: Connection is not secure warning

Post by barkietrin7 »

Hi! SABnzbd 2.3.2 running on a High Sierra (10.13.4) iMac here.

Whenever I try to open SABnzbd on Safari, it warns me that "this connection is not private"and asks me to modify my security settings in order to accept the self-signed certificate SABnzbd uses for HTTPS...

Trouble is: accepting that usually worked in the past; now, I guess that after installing 10.13.4, even if I accept that, it doesn't work.

Is there a way of generating a certificate that will be accepted? Or turning off HTTPS without logging onto SABnzbd (as this is exactly what I cannot do)?

Thank you!

User avatar
sander
Release Testers
Release Testers
Posts: 7477
Joined: January 22nd, 2008, 2:22 pm

Re: Connection is not secure warning

Post by sander »

Hi! SABnzbd 2.3.2 running on a High Sierra (10.13.4) iMac here.
We're on 3.2.1, so upgrade SAB
Or turning off HTTPS
Yes, do that.
without logging onto SABnzbd (as this is exactly what I cannot do)?
Well, you can tell your browser to accept the connection. In Chrome, the page shows an Advanced button.

thusband
Newbie
Newbie
Posts: 22
Joined: April 16th, 2016, 6:04 pm

Re: Connection is not secure warning

Post by thusband »

Turning off "Enable HTTPS" in SABnzbd seems to have stopped my Chrome browser from complaining. Great suggestion.

Many thanks!

User avatar
sander
Release Testers
Release Testers
Posts: 7477
Joined: January 22nd, 2008, 2:22 pm

Re: Connection is not secure warning

Post by sander »

opentoe wrote:
May 10th, 2021, 11:44 am
...
No, not related, so I'll remove your post.

Post Reply