Unable to connect from non 127.0.0.1 address

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
thetreat
Newbie
Newbie
Posts: 2
Joined: November 25th, 2021, 1:00 pm

Unable to connect from non 127.0.0.1 address

Post by thetreat »

I used to be able to connect from my regular IP address (inside network e.g. 192.168.0.100) but after upgrading to 3.4.2 I cannot connect to sabnzbd from anything but 127.0.0.1. I didn't change any firewall settings and did nothing but do an upgrade. I even tried downgrading and it still doesn't work. How can I identify why I'm not able to connect from another machine anymore? Other sites on this machine connect just fine so it seems like *just* sabnzbd.

User avatar
sander
Release Testers
Release Testers
Posts: 7757
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to connect from non 127.0.0.1 address

Post by sander »

Search Sabnzbd Access Deinied. That gives the Howto. Im on mobile now

thetreat
Newbie
Newbie
Posts: 2
Joined: November 25th, 2021, 1:00 pm

Re: Unable to connect from non 127.0.0.1 address

Post by thetreat »

sander wrote:
November 25th, 2021, 1:26 pm
Search Sabnzbd Access Deinied. That gives the Howto. Im on mobile now
Figured it out! Somehow Sabnzbd host on the General settings config page was set to 127.0.0.1 instead of my IP address. Not sure how that got changed or if some policy changed to not allow from multiple IP addresses. Changing to the local IP address of the computer fixed it.

Post Reply