Getting an error and downloads won't work

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
smidley
Jr. Member
Jr. Member
Posts: 64
Joined: January 29th, 2010, 11:34 pm

Getting an error and downloads won't work

Post by smidley » December 1st, 2013, 9:35 pm

Getting the following error, can someone help point me in the right direction for a fix?

Server: news.supernews.com:443

Status: Enabled

# Connections: Failed to connect: (10038, 'Socket operation on non-socket') [email protected]:443

User avatar
inpheaux
Administrator
Administrator
Posts: 730
Joined: January 16th, 2008, 9:14 pm

Re: Getting an error and downloads won't work

Post by inpheaux » December 1st, 2013, 11:14 pm

Are you using SSL or not? 443 is an SSL port. If you don't have the SSL box ticked it won't work.

smidley
Jr. Member
Jr. Member
Posts: 64
Joined: January 29th, 2010, 11:34 pm

Re: Getting an error and downloads won't work

Post by smidley » December 1st, 2013, 11:20 pm

Yes, using SSL with the box ticked.

User avatar
sander
Release Testers
Release Testers
Posts: 6389
Joined: January 22nd, 2008, 2:22 pm

Re: Getting an error and downloads won't work

Post by sander » December 2nd, 2013, 8:47 am

I would do this:

in SABnzbd: config -> server: Add Server:

sslreader.eweka.nl
port 563
tick SSL

then click on Add Server. Then at the new server, click on Test Server. If SABnzbd's popup says "Server requires username and password.", your SABnzbd is fine. If you get something else, the problem is locally: firewall, router, incorrect SABnzbd setup.

smidley
Jr. Member
Jr. Member
Posts: 64
Joined: January 29th, 2010, 11:34 pm

Re: Getting an error and downloads won't work

Post by smidley » December 2nd, 2013, 1:58 pm

Thanks for the advice. I got a message that says Server requires username and password. If I click test server on my supernews one, nothing ever pops up.

User avatar
sander
Release Testers
Release Testers
Posts: 6389
Joined: January 22nd, 2008, 2:22 pm

Re: Getting an error and downloads won't work

Post by sander » December 2nd, 2013, 5:04 pm

I tried news.supernews.com:443 with SSL ticked, and I do get "Server requires username and password.". So that looks correct.

So ... maybe remove the server entry, re-enter it and try again? Try both 443 and 563

You don't have firewall blocking this connection, do you?

smidley
Jr. Member
Jr. Member
Posts: 64
Joined: January 29th, 2010, 11:34 pm

Re: Getting an error and downloads won't work

Post by smidley » December 2nd, 2013, 6:11 pm

Tried removing the server entry and re-adding it. Tried different ports. Firewall is totally disabled on the server. However, I have a feeling something else might be happening now with this server since newznab suddenly isn't authenticating me to supernews as well. Checked my supernews account though and all is well there. I can also get sab to work fine on another computer.

User avatar
sander
Release Testers
Release Testers
Posts: 6389
Joined: January 22nd, 2008, 2:22 pm

Re: Getting an error and downloads won't work

Post by sander » December 2nd, 2013, 6:21 pm

Which OS?
Which SAB version?
How many connections to the newsserver? Lower to 1 for this test.

Have you already tried a reboot?

smidley
Jr. Member
Jr. Member
Posts: 64
Joined: January 29th, 2010, 11:34 pm

Re: Getting an error and downloads won't work

Post by smidley » December 2nd, 2013, 6:26 pm

OS is Server 2008 R2. Sab 0.7.16.

Lowered connections down to 1 and didn't make any difference. Tried multiple reboots.

User avatar
sander
Release Testers
Release Testers
Posts: 6389
Joined: January 22nd, 2008, 2:22 pm

Re: Getting an error and downloads won't work

Post by sander » December 2nd, 2013, 6:32 pm

So Windows. This is the meaning of your error:

Code: Select all

WSAENOTSOCK
10038
Socket operation on nonsocket.
An operation was attempted on something that is not a socket. Either the socket handle parameter did not reference a valid socket, or for select, a member of an fd_set was not valid.

Long shot:

1) Use "138.199.67.30" as server (as you can access eweka over SSL)
2) Stop SABnzbd, open a CMD terminal and run sabnzbd-console.exe ... look at the stdout / stderr logging if you see anything useful.

smidley
Jr. Member
Jr. Member
Posts: 64
Joined: January 29th, 2010, 11:34 pm

Re: Getting an error and downloads won't work

Post by smidley » December 2nd, 2013, 7:13 pm

I did what you said. Here's the output of the cmd window: http://pastebin.com/VR6LUSX9

User avatar
sander
Release Testers
Release Testers
Posts: 6389
Joined: January 22nd, 2008, 2:22 pm

Re: Getting an error and downloads won't work

Post by sander » December 3rd, 2013, 1:58 am

Ah:

Code: Select all

2013-12-02 16:03:22,789::INFO::[downloader:378] [email protected]:443: Initiating connection

2013-12-02 16:05:23,471::INFO::[downloader:661] Thread [email protected]:443: timed out

2013-12-02 16:05:23,471::INFO::[newswrapper:233] Failed to connect: (10038, 'Socket operation on non-socket') [email protected]:443
So ... first the "timed out" after two minutes (and only then non-socket message). I would focus on the time-out ...

De-install and remove firewall, reboot, and try again.
What do you get when you fill out "8.8.8.8" with port 119, and with port 443? On Linux, I get "[Errno 111] Failed to connect: (110, 'timed out') [email protected]:119"
And, just re-checking: the eweka SSL still works (giving the username/password needed)?

Post Reply