Empty NZB Files and Not Adding Files to sabnzbd

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
King_Monkfish
Newbie
Newbie
Posts: 3
Joined: January 4th, 2016, 2:16 pm

Empty NZB Files and Not Adding Files to sabnzbd

Post by King_Monkfish »

So fairly new to all of this, but I have the following issue which I am not able to resolve myself now.

I can get neither Couchpotato or Sickbeard to add files into sabnzbd.

Couchpotato seems to search and then come back with no results at all, log states the following when trying to search:
01-04 19:22:54 INFO[edia._base.providers.base] Found: score(91) on Newznab, api.oznzb.com: American.Sniper.2014.1080p.BluRay.x264-SPARKS-RP
01-04 19:22:54 INFO[hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/validate/YW1lc ... yNjQtbmw=/, data: []
01-04 19:22:56 INFO[edia._base.providers.base] Found: score(91) on Newznab, api.oznzb.com: American.Sniper.2014.1080p.BluRay.x264-NL
01-04 19:22:56 INFO[hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/validate/YW1lc ... yNjQtbmw=/, data: []
01-04 19:22:58 INFO[edia._base.providers.base] Found: score(91) on Newznab, api.oznzb.com: American Sniper 2014.1080p BluRay x264-NL
01-04 19:22:58 INFO[hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/validate/YW1lc ... tc3Bhcmtz/, data: []
01-04 19:22:59 INFO[edia._base.providers.base] Found: score(91) on Newznab, api.oznzb.com: American.Sniper.2014.1080p.BluRay.x264-SPARKS
01-04 19:23:00 INFO[hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/validate/YW1lc ... tc3Bhcmtz/, data: []
01-04 19:23:01 INFO[edia._base.providers.base] Found: score(91) on Newznab, api.oznzb.com: American.Sniper.2014.1080p.BluRay.x264-SPARKS
01-04 19:23:01 INFO[hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/validate/YW1lc ... tc3Bhcmtz/, data: []
01-04 19:23:03 INFO[edia._base.providers.base] Found: score(91) on Newznab, api.oznzb.com: American.Sniper.2014.1080p.BluRay.x264-SPARKS
01-04 19:23:05 INFO[hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/validate/YW1lc ... ud2ViLWRs/, data: []
01-04 19:23:07 INFO[edia._base.providers.base] Found: score(80) on Newznab, api.oznzb.com: American.Sniper.2014.1080p.WEB-DL
01-04 19:23:09 INFO[hpotato.core.plugins.base] Opening url: get https://api.oznzb.com/api?t=get&id=daaf ... apikey=xxx
Lots of errors like above and then this one:
01-04 19:23:14 ERROR[tato.core.plugins.release] Tried to download, but the "nzb" provider gave an error: Traceback (most recent call last): File "/share/MD0_DATA/.qpkg/CouchPotato2/CouchPotato2/couchpotato/core/plugins/release/main.py", line 311, in download filedata = data.get('download')(url = data.get('url'), nzb_id = data.get('id')) File "/share/MD0_DATA/.qpkg/CouchPotato2/CouchPotato2/couchpotato/core/media/_base/providers/nzb/newznab.py", line 196, in download response = e.read().lower() AttributeError: 'HTTPError' object has no attribute 'read'
Just says that it was searching but never snatches anything into sab. I was working and worked for about 5 movies but now, nothing.

Sickbeard is not much better. I can search for a show and it seems to talk to sab but then sab itself has the following warnings:
2016-01-04 17:13:51,771 WARNING: Empty NZB file 90096af9d9bd4e668678fe272e492b27.nzb&i=419634&r=2d201a3946b8e0885ef7cdeef54ac60a.nzb [https://api.oznzb.com/getnzb/90096af9d9 ... eef54ac60a]
2016-01-04 17:13:43,381 WARNING: Empty NZB file 5f10fe18138d3fa54c2e167b0bfe6a71.nzb&i=419634&r=2d201a3946b8e0885ef7cdeef54ac60a.nzb [https://api.oznzb.com/getnzb/5f10fe1813 ... eef54ac60a]
One error for each file by the looks of it.

If anyone can help that would be great.

Thanks
King Monkfish

ALbino
Full Member
Full Member
Posts: 213
Joined: October 23rd, 2014, 12:28 am

Re: Empty NZB Files and Not Adding Files to sabnzbd

Post by ALbino »

You should edit that to remove your private API key, and then you should go to OZnzb and change it to a new one.

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: Empty NZB Files and Not Adding Files to sabnzbd

Post by shypike »

SABnzbd either receives a truly empty NZB or there's something wrong with
the user identification parameters in the URL.
In the latter case SABnzbd receives some HTML page that effectively is an empty NZB file.
Unfortunately many indexers do not return proper error messages but HTML gibberish that
only makes sense to humans after rendering by a web browser.

Post Reply