Two Part question

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
moulson13
Newbie
Newbie
Posts: 7
Joined: June 15th, 2017, 7:21 pm

Two Part question

Post by moulson13 » June 15th, 2017, 7:25 pm

So Im still new at this and I am having a two part question.
Im running Mac OS 10.11 most up to date version. Im getting the following error:

[15/Jun/2017:20:14:42] ENGINE socket.error 41
Traceback (most recent call last):
File "cherrypy/wsgiserver/__init__.pyc", line 1411, in communicate
File "cherrypy/wsgiserver/__init__.pyc", line 862, in respond
File "cherrypy/wsgiserver/__init__.pyc", line 2341, in respond
File "cherrypy/wsgiserver/__init__.pyc", line 2423, in write
File "cherrypy/wsgiserver/__init__.pyc", line 915, in write
File "cherrypy/wsgiserver/__init__.pyc", line 1049, in write
File "cherrypy/wsgiserver/__init__.pyc", line 1056, in send
error: [Errno 41] Protocol wrong type for socket

Any suggestions on what is happening and how to fix it?

Part 2 to the question is I keep dropping connection every 3-5 min from sabnzbd, these could be related but again I don't know. Any help would be great. Thanks
Last edited by moulson13 on June 16th, 2017, 9:22 pm, edited 1 time in total.

User avatar
safihre
Administrator
Administrator
Posts: 2884
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Two Part question

Post by safihre » June 16th, 2017, 12:17 am

10.5? Oh we don't support that anymore. Which version of Sabnzbd are you using? I think 2.0.1 should still work.

moulson13
Newbie
Newbie
Posts: 7
Joined: June 15th, 2017, 7:21 pm

Re: Two Part question

Post by moulson13 » June 16th, 2017, 9:21 pm

Im an Idiot. Im on 10.11

User avatar
safihre
Administrator
Administrator
Posts: 2884
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Two Part question

Post by safihre » June 17th, 2017, 1:24 am

This seems to be a error specific to older versions of OSX that should be fixed in newer versions: http://erickt.github.io/blog/2014/11/19 ... ernel-bug/

It seems I can catch this error, but this would only prevent the error from showing and wouldn't actually fix your dropped connection problem.
I guess you cannot update your OSX versions?

User avatar
safihre
Administrator
Administrator
Posts: 2884
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Two Part question

Post by safihre » June 17th, 2017, 1:28 am

Let me try putting catching this error, maybe it will help actually :)

User avatar
safihre
Administrator
Administrator
Posts: 2884
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Two Part question

Post by safihre » June 17th, 2017, 3:53 am

I applied a fix in 2.2.0Alpha1, maybe you can test that version?

moulson13
Newbie
Newbie
Posts: 7
Joined: June 15th, 2017, 7:21 pm

Re: Two Part question

Post by moulson13 » June 21st, 2017, 10:28 am

sure how would I get that beta version?

User avatar
safihre
Administrator
Administrator
Posts: 2884
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Two Part question

Post by safihre » June 21st, 2017, 11:49 am


Post Reply