v2.3.1 on OSX 10.11.6 crashing Help needed

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
2tef2kqudtyrnu
Newbie
Newbie
Posts: 2
Joined: November 6th, 2017, 10:09 am

v2.3.1 on OSX 10.11.6 crashing Help needed

Post by 2tef2kqudtyrnu » November 6th, 2017, 10:32 am

Good morning,
The latest upgrade of SABNZBD from this site (2.3.1 for OSX 10.11.6) on a 2008 imac is crashing after installation and attempt to start,
I did remove the ini file, but the executable is crashing before getting to that point of seeking the config.

I also reinstalled v2.3.0 from this site and the application is working as expected.

Here's the error from the log file:

**************************************
2017-11-06 7:15:59.566 AM ReportCrash[8832]: Saved crash report for SABnzbd[8829] version 2.3.1 (0.0.0) to /Users/XXX/Library/Logs/DiagnosticReports/SABnzbd_2017-11-06-071559_admins-iMac.crash

Process: SABnzbd [8829]
Path: /Applications/SABnzbd.app/Contents/MacOS/SABnzbd
Identifier: org.sabnzbd.team
Version: 2.3.1 (0.0.0)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: SABnzbd [8829]
User ID: 503

Date/Time: 2017-11-06 07:15:58.497 -0800
OS Version: Mac OS X 10.11.6 (15G1611)
Report Version: 11
Anonymous UUID: 79B126CD-A31A-108A-2F7E-E202D24A7604


Time Awake Since Boot: 50000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

**** followed by a huige amount of application trace information ************
*******************************************************************************************

User avatar
safihre
Administrator
Administrator
Posts: 2214
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by safihre » November 6th, 2017, 2:11 pm

That is strange, we did test it on El Captain..
Maybe you can send me the whole debug log at [email protected]?

2tef2kqudtyrnu
Newbie
Newbie
Posts: 2
Joined: November 6th, 2017, 10:09 am

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by 2tef2kqudtyrnu » November 7th, 2017, 8:36 am

sent yesterday.

User avatar
safihre
Administrator
Administrator
Posts: 2214
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by safihre » November 7th, 2017, 9:46 am

Unfortunately nothing really in the log. It just says one of the threads crashed when it started.

Could you try this: https://sabnzbd.org/wiki/faq#freshstart

GeneralSmiley
Newbie
Newbie
Posts: 2
Joined: November 8th, 2017, 1:20 pm

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by GeneralSmiley » November 8th, 2017, 1:29 pm

I have this problem too, my report was the same as yours though in the general system log it says 'Service exited due to signal: Illegal instruction: 4 '

A little research on this takes me to the forums for developers that suggest this is to do with trying to run code on an OS that won't support it and can be fixed by compiling it with legacy support. In my case, I am running Sab on a Mac Pro 2,1 with a special boot loader that lets it run. Could there be something in the new SAB which takes advantage of things that my processor can't support? And since our computers can't run El Capitan officially it might get confused when it tries to run those new features?

User avatar
safihre
Administrator
Administrator
Posts: 2214
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by safihre » November 8th, 2017, 1:42 pm

Could you try something for me: locate your sabnzbd.ini (with sabnzbd shutdown, locations here: https://sabnzbd.org/wiki/advanced/directory-setup)

And then find
osx_menu = 1
And change it to
osx_menu = 0

Theb try to start sabnzbd again.

GeneralSmiley
Newbie
Newbie
Posts: 2
Joined: November 8th, 2017, 1:20 pm

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by GeneralSmiley » November 11th, 2017, 6:18 am

Gave it a try, same issue. Thanks for the suggestion though!

User avatar
safihre
Administrator
Administrator
Posts: 2214
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by safihre » November 11th, 2017, 7:08 am

Could you try this special version?
https://github.com/sabnzbd/sabbuild/rel ... dec-crash1

teejee
Newbie
Newbie
Posts: 1
Joined: November 23rd, 2017, 9:41 am

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by teejee » November 23rd, 2017, 9:45 am

Same thing happening to me here.
macOS 10.11.6
Running on an 2008 iMac

sabnzbd 2.3.1 (previous version worked fine)

tried the suggestions here. any help would be apprecited... thank you

User avatar
safihre
Administrator
Administrator
Posts: 2214
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by safihre » November 23rd, 2017, 11:09 am

Can you try this special version?
https://github.com/sabnzbd/sabbuild/releases

elightbo
Newbie
Newbie
Posts: 4
Joined: November 23rd, 2017, 8:48 pm

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by elightbo » November 23rd, 2017, 8:51 pm

I'm having the same issue on El Capitan (10.11.6). I did try the 2.3.2RC1 build as suggested, but it is crashing still. It starts up just fine, but crashes shortly after the menu icon loads. Would app logs help at all? Anything I can do? Thank you.

User avatar
safihre
Administrator
Administrator
Posts: 2214
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by safihre » November 24th, 2017, 2:07 am

Can you run on the command line:

Code: Select all

/Applications/SABnzbd.app/Contents/MacOS/SABnzbd -l2 --console
What is the last few lines of the output?

elightbo
Newbie
Newbie
Posts: 4
Joined: November 23rd, 2017, 8:48 pm

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by elightbo » November 24th, 2017, 10:32 am

The forum is blocking my console output for some reason, so here it is.
Image

User avatar
sander
Release Testers
Release Testers
Posts: 6160
Joined: January 22nd, 2008, 2:22 pm

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by sander » November 24th, 2017, 11:41 am

FWIW: Googling "Illegal instruction: 4" gives https://github.com/muammar/mkchromecast ... -222174145 with the following quotes:
I saw it when creating the app in my macbook pro 2015, and launching it in older models. To tackle it, I used another Macbook pro from 2011 (model 8,2) to build the binary that is being currently shipped.
I am trying to build a universal application with py2app but your report is a prove that it is not working.
so ... related?

Cpuroast
Release Testers
Release Testers
Posts: 118
Joined: December 15th, 2010, 11:19 pm

Re: v2.3.1 on OSX 10.11.6 crashing Help needed

Post by Cpuroast » November 24th, 2017, 7:33 pm

The mac version is being built on the oldest travis build environment possible using xcode 6.4 on 10.10, it contains the sdk for 10.9 and 10.10.
So the version of Sab currently shipping is essentially as un-optimized as possible to support the highest number of OSes as possible.

Starting with 2.3.0, I have been personally testing Sab on 10.9, 10.10, 10.11, 10.13 in VMs and on 10.12 on the host running those VMs which is a mid-2012 MacBook Pro running 10.12, to make sure builds run on all OSes and so far they have been working flawlessly at least on this 2012 CPU.

It really looks like the travis build environment which is building Sab or python 2.7.14 is using more recent CPU instructions not present on legacy CPUs, most likely of the Core 2 Duo era which are now over 10 years old.

Sab 2.3.0 uses Python 2.7.13 while Sab 2.3.1 and newer uses Python 2.7.14, so this could be something.

Maybe there's way to make the build environment even more restrictive in terms of CPU instructions used.

But realistically, at the end of the day, it's very simple, at some point old stuff needs to be recycled.
10+ year old computers while still supported by Apple under 10.11, at least until Fall 2018, when 10.11 goes out of support, need to be replaced.

Post Reply