SAB stopped checking RSS feeds

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
MiG
Jr. Member
Jr. Member
Posts: 52
Joined: January 11th, 2010, 7:13 pm

SAB stopped checking RSS feeds

Post by MiG »

I have two very similarly configured instances of SAB running, one is a Win7 desktop for the heavy lifting and the other is a Raspberry Pi which monitors my RSS feeds while the main machine is offline. Both use the same indexer and have been operating in this configuration for years, however for some reason the RasPi has stopped pulling in NZBs a couple of days ago, even though the Win7 machine works just fine.

The RasPi is connected to the web and able to ping places, available space is sufficient for pulling in the nzbs (9.6GB) and at the bottom of the RSS feed URL pages NZBs appear. I've tried restarting SAB and a full reboot, to no avail. Any idea what could be going wrong here?

User avatar
safihre
Administrator
Administrator
Posts: 4057
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: SAB stopped checking RSS feeds

Post by safihre »

Could you enable Debug logging in the Status and Interface settings window. Then restart SABnzbd, and when you expect the readout to happen again, click Show Logging and check if there's anything in the log about the RSS readout.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

MiG
Jr. Member
Jr. Member
Posts: 52
Joined: January 11th, 2010, 7:13 pm

Re: SAB stopped checking RSS feeds

Post by MiG »

Thanks! There's an SSL issue apparently:

Code: Select all

2019-11-15 07:23:33,382::INFO::[rss:309] Failed to retrieve RSS from (INDEXER): <urlopen error [Errno 1] _ssl.c:504: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure>
The RPi has not received any updates recently, and the exact same URL works fine on the Win7 machine. Any idea what could suddenly cause this?

User avatar
safihre
Administrator
Administrator
Posts: 4057
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: SAB stopped checking RSS feeds

Post by safihre »

Seems like a problem with SSL, can you double check the URL and if a browser or curl on the Pi can actually open the URL's?
Maybe they should be http instead of https?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

User avatar
sander
Release Testers
Release Testers
Posts: 7334
Joined: January 22nd, 2008, 2:22 pm

Re: SAB stopped checking RSS feeds

Post by sander »

MiG wrote:
November 15th, 2019, 1:38 am
Thanks! There's an SSL issue apparently:

Code: Select all

2019-11-15 07:23:33,382::INFO::[rss:309] Failed to retrieve RSS from (INDEXER): <urlopen error [Errno 1] _ssl.c:504: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure>
The RPi has not received any updates recently, and the exact same URL works fine on the Win7 machine. Any idea what could suddenly cause this?
If you tell us the RSS Indexer's URL, we can help further. No need for password or other details.

A possible cause could be: the indexer has changed it's certificate of which your Raspi does not know / not trust the root certificate.

But we can only tell if you provide the URL / FQDN, so https://blabla.myindexerxyz.com/ ...

Post Reply