Changing the default base folder

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
jimerb
Newbie
Newbie
Posts: 2
Joined: January 11th, 2020, 9:31 am

Changing the default base folder

Post by jimerb » January 11th, 2020, 9:41 am

Just installed Sabnzbd for the first time.

Looking to change the default base folder with the -f parameter (as outlined at /wiki/advanced/command-line-parameters in the wiki)

It is currently set to:
"C:\Program Files\SABnzbd\SABnzbd.exe" -f "C:\SABnzbd Files\sabnzbd.ini"

There is an INI file at that location.

When i start sabnzbd it still shows the one in my user profile.

What am i missing??????

I've tried with and without quotes around the ini file.

This should be as easy as clicking an elliptical and changing it right on screen. Unnecessarily complicated.

User avatar
sander
Release Testers
Release Testers
Posts: 6803
Joined: January 22nd, 2008, 2:22 pm

Re: Changing the default base folder

Post by sander » January 11th, 2020, 11:08 am

Before you issue that command, make sure there is NO sabnzbd running. Check with your windows process viewer.

And, then, issue:

"C:\Program Files\SABnzbd\SABnzbd-console.exe" -f "C:\SABnzbd Files\sabnzbd.ini"

Then watch the line

2020-01-11 17:05:35,137::INFO::[sabnzbdplus:1168] Using INI file /home/sander/blablabla.ini

So: "Using INI file"

jimerb
Newbie
Newbie
Posts: 2
Joined: January 11th, 2020, 9:31 am

Re: Changing the default base folder

Post by jimerb » January 11th, 2020, 12:32 pm

Ahh! Didn't realize it was running as a service. Thanks.

Day one for me... :)

Post Reply