Unable to start sabnzbd: feedparser issue

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
dma
Newbie
Newbie
Posts: 2
Joined: September 1st, 2020, 12:13 pm

Unable to start sabnzbd: feedparser issue

Post by dma »

I'm on Ubuntu running the latest SABnzbd (I just removed and reinstalled) 3.0.2 from the tarball.

I can't start it, seeing the error:
AttributeError: module 'feedparser' has no attribute '_FeedParserMixin'
i have made sure that feedparser is installed and i also don't see the attribute in the python3 repl.

could this be an issue with my version of feedparser?
$ pip3 list | ag feedparser
feedparser 6.0.0b3

dma
Newbie
Newbie
Posts: 2
Joined: September 1st, 2020, 12:13 pm

Re: Unable to start sabnzbd: feedparser issue

Post by dma »

I managed to uninstall that version and force install version 5.2.1 of feedparser. that seemed to fix it.

User avatar
safihre
Administrator
Administrator
Posts: 4283
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Unable to start sabnzbd: feedparser issue

Post by safihre »

Indeed we only support 5 in sabnzbd 3.0.2. In 3.1.0 we will also support 6.0.0. It's still in beta, so there was no rush.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

elurin
Newbie
Newbie
Posts: 9
Joined: September 14th, 2011, 5:02 pm

Re: Unable to start sabnzbd: feedparser issue

Post by elurin »

Had a similar issue as version 6 was pushed in Opensuse Tumbleweed. Opted to use 3.1.0 and it works fine.

oldozguy
Newbie
Newbie
Posts: 7
Joined: April 27th, 2017, 7:35 am

Re: Unable to start sabnzbd: feedparser issue

Post by oldozguy »

dma - please provide instructions on how to force feedparser-5.2.1 install.

I am on FreeNAS 11.3 U5, and between a rock and a hard place. Hit problems on upgrading to sabnzbd 3.0.2... which pulled in freeparser, and now I cannot recover.

pkg install sabnzbdplus wants to install the latest freeparser... which obviously is incompatible with something and triggers this error.

Any help appreciated.

rdr_than_urdad
Newbie
Newbie
Posts: 4
Joined: April 23rd, 2021, 11:29 pm

Re: Unable to start sabnzbd: feedparser issue

Post by rdr_than_urdad »

I’m also having this issue on freeNAS 11.3-U5, sabnzbd isn’t starting, sockstat doesn’t show anything on port 8080, and this was all brought on by an update.

I would also appreciate any help on how to force feedparser-5.2.1 install on FreeBSD/freeNAS

oldozguy
Newbie
Newbie
Posts: 7
Joined: April 27th, 2017, 7:35 am

Re: Unable to start sabnzbd: feedparser issue

Post by oldozguy »

safihre/admin... isn't this (I mean, retrofixing feedparser) the wrong approach? Seems to me that the package is just out of date... I don't really know who/how that gets updated, but there is clearly a need for something other than the 3.0.2 version that introduced this issue. Latest sabnzbd download version looks like 3.2.1... well past 3.0.2.

Or do we mere mortals really need to try to patch things ourselves? Not quite so easy on a NAS...

Thanks for any help... we need it!

User avatar
safihre
Administrator
Administrator
Posts: 4283
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Unable to start sabnzbd: feedparser issue

Post by safihre »

We have switched to the latest feedparser. I don't fully understand why this is suddenly a problem?
Also, why isn't the sabnzbd package just updated to the latest version? Because 3.0.2 is really old..
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

User avatar
sander
Release Testers
Release Testers
Posts: 7480
Joined: January 22nd, 2008, 2:22 pm

Re: Unable to start sabnzbd: feedparser issue

Post by sander »

safihre wrote:
April 29th, 2021, 11:15 am
We have switched to the latest feedparser. I don't fully understand why this is suddenly a problem?
Also, why isn't the sabnzbd package just updated to the latest version? Because 3.0.2 is really old..
The users are saying they are using FreeNAS. Maybe FreeNAS itself is old? https://en.wikipedia.org/wiki/TrueNAS#History tells "In March 2020, iXsystems announced that the 12.0 release will merge the FreeNAS code base with that of their commercial TrueNAS offering. FreeNAS will become TrueNAS CORE while TrueNAS will be renamed TrueNAS Enterprise.[20] This change was made official with the release of TrueNAS 12.0 on October 20, 2020"

So maybe there are no updates anymore on FreeNAS, as all updates are on TrueNAS?

oldozguy
Newbie
Newbie
Posts: 7
Joined: April 27th, 2017, 7:35 am

Re: Unable to start sabnzbd: feedparser issue

Post by oldozguy »

FreeNAS 11.3-U5 is the current non-beta release... I doubt that is the issue, as FreeNAS (I think) tracks TrueNAS pretty closely.

When I tried to track down stuff under the Downloads button, then selected Linux/FreeBSD, it appears to me that the freeBSD package for sabnzbd has not been updated correctly... or the pkg manager in freeNAS is not recognising that the update adamw made 6 months ago (refers to incompatible feedburner (not feedparser)). I'm not very cluey about this... but it looks to me like that might be where/why we are now having issues, as I believe FreeNAS is just pulling in the pkg info from the freeBSD ...er... thing!

See this link: https://svnweb.freebsd.org/ports/head/news/sabnzbdplus/

I hope this is not a red herring... as I said... I am pretty ignorant about this stuff. But happy to learn more ... and will be even happier if this resolves the problem for the many users of freeNAS ;-)

Hope it helps someone who actually knows what they are doing to figure it out !!

Cheers,

hertzsae
Newbie
Newbie
Posts: 3
Joined: March 4th, 2021, 1:20 pm

Re: Unable to start sabnzbd: feedparser issue

Post by hertzsae »

This is a FreeBSD issue, which makes it a FreeNAS/TrueNAS issue. The package needs updating. From the bug report it looks like the fix is ready and just needs to have a pull request done to get us to the latest version.

As a newish forum member, I can't post links.
If you want to watch the package, you can see it by going to freshports dot org /news/sabnzbdplus/
The bug report is at bugs dot freebsd dot org /bugzilla/show_bug.cgi?id=250411

Looks like we're waiting on someone doing a pull request, but I'm not sure where we can watch that more closely or request someone does it.

oldozguy
Newbie
Newbie
Posts: 7
Joined: April 27th, 2017, 7:35 am

Re: Unable to start sabnzbd: feedparser issue

Post by oldozguy »

Thanks hertzsae.. it does look like james or adamw need to give this a prod.

Meanwhile... I still can't download anything ;-( I tried reverting to v3.0.1, but that was successful. Maybe I screwed up...

While we wait for the freeBSD package to be updated, if anyone can advise how to reinstate the earlier version that worked... that would be nice.

Regards,

oldozguy
Newbie
Newbie
Posts: 7
Joined: April 27th, 2017, 7:35 am

Re: Unable to start sabnzbd: feedparser issue

Post by oldozguy »

Hi... I found (I think) a way to contact the adamw referred to in the bugzilla report... have sent an email asking for assistance to get this sorted.

Will advise if/when something gets fixed.

hertzsae
Newbie
Newbie
Posts: 3
Joined: March 4th, 2021, 1:20 pm

Re: Unable to start sabnzbd: feedparser issue

Post by hertzsae »

They've committed the fix, I think it takes a day or two to compile. I'm guessing that you're using the 'latest' pkg distro. Based on a comment I saw, I'm guessing that if you switched back to quarterly things should work for now until the fix gets through. I found this in a new test jail that I was building and am lucky that I haven't updated my regular jail yet.

oldozguy
Newbie
Newbie
Posts: 7
Joined: April 27th, 2017, 7:35 am

Re: Unable to start sabnzbd: feedparser issue

Post by oldozguy »

All good... pkg upgrade now installs 3.2.1 and no problems. Woohoo...

Post Reply