Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by AnonyMouse »

I'm on an install of 2.3.9. I've noticed if I manually add an NZB, using the + option, giving it a URL to retrieve, and setting category, processing, and a script, the script gets run before the processing. Is this by intent? I noticed the pop up hint says it's "post-processing", which seems like it's attempting to run that after the user script, which I think is the reverse of how nzb's are normally processed?

Anyway, this makes it less useful, since my script is pushing files to remote storage, but I was expecting the files to be unpacked first, which is what normally happens from RSS feeds or NZBs pushed from Sonarr. I haven't tried the watch folder yet to see if it happens there (I noticed this explicitly as a result of trying user post-processing scripts for the first time). I also haven't tested uploading a NZB to see if that does the same thing or not.

Is it something that is fixed/changed in 3.x? I can't control when I can upgrade, as it's being provided by my host, but it would be good to know if that's the case at least for the new version.

Thank you!

User avatar
sander
Release Testers
Release Testers
Posts: 7241
Joined: January 22nd, 2008, 2:22 pm

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by sander »

SABnzbd has Pre-queue User Scripts and Post-processings Sripts. Is it possible that you are mixing things up?

AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by AnonyMouse »

sander wrote:
October 26th, 2020, 4:36 pm
SABnzbd has Pre-queue User Scripts and Post-processings Sripts. Is it possible that you are mixing things up?
I don't think so. The options when you do a manual add are more limited. You can still select a user script, and you can still select a processing option, like you would in a category, for instance. But the pop-up tip in the manual add where you select the what would be processing in categories (download/unpack/repair/delete) specifically says "post-processing" which is always what I thought the user script was. User scripts are still listed under "scripts" as expected, but they seem to execute before processing.

I acutally have been trying a few things, and I can't get it to do any processing options at all. It doesn't want to ever unpack a manually added nzb as far as I can tell.

AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by AnonyMouse »

Image
screen cap of the add dialogs I'm talking about...I've got the pop up showing there. The dialog box on the right is the user scripts, and it shows my scripts as expected, but they seem to get run before the processing dialog. well, actually, as I said in the other post, if I don't select a script, but I do select a processing option, it still doesn't seem to do it. I end up with a bunch of rar files. I guess it could be a nested pack, though I don't think it is, and I do have the nested unpack option set. Processing works fine for things picked up in the watch folder(which I've since tested) but I don't think the NZBs have the categories set so it's not triggering my scripts, and works fine for things passed from sonarr.

Thanks!

User avatar
safihre
Administrator
Administrator
Posts: 3980
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by safihre »

Well, please update to sabnzbd 3.1.0 first.
After that, you are quite confusing me to be honest.
Will you please check in Config > Switches that you have not setup a Pre queue script? Because scripts that you select in that box are really only run after the download.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by AnonyMouse »

safihre wrote:
October 27th, 2020, 1:50 am
Well, please update to sabnzbd 3.1.0 first.
Yeah I expected that. I was able to get the provider to update, so I'm going to try the update first.
safihre wrote:
October 27th, 2020, 1:50 am
After that, you are quite confusing me to be honest.
Will you please check in Config > Switches that you have not setup a Pre queue script? Because scripts that you select in that box are really only run after the download.
Yep, I want the scripts to run after the download, this is how it happens with downloads queued via API. I'll check switches, but if it's not something that is set by default, I haven't toggled it, this particular install is only a couple days old. I never had occasion to try adding a nzb by hand this way before now, so it's possible it's always that way, and I just didn't know.

Anyway, what I'm observing that is confusing is I thought the order of operations would be:
  1. Sab downloads.
  2. Sab executes "Processing" box, which I usually have set to "+Delete"
  3. Sab execute selected user script, which for me is what pushes the result of the download to my storage target.
This is how it works when the nzb file is picked up from the watch folder, or submitted via API (from sonarr), how it's setup with my Categories for instance. I thought it would work the same for a manually added download, via the "Add NZB" button, but it doesn't appear to.

When I was submitting the file from the queue/history screen by hand, the order of operations appeared to be:
  1. Sab downloads
  2. User Script (if specified) runs
I think this is what happens because downloads would get pushed to my storage, but they are never unpacked, when I submit the nzb this way. It's all the rar and par files. Nothing is unpacked.

If I didn't specify a user processing script, so that the download isn't pushed to my storage, but I did still specify processing to be "+Delete", I'd just end up with the par and rar files sitting in the download folder. So the processing never seemed to get run from a manually added nzb.

In any event, I will upgrade the install, and see if the issue persists, and follow up here.

Thank you!

User avatar
safihre
Administrator
Administrator
Posts: 3980
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by safihre »

Sounds almost like maybe your job is added to a category that does not have +Delete set.
Can you check if all your Categories have their Post-processing set to +Delete OR Default?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by AnonyMouse »

Can you check if all your Categories have their Post-processing set to +Delete OR Default?
Sure, checked it, and it is set. You can also set these when you add the nzb manually, I would have assumed they'd override the default setting, but in any case, I was setting them to the same thing the category had, so it shouldn't matter.
Image


I've reteseted and it is still not unpacking. Does this unpack for other people? That's fine if it's something I'm doing wrong and I can just change whatever is making it do this. I did 2 tests, in the first, I uploaded by pasting a link to to NZB for sab to retrieve. In the second, I downloaded the nzb myself, and dropped it in the watch folder. Test 1 failed to unpack, test 2 unpacked just fine. These are the settings I used for test 1:
Image

Actually, I just realized from my screenshot I didn't set my user script in test 1. Which is fine, I wanted the files to remain local to sab, I still expected them to unpack since I set +Delete, but they did not. The wording on "Add NZB" is a little confusing, so let me be sure: If a Script is specified, it doesn't run until after the "Post processing" option happens (the +Delete in the screenshot)? This is how it happens at the categories level, which is what I expect (I want the result of the download/unpack before my script is run).

Thank you for the help!

User avatar
safihre
Administrator
Administrator
Posts: 3980
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by safihre »

Just to be sure, can you try a different browser that doesn't have Lastpass or any browser extensions installed?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Re: Sab 2.3.9: Manual added nzb doesn't run processing before pp script

Post by AnonyMouse »

safihre wrote:
October 28th, 2020, 2:38 pm
Just to be sure, can you try a different browser that doesn't have Lastpass or any browser extensions installed?
I'll start one up in a safe mode or something and report back...I don't think I have any browsers that don't have at least Lastpass and uBlock.

Post Reply