SAB not starting anymore? [Ubuntu]

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
breedingh8
Newbie
Newbie
Posts: 7
Joined: February 24th, 2010, 7:57 pm

SAB not starting anymore? [Ubuntu]

Post by breedingh8 »

OK I was 'away' for awhile, I had to setup my network again, servers etc. sab let me login in at first but was giving me the 503? cherrypy errors.
I backed up ~/.sabnzbd and removed SAB via apt BTW this is on Ubuntu 18.04 and re-addded repo's and reinstalled.
when I started SAB the wizard ran, I replaced ~/.sabnzbd with the old one and now it's not starting at all and there's no service in /etc/default
any help on getting it working again without having to re-wizard would be exceptional here is the output from systemctl after trying a service start

● sabnzbdplus.service - Sabnzbd
Loaded: loaded (/etc/systemd/system/sabnzbdplus.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2021-02-13 18:27:40 UTC; 10s ago
Process: 16567 ExecStart=/usr/bin/python /usr/bin/sabnzbdplus --config-file /usr/share/sabnzbdplus/sabnzbdplus.ini --logging 1 --daemon --browser 1 (code=e

Feb 13 18:27:40 server01 systemd[1]: sabnzbdplus.service: Service hold-off time over, scheduling restart.
Feb 13 18:27:40 server01 systemd[1]: sabnzbdplus.service: Scheduled restart job, restart counter is at 5.
Feb 13 18:27:40 server01 systemd[1]: Stopped Sabnzbd.
Feb 13 18:27:40 server01 systemd[1]: sabnzbdplus.service: Start request repeated too quickly.
Feb 13 18:27:40 server01 systemd[1]: sabnzbdplus.service: Failed with result 'exit-code'.
Feb 13 18:27:40 server01 systemd[1]: Failed to start Sabnzbd.


- Unit sabnzbdplus.service has finished shutting down.
Feb 13 18:29:07 server01 systemd[1]: sabnzbdplus.service: Start request repeated too quickly.
Feb 13 18:29:07 server01 systemd[1]: sabnzbdplus.service: Failed with result 'exit-code'.
Feb 13 18:29:07 server01 systemd[1]: Failed to start Sabnzbd.
-- Subject: Unit sabnzbdplus.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- Unit sabnzbdplus.service has failed.

let me know what else you need thanks

breedingh8
Newbie
Newbie
Posts: 7
Joined: February 24th, 2010, 7:57 pm

Re: SAB not starting anymore?

Post by breedingh8 »

Sorry heres the rest

- Unit sabnzbdplus.service has begun starting up.
Feb 13 18:29:07 server01 python[16731]: File "/usr/bin/sabnzbdplus", line 130
Feb 13 18:29:07 server01 python[16731]: self._size: int = size
Feb 13 18:29:07 server01 python[16731]: ^
Feb 13 18:29:07 server01 python[16731]: SyntaxError: invalid syntax
Feb 13 18:29:07 server01 systemd[1]: sabnzbdplus.service: Control process exited, code=exited status=1
Feb 13 18:29:07 server01 systemd[1]: sabnzbdplus.service: Failed with result 'exit-code'.
Feb 13 18:29:07 server01 systemd[1]: Failed to start Sabnzbd.
-- Subject: Unit sabnzbdplus.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- Unit sabnzbdplus.service has failed.

User avatar
jcfp
Release Testers
Release Testers
Posts: 891
Joined: February 7th, 2008, 12:45 pm

Re: SAB not starting anymore?

Post by jcfp »

Looks like you installed a broken systemd service of some kind in /etc/systemd/system/sabnzbdplus.service.

Packages (from both ppa and official ubuntu repos) still only ship an init.d script which works fine. Use that if you can; you will have to remove the native systemd service file first though or systemd will always go with that no matter how broken the thing is.

sinetheta
Newbie
Newbie
Posts: 1
Joined: February 19th, 2021, 1:19 pm

Re: SAB not starting anymore? [Ubuntu]

Post by sinetheta »

Hey I had the same problem. I don't remember where I got that systemd service entry but the problem is trying to run a python 3 script with your default system's python 2.

Code: Select all

ExecStart=/usr/bin/python /usr/bin/sabnzbdplus --config-file /usr/share/sabnzbdplus/sabnzbdplus.ini --logging 1 --daemon --browser 1
Just drop the `/usr/bin/python` and you'll be fine.

Code: Select all

ExecStart=/usr/bin/sabnzbdplus --config-file /usr/share/sabnzbdplus/sabnzbdplus.ini --logging 1 --daemon --browser 1

Post Reply