Page 1 of 1

Postpocess fail

Posted: April 7th, 2021, 1:57 pm
by Mue
Hello, I recently had a problem with a postprocess script. Otherwise it always ran perfectly, since a few weeks the error message has been appearing:

fatal: not a git repository (or any of the parent directories): .git Changing to directory: /var/packages/sabnzbd/scripts/nzbToMedia-12.1.08 - Cleaning bytecode - WARNING: Automatic cleanup could not be executed. If errors occur, manual cleanup may be required. REASON: Error Code: 128 Directory is not a git repository Force cleaning folder: libs Skipping required subfolders ['common', 'custom', 'py2', 'win'] Force cleaning folder: core Skipping required subfolders ['auto_process', 'extractor', 'plugins', 'utils'] Returning to directory: / volume1 / @ appstore / sabnzbd / share / SABnzbd - Cleanup finished - Traceback (most recent call last): File "/var/packages/sabnzbd/scripts/nzbToMedia-12.1.08/nzbToSickBeard.py", line 273, in <module> result = nzbToMedia.main (sys.argv, section) File "/var/packages/sabnzbd/scripts/nzbToMedia-12.1.08/nzbToMedia.py", line 885, in main core.initialize (section) File "/var/packages/sabnzbd/scripts/nzbToMedia-12.1.08/core/__init__.py", line 1024, in initialize configure_migration () File "/var/packages/sabnzbd/scripts/nzbToMedia-12.1.08/core/__init__.py", line 339, in configure_migration if not config.migrate (): File "/var/packages/sabnzbd/scripts/nzbToMedia-12.1.08/core/configuration.py", line 257, in migrate CFG_NEW.write () File "/var/packages/sabnzbd/scripts/nzbToMedia-12.1.08/libs/common/configobj/__init__.py", line 2098, in write with open (self.filename, 'wb') as h: PermissionError: [Errno 13] Permission denied: '/var/packages/sabnzbd/scripts/nzbToMedia-12.1.08/autoProcessMedia.cfg'

I have a disk station and loaded the latest Sabnzbd from the synocommunity on it. I also checked the authorizations today, Sabnzbd has read and write rights. I hope someone can help me.

Re: Postpocess fail

Posted: April 7th, 2021, 2:20 pm
by sander
Which postprocessing script are you calling?! It looks it has git commands in it. If so: not good.

Re: Postpocess fail

Posted: April 7th, 2021, 5:28 pm
by Mue
I'm using the nzbToMedia script. Why is it not good?

Re: Postpocess fail

Posted: April 7th, 2021, 11:03 pm
by sander
Mue wrote:
April 7th, 2021, 5:28 pm
I'm using the nzbToMedia script.
Maybe better if you report your problem at the makers of nzbToMedia?

Re: Postpocess fail

Posted: April 8th, 2021, 2:20 am
by Mue
OK, I'll try it.