I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the erro

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the erro

Post by loopdemack »

I was sticking to the PLUSH webinterface as long as I could, and now when there is no option for plush, I cant get around the error, I updated to latest python 3.9. I use only https access, http is disabled.
[21/Sep/2021:11:57:37] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/cherrypy/wsgiserver/__init__.py", line 2021, in start
self.tick()
File "/usr/lib/python3/dist-packages/cherrypy/wsgiserver/__init__.py", line 2090, in tick
s, ssl_env = self.ssl_adapter.wrap(s)
File "/usr/lib/python3/dist-packages/cherrypy/wsgiserver/ssl_builtin.py", line 67, in wrap
server_side=True)
File "/usr/lib/python3.6/ssl.py", line 407, in wrap_socket
_context=self, _session=session)
File "/usr/lib/python3.6/ssl.py", line 817, in __init__
self.do_handshake()
File "/usr/lib/python3.6/ssl.py", line 1077, in do_handshake
self._sslobj.do_handshake()
File "/usr/lib/python3.6/ssl.py", line 689, in do_handshake
self._sslobj.do_handshake()
OSError: [Errno 0] Error
I updated to python 3.9
python --version
Python 2.7.17
python3 --version
Python 3.6.9
python3.9 --version
Python 3.9.7
Seems that even after python 3.9 update, sab is still using older Python 3.6. Is there a way to instruct sabnzbd to use Python 3.9 or is there a way to overcome this issue?

User avatar
sander
Release Testers
Release Testers
Posts: 7706
Joined: January 22nd, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by sander »

I'm confused:
What does Plush have to do with error message you show, and with the Python version?

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

Plush is no longer option in sab, and with latest version Glitter webinterface is the only option, and I don't want permanent error. Seems I collected unintentional sabnzbd update and now I'm stuck with Glitter and this error.

After adding the alternate for python now I cant even start sabnzbd

# sudo update-alternatives --config python3
update-alternatives: error: no alternatives for python3
# sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 1
update-alternatives: using /usr/bin/python3.6 to provide /usr/bin/python3 (python3) in auto mode
# sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.9 2
update-alternatives: using /usr/bin/python3.9 to provide /usr/bin/python3 (python3) in auto mode
# sudo update-alternatives --config python3
There are 2 choices for the alternative python3 (providing /usr/bin/python3).

Selection Path Priority Status
------------------------------------------------------------
* 0 /usr/bin/python3.9 2 auto mode
1 /usr/bin/python3.6 1 manual mode
2 /usr/bin/python3.9 2 manual mode

Press <enter> to keep the current choice[*], or type selection number: 2
# sudo service sabnzbdplus restart
Job for sabnzbdplus.service failed because the control process exited with error code.
See "systemctl status sabnzbdplus.service" and "journalctl -xe" for details.
# sudo service sabnzbdplus stop
# sudo service sabnzbdplus start
Job for sabnzbdplus.service failed because the control process exited with error code.
See "systemctl status sabnzbdplus.service" and "journalctl -xe" for details.
# systemctl status sabnzbdplus.service
● sabnzbdplus.service - LSB: SABnzbd+ binary newsgrabber
Loaded: loaded (/etc/init.d/sabnzbdplus; generated)
Active: failed (Result: exit-code) since Tue 2021-09-21 12:23:59 CEST; 18s ago
Docs: man:systemd-sysv-generator(8)
Process: 9724 ExecStop=/etc/init.d/sabnzbdplus stop (code=exited, status=0/SUCCESS)
Process: 9804 ExecStart=/etc/init.d/sabnzbdplus start (code=exited, status=1/FAILURE)

sabnzbdplus[9804]: Traceback (most recent call last):
sabnzbdplus[9804]: File "/usr/bin/sabnzbdplus", line 44, in <module>
hq3 sabnzbdplus[9804]: import feedparser
sabnzbdplus[9804]: File "/usr/lib/python3/dist-packages/feedparser.py", line 93, in <module>
sabnzbdplus[9804]: _base64decode = getattr(base64, 'decodebytes', base64.decodestring)
sabnzbdplus[9804]: AttributeError: module 'base64' has no attribute 'decodestring'
sabnzbdplus[9804]: ...fail!
systemd[1]: sabnzbdplus.service: Control process exited, code=exited status=1
systemd[1]: sabnzbdplus.service: Failed with result 'exit-code'.
systemd[1]: Failed to start LSB: SABnzbd+ binary newsgrabber.

User avatar
sander
Release Testers
Release Testers
Posts: 7706
Joined: January 22nd, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by sander »

I still don't understand what Plush has to with your python version nor your error message. Glitter does not have to do SSL errors.

* SABnzbd requires Python 3.6. No need for Python 3.9
* I can't help with and would advice against upgrading to Python 3.9 on Linux. I can't help with python problems if did a python upgrade and that is causing problems
* SABnzbd 3.4.0 only has Glitter
* you can instruct your Linux to install a specific version of SABnzbd. Google "ubuntu install specific version of package"

So ... what do you want?

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

Wait, Safihre gave advice in few threads that we install Python 3.9 to fix this error I posted in the first post, in which bugs were fixed and even said about adding PPA repository, now this sudden switch and its not anymore advice ? I added ppa:deadsnakes/ppa
Should I uninstall python3.9 python3.9-venv and python3.9-dev?

I don't want to see this ENGINE Error in HTTPServer.tick Traceback error in sab. I had this error before I installed python 3.9.
How to fix it?

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

Also I installed alternate paths for python I can switch paths with
sudo update-alternatives --config python3

1 /usr/bin/python3.6 1 manual mode
2 /usr/bin/python3.9 2 manual mode

I'm now in mode 1 and I can start sabnzbd but I still have error in webinterface?
ENGINE Error in HTTPServer.tick
Traceback (most recent call last):

User avatar
sander
Release Testers
Release Testers
Posts: 7706
Joined: January 22nd, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by sander »

Safihre gave advice in few threads that we install Python 3.9 to fix this error I posted in the first post
Can you post the URL to that thread?
I don't want to see this ENGINE Error in HTTPServer.tick Traceback error in sab
Clear. Workaround: uncheck "Enable HTTPS" in SABnzbd. Also, see the warning at that option: "Modern web browsers and other clients will not accept self-signed certificates and will give a warning and/or won't connect at all."

In the meantime I did some work: I can reproduce on Ubuntu 18.04. See https://github.com/sabnzbd/sabnzbd/issues/1950

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

I enabled https because I had 20000 http hack attempts and seems few successful, they just added some garbage nothing important, when I disabled http and enabled https it stopped. Its was an know issue from last year. I need webinterface on the internet its not used locally.

User avatar
sander
Release Testers
Release Testers
Posts: 7706
Joined: January 22nd, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by sander »

You didn't answer my first question. Pity.

I don't think I can make you happy, so I'll leave it to this.

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

sander wrote:
September 21st, 2021, 8:29 am
You didn't answer my first question. Pity.

I don't think I can make you happy, so I'll leave it to this.
First question, you mean links to threads, I think it was several I also saw you in those threads.
I closed them let me check in the history.

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

It was about ancient CherryPy and that bugs were fixed in python 3.8 and 3.9.
I just cant find it again I will try even deeply to search again thread I mentioned, maybe it was on github.

I use letsencrypt SSL certificates but not for the domain but for the registered IP.

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

safihre wrote:
December 4th, 2020, 3:06 pm
This is a different problem:
viewtopic.php?f=2&t=24900
It is a bug in Python which is fixed in the latest Python 3.8 and 3.9
I found one I will post when I find other two posts.

loopdemack
Newbie
Newbie
Posts: 46
Joined: April 26th, 2008, 2:22 pm

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by loopdemack »

Ok if there is no fix could in the next sab we get the option not to show this error, because every 5-10 seconds after I remove the error if I download something error is back.

User avatar
safihre
Administrator
Administrator
Posts: 4470
Joined: April 30th, 2015, 7:35 am
Contact:

Re: I was sticking to PLUSH webinterface as long as I could now when there is no option for plush I cant get around the

Post by safihre »

The error is fixed in Python 3.9, it's not a SABnzbd thing but a Python-problem.
We also don't choose which Python to use, that's what you do when running SABnzbd.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

Post Reply