Running as service, how to stop the web gui loading at startup? [Solved]

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
zonky
Newbie
Newbie
Posts: 10
Joined: February 13th, 2008, 8:58 pm

Running as service, how to stop the web gui loading at startup? [Solved]

Post by zonky »

I run the .exe as a service, and this works fine. However, firefox.exe is being loaded as well, i assume to being the default www handler.

I assume this is because when you run sabnzbd.exe, it also fires up the gui via a browser.

Is there anyway to supress this behaviour at startup? I don't want or need firefox running and taking up memory.
Last edited by zonky on February 13th, 2008, 9:10 pm, edited 1 time in total.

zonky
Newbie
Newbie
Posts: 10
Joined: February 13th, 2008, 8:58 pm

Re: Running as service, how to stop the web gui loading at startup?

Post by zonky »

OOps, so i need to add to the launch paramaters: -b 0

http://sabnzbdplus.wiki.sourceforge.net ... parameters

User avatar
shypike
Administrator
Administrator
Posts: 21043
Joined: January 18th, 2008, 12:49 pm

Re: Running as service, how to stop the web gui loading at startup? [Solved]

Post by shypike »

BTW you should use SABnzbd-console.exe and not SABnzbd.exe when running as a service.
SABnzbd.exe will be terminated as soon as you log out, SABnzbd-console.exe will not.

jeff_porter
Newbie
Newbie
Posts: 25
Joined: February 13th, 2008, 5:02 pm

Re: Running as service, how to stop the web gui loading at startup? [Solved]

Post by jeff_porter »

thanks for the tips guys.

;D

zonky
Newbie
Newbie
Posts: 10
Joined: February 13th, 2008, 8:58 pm

Re: Running as service, how to stop the web gui loading at startup? [Solved]

Post by zonky »

Admittidly, i am running the service with an created sabnzbd user account, not the system process.

But when no user is logged in the service does run.

I'm using XYNTservice to wrap the executable

http://www.codeproject.com/KB/system/xyntservice.aspx

& here is my xyntservice.ini

Code: Select all

[Settings] 
ServiceName=SABnzbdService 
CheckProcessSeconds = 60  
[Process0] 
CommandLine = C:\Program Files\SABnzbd\0.3.1\SABnzbd.exe -b 0
WorkingDir= C:\Program Files\SABnzbd\0.3.1 
PauseStart= 5000  
PauseEnd= 5000  
UserInterface = Yes  
Restart = Yes  

Post Reply