SABnzbd not closing connections..

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
JPL4
Newbie
Newbie
Posts: 7
Joined: March 25th, 2010, 3:31 pm

SABnzbd not closing connections..

Post by JPL4 » October 24th, 2010, 2:30 am

After many frustrating weeks of Sab closing itself down on my QNAP 509 I finally decided to get to the bottom of what was going on. Initially I thought it would be a simple fix maybe an update, reinstall, qnap firmware but this hole kept going and here is what I've got.

Sab seemed to shut down at random. This would happen in the paused state on a daily basis with no apparent reasons. Looking in the Sab errlog I found a errno 24 "too many files open". After googling this it seemed to be a Ubuntu os issue as (i think in this forum) someone pointed out. Being unfamiliar with linux I searched on and found that I could list my open files using ssh lsof in hopes that it would explain where all these files may be coming from. Had to install OptiPKG (QNAP).. What I found had little to do with the OS and much to do with Sab itself. Hundreds of CLOSE_WAIT connections: SABnzbd.p  5040 admin  848u    IPv4      47138      0t0        TCP STRA-QNAP:****->h91.131.***.***.static.ip.windstream.net:63456 (CLOSE_WAIT)

I then did a netstat -n and once again a wall of tcp local address --> foreign address STATE: (CLOSE_WAIT)

I dont know what changed. I have been using Sabnzbd on this box for almost 2 years without error. Why would Sab not be terminating my connections? Please Help..

User avatar
shypike
Administrator
Administrator
Posts: 21039
Joined: January 18th, 2008, 12:49 pm

Re: SABnzbd not closing connections..

Post by shypike » October 24th, 2010, 2:54 pm

I'm not aware of any changes in socket handling that explain this.
Since which release do you notice this.
Were there any changes in the operating system, Python etc. ?
Any idea if the socket are from the internal webserver or the Usenet servers?
How is "Config->Switches->Disconnect on empty queue" set?
Do you see many disconnect warnings?

JPL4
Newbie
Newbie
Posts: 7
Joined: March 25th, 2010, 3:31 pm

Re: SABnzbd not closing connections..

Post by JPL4 » November 8th, 2010, 6:01 pm

The connections I was seeing was to my office.. SABconnect chrome extension seemed to be holding on but still SAB couldnt shut them down. ended up disabling all the options in my Bonjour tab under Network Discovery Services in the QNAP admin GUI.. All is good again..

Post Reply