Language setup in SABnzbd 0.6.0

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
sacii
Newbie
Newbie
Posts: 17
Joined: January 4th, 2011, 10:37 am

Language setup in SABnzbd 0.6.0

Post by sacii »

I have successfully setup SABnzbd 0.6.0 to run on FreeNAS 7.2 / FreeBSD 7.3, however, the Language option under General Configuration is empty. Additionally, the Quick Start Wizard did not have any language choices either. Everything else is working perfectly. I did run make_mo.py after copying the source code to my system and it appeared to run normally.

Previous versions of SABnzbd had a language directory that provided language options if properly symbolically linked (ln -s /usr/local/share/sabnzbdplus/language /usr/local/bin/language). However, SABnzbd 0.6.0 does not have a language directory. Is it possible the language directory is somehow missing from the latest download? I have downloaded the file more than once to check. Is it possible that a different directory within the SABnzbd 0.6.0 file hierarchy now needs to be symbolically linked to fix this problem?

Thanks in advance to anyone who can help me.

User avatar
shypike
Administrator
Administrator
Posts: 21043
Joined: January 18th, 2008, 12:49 pm

Re: Language setup in SABnzbd 0.6.0

Post by shypike »

The translation must be in the "locale" subfolder.
Like this: locale\XX\LC_MESSAGES\SABnzbd.mo

sacii
Newbie
Newbie
Posts: 17
Joined: January 4th, 2011, 10:37 am

Re: Language setup in SABnzbd 0.6.0

Post by sacii »

You are correct, a symbolic link to the locale directory and a restart of SABnzbd+ fixes everything.

Thank you!
Last edited by sacii on May 13th, 2011, 2:42 pm, edited 1 time in total.

Post Reply