Page 1 of 1

AttributeError in log and error log

Posted: October 3rd, 2018, 1:25 pm
by spec1alk
I see the error "AttributeError: 'bool' object has no attribute 'filename'" in my error log.
I also see the error "AttributeError: 'module' object has no attribute 'exc_value'" in my sabnzbd.log file.
Any idea what is causing these?

I tried to add a pastebin, but I can't post links (being a new user). I also tried to paste the errors into this message wrapped in 'code' tags, but the error logs seem to be identified as links...

Re: AttributeError in log and error log

Posted: October 3rd, 2018, 1:26 pm
by spec1alk
FWIW, the error log pastebin is 'L88C6jtN' and the excerpts from the log with errors are in pastebin 'qA6P3FDj'.

Re: AttributeError in log and error log

Posted: October 3rd, 2018, 1:28 pm
by spec1alk
I also forgot to add, I am running version 2.3.4 [2a113f7] on FreeBSD 11.2 (FreeNAS 11.2 BETA3).

Re: AttributeError in log and error log

Posted: October 3rd, 2018, 11:19 pm
by sander
Same error in the past on https://github.com/sabnzbd/sabnzbd/issues/1034

Can you post the sabnzbd.log before the crash?

Re: AttributeError in log and error log

Posted: October 4th, 2018, 6:31 am
by safihre
It seems your database is being locked somehow.
The other one should be fixed with an update to 2.3.5.

Re: AttributeError in log and error log

Posted: October 4th, 2018, 6:37 pm
by spec1alk
sander wrote:
October 3rd, 2018, 11:19 pm
Same error in the past on https://github.com/sabnzbd/sabnzbd/issues/1034

Can you post the sabnzbd.log before the crash?
Sure, here is a sanitized log file: https://pastebin.com/ufSg36BP
safihre wrote:
October 4th, 2018, 6:31 am
It seems your database is being locked somehow.
The other one should be fixed with an update to 2.3.5.
Good to know. Not sure how often it is updated. I would rather wait for FreeBSD/FreeNAS to update the version rather than trying to update it myself. I will ask around on the FreeNAS forum how this is handled.