Server password in clear text

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
emulink
Newbie
Newbie
Posts: 2
Joined: September 2nd, 2018, 10:30 am

Server password in clear text

Post by emulink » September 2nd, 2018, 10:44 am

Hi,

Since I get an error 500 using the search function on the forum, I do not know if this has been discussed or not: when adding a server, SabNZB requests a password. When I fill it in, it is in clear text. Would it be possible to have a checkbox next to it, to "censor" the content I fill in? I usually use SabNZB to introduce new people to Usenet and I do not want them to know my password.

I think that it probably has been done so, to prevent Chrome / Firefox to remember the passwords.

User avatar
safihre
Administrator
Administrator
Posts: 2816
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Server password in clear text

Post by safihre » September 3rd, 2018, 1:42 am

Yes indeed, it's top stop Chrome/FF/LastPass from storing the password.
We had many many many many users where the browser auto-filled usenet-passwords as their SABnzbd-main password.
You can request this feature on GitHub: https://github.com/sabnzbd/sabnzbd/issues

emulink
Newbie
Newbie
Posts: 2
Joined: September 2nd, 2018, 10:30 am

Re: Server password in clear text

Post by emulink » September 8th, 2018, 6:28 am

Thanks, I will check it out!

Post Reply