ENGINE Error in HTTPServer.tick

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
User avatar
.maxx
Release Testers
Release Testers
Posts: 85
Joined: April 10th, 2008, 6:32 am

ENGINE Error in HTTPServer.tick

Post by .maxx » October 8th, 2018, 5:59 am

Get this error nearly monthly:

I'm on:
macOS 10.14
sabnzb: v. 2.3.5 [76c7a6c]
Python Version: 2.7.15 (default, Aug 22 2018, 16:41:11) [GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.42.1)] [UTF-8]
OpenSSL: OpenSSL 1.0.2p 14 Aug 2018

Code: Select all

vor 18 Minuten [08/Oct/2018:12:38:17] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
  File "cherrypy/wsgiserver/__init__.pyc", line 2025, in start
  File "cherrypy/wsgiserver/__init__.pyc", line 2092, in tick
  File "cherrypy/wsgiserver/ssl_builtin.pyc", line 67, in wrap
  File "ssl.pyc", line 369, in wrap_socket
  File "ssl.pyc", line 596, in __init__
  File "socket.pyc", line 228, in meth
error: [Errno 22] Invalid argument

User avatar
safihre
Administrator
Administrator
Posts: 3425
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: ENGINE Error in HTTPServer.tick

Post by safihre » October 8th, 2018, 6:39 am

It seems you are still the only one: viewtopic.php?t=22542 :P

Do you use HTTPS to access the interface?

User avatar
.maxx
Release Testers
Release Testers
Posts: 85
Joined: April 10th, 2008, 6:32 am

Re: ENGINE Error in HTTPServer.tick

Post by .maxx » October 11th, 2018, 7:52 am

safihre wrote:
October 8th, 2018, 6:39 am
It seems you are still the only one: viewtopic.php?t=22542 :P

Do you use HTTPS to access the interface?
yes, I do

User avatar
.maxx
Release Testers
Release Testers
Posts: 85
Joined: April 10th, 2008, 6:32 am

Re: ENGINE Error in HTTPServer.tick

Post by .maxx » March 8th, 2019, 3:04 am

Hey @safihre, any updates on this?
This error comes more and more often and is very annoying.

User avatar
safihre
Administrator
Administrator
Posts: 3425
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: ENGINE Error in HTTPServer.tick

Post by safihre » March 8th, 2019, 7:48 am

I hope it might be gone when we switch to Python 3!

User avatar
LapinFou
Jr. Member
Jr. Member
Posts: 82
Joined: April 23rd, 2012, 7:35 am
Location: France, Caen

Re: ENGINE Error in HTTPServer.tick

Post by LapinFou » May 21st, 2019, 8:45 am

You are not alone !! :)
I got the same issue with SABnzbd running on my Synology NAS.
And yes, I'm also using a "Let's Encrypt" SSL connection:

Code: Select all

[21/May/2019:15:34:36] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
  File "/volume1/@appstore/sabnzbd/share/SABnzbd/cherrypy/wsgiserver/__init__.py", line 2025, in start self.tick()
  File "/volume1/@appstore/sabnzbd/share/SABnzbd/cherrypy/wsgiserver/__init__.py", line 2092, in tick s, ssl_env = self.ssl_adapter.wrap(s)
  File "/volume1/@appstore/sabnzbd/share/SABnzbd/cherrypy/wsgiserver/ssl_builtin.py", line 107, in wrap return s, self.get_environ(s)
  File "/volume1/@appstore/sabnzbd/share/SABnzbd/cherrypy/wsgiserver/ssl_builtin.py", line 116, in get_environ 'SSL_PROTOCOL': cipher[1],
TypeError: 'NoneType' object has no attribute '__getitem__'
Synology NAS DS916+ DSM 6.2.2-24922
Version: 2.3.8 [0dd1f64]
Python Version: 2.7.14 (default, May 28 2018, 14:47:18) [GCC 4.7.3 20130102 (prerelease)] [UTF-8]
OpenSSL: OpenSSL 1.0.2n 7 Dec 2017
Synology Model: DS-411+
Firmware Version: DSM 5.2-5592
HDD Model: 4xSeagate ST2000DL003 2To - SHR

How to fix foreign accents issue with SABnzbd
Corriger Les Problème D'accents Sous Sabnzbd

astr0b0y
Newbie
Newbie
Posts: 5
Joined: September 7th, 2009, 5:45 pm

Re: ENGINE Error in HTTPServer.tick

Post by astr0b0y » December 7th, 2019, 5:57 am

Same issue for me, been happening for a couple of years. MacOS 10.14.

Post Reply