Sabnzbd won`t work

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
bbbb1969
Newbie
Newbie
Posts: 4
Joined: October 9th, 2017, 9:20 am

Sabnzbd won`t work

Post by bbbb1969 » October 9th, 2017, 9:26 am

Hello.

I have been using Sabnzbd a long time, but now it won`t work anymore.

Getting this error when clicking warnings and configuration:

Unrecoverable error in the server.
Traceback (most recent call last):
File "cherrypy\_cprequest.pyo", line 589, in run
File "cherrypy\_cprequest.pyo", line 690, in respond
File "cherrypy\_cprequest.pyo", line 767, in handle_error
File "cherrypy\_cperror.pyo", line 394, in set_response
File "cherrypy\_cperror.pyo", line 400, in get_error_page
File "cherrypy\_cperror.pyo", line 537, in get_error_page
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe6 in position 1055: invalid continuation byte

I have tried several versions also some of the later ones.

I am using windows 7

User avatar
safihre
Administrator
Administrator
Posts: 2648
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Sabnzbd won`t work

Post by safihre » October 9th, 2017, 9:46 am

Are you on SABnzbd 2.3.0?
Can you restart SABnzbd? Does it work then?
Do you have any special characters in your Windows-username, for example umlauts etc?

bbbb1969
Newbie
Newbie
Posts: 4
Joined: October 9th, 2017, 9:20 am

Re: Sabnzbd won`t work

Post by bbbb1969 » October 9th, 2017, 11:58 am

i am on 2.2.0 , have tried 2.3.0 but its the same, i have no special characters in my windows-username.
i restarted SABnzb several times and my computer, still the same

User avatar
safihre
Administrator
Administrator
Posts: 2648
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Sabnzbd won`t work

Post by safihre » October 9th, 2017, 12:36 pm

I think there's something broken in the history. Can you shutdown SABnzbd, then go to (press WindowsKey+R):
%userprofile%\AppData\Local\sabnzbd\admin

And then delete "history1.db" and "queue10.sab"

Then start SABnzbd again.

bbbb1969
Newbie
Newbie
Posts: 4
Joined: October 9th, 2017, 9:20 am

Re: Sabnzbd won`t work

Post by bbbb1969 » October 10th, 2017, 2:13 am

ok, i did that and tried again, not working, i then uninstalled version 2.2.0 and installed 2.3.0
and now it works :-)

now i have another question, can i change the interface so it looks like the old one

User avatar
safihre
Administrator
Administrator
Posts: 2648
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Sabnzbd won`t work

Post by safihre » October 10th, 2017, 2:54 am

Yes, in the General page of the configuration. It's called Web interface.
Why do you prefer the old one? It hasn't been updated in years and misses features we recently introduced (like Direct Unpack).

bbbb1969
Newbie
Newbie
Posts: 4
Joined: October 9th, 2017, 9:20 am

Re: Sabnzbd won`t work

Post by bbbb1969 » October 10th, 2017, 4:15 am

its not that i dont appreciate the work that has been done, i just like things to be like they have been for a long time :-)
i hate changes

Post Reply