[SOLVED - HARDWARE] 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
jroch74
Newbie
Newbie
Posts: 11
Joined: April 3rd, 2017, 11:17 am

[SOLVED - HARDWARE] 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by jroch74 »

Hello since 2.3.3, SABnzbd crash ~ every 30 minutes
It happens with all NZB, sometimes when I resume the queue after restarting SABnzbd service, sometimes 30 minutes later

I have disabled direct extract (high CPU load) but SABnzbd still crashes
Results to a 502 bad gateway from my reverse proxy URL and a connection fail via IP:8080

Software : OpenMediaVault 4 (Debian 9 and kernel 4.9) - SABnzbd 2.3.3 - python 2.7.13 - python-sabyenc 3.3.5

I can send debug log via MP ;)
Last edited by jroch74 on May 3rd, 2018, 9:28 am, edited 1 time in total.

User avatar
sander
Release Testers
Release Testers
Posts: 7241
Joined: January 22nd, 2008, 2:22 pm

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by sander »

Open a terminal, start sabnzbdplus as a console application (not as a service), wait until crash, and post the screen log & screen shot here.

jroch74
Newbie
Newbie
Posts: 11
Joined: April 3rd, 2017, 11:17 am

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by jroch74 »

I will try this
But before I will have a look at my RAID 6 how can probably be the problem (3 resyncs in syslog today ...)
5-6 years of SAB and Plex, I think he's exhausted ^^

jroch74
Newbie
Newbie
Posts: 11
Joined: April 3rd, 2017, 11:17 am

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by jroch74 »

Not a RAID problem, same issue with my other "new" array

OOM fault, he killed SAB every time
Solved by reducing cache from 37.5% to 25% (2G instead of 3G)
Don't know why it didn't happened before 2.3.3 :-/

User avatar
sander
Release Testers
Release Testers
Posts: 7241
Joined: January 22nd, 2008, 2:22 pm

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by sander »

An OOM on a 8GB system? What else have you running? Or: what else is using your RAM?

jroch74
Newbie
Newbie
Posts: 11
Joined: April 3rd, 2017, 11:17 am

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by jroch74 »

Yes, that's very strange !
I'm still diging to see what's wrong

Plex (direct play 99% of the time)
Nginx
FTP
OpenVPN Access Server
dnsmasq

Nothing that uses a lot of RAM ...

Nothing is accessible from the outside (only OpenVPN AS and Plex), firewall and router are correctly configured
I think it comes from inside the system but I can't find what :-/

User avatar
sander
Release Testers
Release Testers
Posts: 7241
Joined: January 22nd, 2008, 2:22 pm

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by sander »

Do you have swap enabled? Check with "swapon -s".

In my experience you always need swap. Because, if(when) it is used (check with "top -bn2 | head -20") , yes, it will your system slower, but it avoids OOM crashes.

jroch74
Newbie
Newbie
Posts: 11
Joined: April 3rd, 2017, 11:17 am

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by jroch74 »

Yes, swap is enabled

I think it comes from my power supply, non stop RAID resyncing (RAID is clean and no SMART errors for each disk in the last test 10 days ago) + RAM issues + a system failure 2 days ago
I will try to replace the PS tomorow, set SAB cache to 4G and see if SAB still crashes and if my RAID stop to non stop resync
I hope it's only hardware :)

jroch74
Newbie
Newbie
Posts: 11
Joined: April 3rd, 2017, 11:17 am

Re: 2.3.3 always crash (OpenMediaVault 4 (Debian 9 ))

Post by jroch74 »

Seems that my issue is solved
System is stable with 4G cache since 6 hours after PS replacement
Really sorry for this false bug report, and thank you for your help ans tips sander :-)

Post Reply