Page 1 of 1

Ubuntu snap install just doesn't work [as OP expeceted]

Posted: May 1st, 2019, 11:24 am
by Skeo
I've just updated to ubuntu 18.04 and have tried installing sabnzbd via the snap package.
I honestly can't think of any polite way to describe the experience.
In the couple hours I've been banging my head against the wall trying to get it to work, I've come across two really obvious problems, one of which is a showstopper.

1) Because of the sandboxing, the snap package can't see other packages on the system. - In the config tab I get the message asking me to install multicore par2. I did, restart everything and the message is still there.
2) Also because of sandboxing, sabnzbd doesn't have permission to access pretty much any part of the filesystem except it's own little /var/snap/sabnzbd place. The most obvious symptom of this is I get "Cannot create download_dir folder" errors when I try and point to the folders where I have my large HDDs mounted. I can't really setup my system to work in any useful way if I can't actually specify where I want things to download to.

After a LOT of google searching, I discovered you can install a snap with a "--classic" flag to fix problems like this with permissions.
I tried that and get: "Warning: flag --classic ignored for strictly confined snap sabnzbd"

right then.

I realise this filesystem permission issue is more a snap thing and not necessarily a sabnzbd thing, but it makes trying to install via snap a complete waste of time. It would be nice if you could fix the snap package so it actually works, because there seems to be some usefulness in the automatic updating etc etc.

Until that happens, and probably forever now anyway, I'm going back to a standard install and I'd suggest you put a big warning on the website saying DONT USE THE SNAP IF YOU HAVE MORE THAN ONE HARD DRIVE IN YOUR SYSTEM.

Re: Ubuntu snap install just doesn't work

Posted: May 1st, 2019, 12:29 pm
by sander
What you describe as problems are the goals of docker and other container technologies and thus probably snap packages:

the app within the container should not be able to access the whole host system; only what you positively define as accessible.
the app within the container is self-contained
the container is "cattle, not a pet". Kill it if it doesn't work

In general, it's called "isolation".

If you don't want that or find it hard to use, don't use it.

I use Ubuntu, and I find snap horrible. I do like docker for testing purposes, but hard to use for apps with interactions.
So ... I use SABnzbd as real app on Ubuntu. Not in snap nor docker.

HTH

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: May 2nd, 2019, 1:43 am
by safihre
I'm not a snap expert. but what I was told is that you can "mount" your drive as a "media" in the snap to access them. This should work around the no-access problem.

Indeed the Snap doesn't have multicore-par2, but that's something we could add later to the snap. Although it's a bit harder due to all the platforms.

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: May 8th, 2019, 9:14 am
by Skeo
Huh, so I should have known not to bother with the brand spanking new installation format that is supposed to be amazing ... because ... it's useless by design.
And I should have known that... How?
Snap doesn't advertise any of these things, and it takes a loooooong time googling to try and find how it works detailed anywhere at all, let alone troubleshoot what you seem to think are obvious issues. And thanks for renaming my thread incorrectly, spelling mistake and all. This behaviour is not remotely "as I expected", instead it is how I found out it works after hours of investigating. Would you prefer I submitted bugs with absolutely no idea what's happening or why?

Mounting as media in the snap seems like it would indeed solve the issue, but in my hours of googling I couldn't find that mentioned anywhere, certainly not instructions on how to do it. This thread is the first I've heard of it.

As I said in my original comment, the snap install should come with serious disclaimers on the box. Something along the lines of "Don't use this. It doesn't really work and won't do what you're hoping. Especially not if you've ever used sabnzbd+ before." That should just about cover it.

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: May 8th, 2019, 10:25 am
by safihre
We don't make the snap eco-system and trust me, it was also a terrible hassle to create the snap.. Only with some of their developers helping out we managed to push something..
Anyway, maybe just use the regular Ubuntu installation we provide?

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: June 1st, 2020, 2:25 pm
by pinn
I know this is an old thread but with Sab getting frequent updates now this may be workable. Are the issues described above still there or is the experience more straight forward?

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: June 3rd, 2020, 4:05 am
by safihre
I updated the edge-snap, can you try that one and see if it works for you?
It should now also have access to your home-folder, although not sure exactly how it works.

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: June 3rd, 2020, 7:32 am
by pinn
safihre wrote:
June 3rd, 2020, 4:05 am
I updated the edge-snap, can you try that one and see if it works for you?
It should now also have access to your home-folder, although not sure exactly how it works.
Before I do, can I just ask about the built-in updater (Debian build). I note it says it checks for updates 1 a week. According to the settings, I'm on 3.0.0-develop [unknown].
Am I to assume that it will automatically update itself at some point?

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: June 3rd, 2020, 8:17 am
by safihre
Yes I think it should.

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: June 3rd, 2020, 11:22 am
by pinn
Cheers. Think I'll take the path of least resistance then :)
If it doesn't work, I'll check out snap and feedback to you

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: June 23rd, 2020, 9:18 pm
by Gorklax
Dumb question. Does the snap version just run in the background without the need to launch? If so, how do I access it? It's running on a headless server, but I can't access it via the port from another pc. The port is open in the firewalld service.

Edit: I was able to fix it by changing the listening port to my network address instead of localhost.

Re: Ubuntu snap install just doesn't work [as OP expeceted]

Posted: June 24th, 2020, 6:28 am
by safihre
Exactly, by default it runs on localhost only.